about Reload Router -Vincent (CCIE's proctor)
 
Tips for Taking the CCIE SP Lab Exam
 
 
 
Reload to Take Effect
 
Some configurations do not take effect until the relevant process is reset or the router is reloaded.
Reload is a good method of making some processes work.
For example, candidates of the CisIE® Service Provider (SP) lab exam may first be asked to configure
basic Open Shortest Path First (OSPF) between routers,
then to have each router automatically choose the loopback IP address as router ID (if there is no loopback
interface defined, then the highest interface IP address), and finally to define an exact router ID.
 
In these circumstances, the OSPF process should be cleared or the router reloaded to ensure that the new
router ID takes effect.
 


Here is an example of basic OSPF.
 
R8,
interface Loopback0
ip address 8.8.0.8 255.255.255.255
!
interface GigabitEthernet0/1
ip address 8.8.89.8 255.255.255.0
!
router ospf 100
network 8.8.0.8 0.0.0.0 area 0
network 8.8.89.8 0.0.0.0 area 0
 
R9,
interface Loopback0
ip address 8.8.0.9 255.255.255.255
!
interface GigabitEthernet0/1
ip address 8.8.89.9 255.255.255.0
!
router ospf 100
network 8.8.0.9 0.0.0.0 area 0
network 8.8.89.9 0.0.0.0 area 0
 
R8#show ip ospf
Routing Process "ospf 100" with ID 8.8.0.8
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS) Supports area transit capability

 
Here is a follow-up question asking the candidate to change the R8 OSPF router ID to 8.8.0.88.
R8,
router ospf 100
router-id 8.8.0.88
network 8.8.0.8 0.0.0.0 area 0
network 8.8.89.8 0.0.0.0 area 0
 
Finally, here is a request to reload R8 or to clear the ip ospf process to make the new router ID take effect.
R8#show ip ospf
Routing Process "ospf 100" with ID 8.8.0.88
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS) Supports area transit capability
 
 
Reload to Find a Configuration Problem
Taking the CCIE SP lab exam can be stressful, and it is possible that, under the circumstances, candidates will lose some command lines.
Reload is a good way to recover these lost command lines. For example, a question asks the candidate to configure basic Multiprotocol Label Switching (MPLS) with the designated Loopback0 interface IP address as LDP-ID. The candidate might lose the command “mpls ldp router-id Loopback0.”
Candidates can verify that Loopback0 is chosen as LDP-ID by using the command “show mpls
ldp neighbor,”
because Label Distribution Protocol (LDP) automatically chooses the Loopback0 IP address as LDP-ID.
A follow-up question might ask the candidate to add Loopback1 and to define a large-number IP address.
The router will not migrate to the new LDP-ID, but after a reload, the Loopback1 IP address will take over as the new LDP-ID. Performing a router reload will pinpoint this kind of problem.
 


Here is a basic MPLS LDP configuration.
 
R8,
mpls label protocol ldp interface GigabitEthernet0/1
ip address 8.8.89.8 255.255.255.0
mpls ip
!
 
R9,
mpls ldp router-id Loopback0
mpls label protocol ldp
!
interface GigabitEthernet0/1
ip address 8.8.89.9 255.255.255.0
mpls ip
!
 
 
Here is the verification information.
 
Rack08R8#show mpls ldp neighbor
Peer LDP Ident: 8.8.0.9:0; Local LDP Ident 8.8.0.8:0
TCP connection: 8.8.0.9.11003 - 8.8.0.8.646
State: Oper; Msgs sent/rcvd: 73814/73817; Downstream
Up time: 6w2d
LDP discovery sources:
GigabitEthernet0/1.89, Src IP addr: 8.8.89.9
Addresses bound to peer LDP Ident:
8.8.0.9        8.8.89.9
 
A follow-up question might ask the candidate to add the Loopback1 interface with the IP address
8.8.0.88 on R8 after reload.
 
R8#show mpls ldp neighbor
Peer LDP Ident: 8.8.0.9:0; Local LDP Ident 8.8.0.88:0
TCP connection: 8.8.0.9.646 - 8.8.0.88.11014
State: Oper; Msgs sent/rcvd: 8/7; Downstream
Up time: 00:00:39
LDP discovery sources:
GigabitEthernet0/1.89, Src IP addr: 8.8.89.9
Addresses bound to peer LDP Ident:
8.8.0.9        8.8.89.9
 
 
Do Not Reload Right Before the Lab Exam Ends
 
The lab exam evaluation is based on the final submission of the candidate. In other words, grading is based
on the work as it exists when the candidate leaves the lab.
As outlined in the previous scenario, some configurations might not work after a reload.
Therefore, candidates should NOT reload any devices close to the time that they will be leaving the lab, unless they are extremely confident in their work.
 
 
Ensure that the Console is Accessible After a Reload
 
Some configurations change the method of accessing the device console. For example, after the command
“aaa new-model” is defined, the router default requires a username and password to access the console.
 
If the candidate has not configured a username, password, or the command “aaa authentication login default
line/none,” then the candidate will be denied access to the console after the reload.
 
R8,
aaa new-model
enable password Cisco
!
line con 0
exec-timeout 0 0 password cisco logging synchronous
 
 
After reload, see the console prompt below. There is no username and password configured, so the candidate will not be able to enter into “>” mode.
 
User Access Verification
 
Username: