【实训背景】
企业有两个主要部门,技术部和销售部,分别在不同的办公室,为了安全和便于管理对两个部门的主机进行了VLAN的划分,技术部和销售部分处于不同的VLAN。现由于业务的需求需要销售部和技术部的主机能够相互访问,获得相应的资源,两个部门的交换机通过一台三层交换机进行了连接。
【实训目的】
掌握三层交换机基本配置方法、掌握三层交换机VLAN路由的配置方法
【技术原理】
在交换网络中,通过VLAN对一个物理网络进行了逻辑划分,不同的VLAN之间是无法直接访问的,必须通过三层的路由设备进行连接。一般利用路由器或三层交换机来实现不同VLAN之间的互相访问。三层交换机和路由器具备网络层的功能,能够根据数据的IP 包头信息,进行选路和转发,从而实现不同网段之间的访问。
直连路由是指:为三层设备的接口配置IP地址,并且激活该端口,三层设备会自动产 生该接口IP所在网段的直连路由信息。
三层交换机实现VLAN互访的原理是,利用三层交换机的路由功能,通过识别数据包 的IP地址,查找路由表进行选路转发。三层交换机利用直连路由可以实现不同VLAN之 间的互相访问。三层交换机给接口配置IP地址,采用SVI (交换虚拟接口)的方式实现 VLAN间互连。SVI是指为交换机中的VLAN创建虚拟接口,并且配置IP地址。
【实训内容】
1、按照拓扑进行网络连接
2、二层交换机配置相应VLAN和Trunk
3、配置三层交换机的路由功能
4、测试
【实现功能】
使在同一VLAN里的计算机系统能跨交换机进行相互通信,而在不同VLAN里的计算机系统也能进行相互通信。
【实训设备】
S3100(2台),S3500(1台)、直连线(4条)、PC(2台)
【实训拓扑】
设备型号
实训名称
IP地址/掩码
网关
端口连接情况
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
【主要命令】
port link-mode trunk、port access vlan id
【实训步骤】
1、在交换机( S2126A) SwitchA 上创建 Vlan 10,并将 0/1 端口划分到 Vlan 10 中。
<Quidway >
<Quidway >SYS !进入全局配置模式。
[Quidway]sysname SwitchA
[SwitchA] vlan 10 !创建 Vlan 10。
[SwitchA-vlan-10]quit
[SwitchA]interface fastethernet 0/1 !进入接口配置模式。
[SwitchA fastethernet 0/1] port access vlan 10 !将 0/1 端口划分到 Vlan 10。
[SwitchA fastethernet 0/1]quit
验证测试:验证已创建了 Vlan 10,并将 0/1 端口已划分到 Vlan 10 中。
[SwitchA]disp vlan id 10
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
10 VLAN0010 active Fa0/1
2、在交换机( S2126B) SwitchB上创建 Vlan 20,并将 0/1 端口划分到 Vlan 20 中。
<Quidway >sys!进入全局配置模式。
[Quidway]systname SwitchB
[SwitchB] vlan 20 !创建 Vlan 20。
[SwitchB –vlan20] quit
[SwitchB]interface fastethernet 0/1 !进入接口配置模式。
[SwitchB fastethernet 0/1] port access vlan 20 !将 0/1 端口划分到 Vlan 20。
[SwitchB fastethernet 0/1]quit
验证测试:验证已创建了 Vlan 20,并将 0/2 端口已划分到 Vlan 20 中。
[SwitchBdisp vlan id 20
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
20 VLAN0020 active Fa0/1
3、在交换机 SwitchA 、 SwitchB 与交换机3760( SwitchC)相连的端口(0/23、 0/24端口)定义为 tag vlan 模式。
<SwitchA>sys
[SwitchA]interface fastethernet 0/24 !进入接口配置模式。
[SwitchA- fastethernet 0/24] port link-mode trunk !将 fastethernet 0/24 端口设为 tag vlan 模式。
验证测试:验证fastethernet 0/24 端口已被设置为tag vlan模式。
[SwitchA]disp interfaces fastEthernet 0/24 switchport
Interface Switchport Mode Access Native Protected VLAN lists
---------- ---------- --------- ------- -------- --------- --------------------
Fa0/24 Enabled Trunk 1 1 Disabled All
<SwitchB>sys
[SwitchB]interface fastethernet 0/23 !进入接口配置模式。
[SwitchB- fastethernet 0/23] port link-mode trunk !将 fastethernet 0/23 端口设为 tag vlan 模式。
验证测试:验证fastethernet 0/23 端口已被设置为tag vlan模式。
[SwitchB]show interfaces fastEthernet 0/23 switchport
Interface Switchport Mode Access Native Protected VLAN lists
---------- ---------- --------- ------- -------- --------- --------------------
Fa0/23 Enabled Trunk 1 1 Disabled All
4、在交换机 SwitchC 上将与 SwitchA、 SwitchB相连的端口(0/23、 0/24 端口)定义为 tag vlan 模式。
<Quidway >sys
[Quidway]sysname SwitchC
[SwitchC]interface fastethernet 0/23 !进入接口配置模式。
[SwitchC -fastethernet 0/23] port link-mode trunk !将fastethernet 0/23端口设为tag vlan 模式。
[SwitchC]interface fastethernet 0/24 !进入接口配置模式。
[SwitchC-fastethernet 0/24]port link-mode trunk !将fastethernet 0/24端口设为tag vlan 模式。
[SwitchC]quit
验证测试:
验证 fastethernet 0/23 端口已被设置为tag vlan模式。
[Switchc]disp interfaces fastEthernet 0/23 switchport
Interface Switchport Mode Access Native Protected VLAN lists
---------- ---------- --------- -------- --------- --------------------
Fa0/23 Enabled Trunk 1 1 Disabled All
验证 fastethernet 0/24 端口已被设置为tag vlan模式。
[Switchc]disp interfaces fastEthernet 0/24 switchport
Interface Switchport Mode Access Native Protected VLAN lists
---------- ---------- --------- -------- --------- --------------------
Fa0/24 Enabled Trunk 1 1 Disabled All
5、验证 PC1 与 PC2不能互相通信。
C:\>ping 192.168.10.10 !从 PC2 ping PC1
Pinging 192.168.10.10 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 192.168.10.10:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
6、设置三层交换机 VLAN 间通讯。
在交换机 SwitchC 上创建Vlan 10、 Vlan 20 并配置IP地址
<SwitchC>sysl !进入全局配置模式。
[SwitchC] vlan 10 !创建 Vlan 10。
[SwitchC –vlan10]quit
<SwitchC>sys !进入全局配置模式。
[SwitchC] vlan 20 !创建 Vlan 20。
[SwitchC-vlan20]quit
[SwitchC]int vlan-interface 10
[Switchc-Vlan-interface10 ]ip add 192.168.10.1 255.255.255.0
[Switchc-Vlan-interface10 ]undo sh
[Switchc-Vlan-interface10 ]quit
[SwitchC]int vlan-interface 20
[Switchc-Vlan-interface20 ]ip add 192.168.20.1 255.255.255.0
[Switchc-Vlan-interface20 ]undo shutdown
[Switchc-Vlan-interface20 ]quit
[SwitchC]
7、将 PC1 和 PC2 的默认网关设置为 192.168.10.1,将 PC2 的默认网关设置为:192.168.20.1。
8、测试结果。不同 VLAN 内的主机可以互相PING通。
C:\>ping 192.168.10.10
Pinging 192.168.10.10 with 32 bytes of data:
Reply from 192.168.10.10: bytes=32 time=19ms TTL=126
Reply from 192.168.10.10: bytes=32 time=20ms TTL=126
Reply from 192.168.10.10: bytes=32 time=21ms TTL=126
Reply from 192.168.10.10: bytes=32 time=20ms TTL=126
Ping statistics for 192.168.10.10:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 19ms, Maximum = 21ms, Average = 20ms
【注意事项】
1、两台交换机之间相连的端口应该设置位tag vlan模式
2、PC需要设置网关。
【参考配置】
1、SwitchA配置
[SwitchA]disp curr
System software version : 1.66(3) Build Sep 7 2006 Rel
Building configuration...
Current configuration : 361 bytes
!
version 1.0
!
hostname SwitchA
vlan 1
!
vlan 10
!
enable secret level 1 5 $2,1u_;C3&-8U0<D4'.tj9=GQ+/7R:>H
enable secret level 14 5 'T-aeh`@3U'dfimL4^{bcknA54zyglow
enable secret level 15 5 $2.Y*T7+3,tZ[V/,4+S(\W&-Q1X)sv'~
!
interface fastEthernet 0/1
switchport access vlan 10
!
interface fastEthernet 0/24
switchport mode trunk
!
end
2、SwitchB配置
[SwitchB]disp cur
System software version : 1.66(3) Build Sep 7 2006 Rel
Building configuration...
Current configuration : 361 bytes
!
version 1.0
!
hostname SwitchB
vlan 1
!
vlan 20
!
enable secret level 1 5 $2>H.Y*T3;C,tZ[V4<D+S(\WQ=G1X)sv
enable secret level 14 5 'Ttj9=G13U7R:>H.4^u_;C,t54U0<D+S
enable secret level 15 5 $2;C,tZ[30<D+S(\49=G1X)sQ:>H.Y*T
!
interface fastEthernet 0/1
switchport access vlan 20
!
interface fastEthernet 0/23
switchport mode trunk
!
end
3、SwitchC配置
[SwitchC]disp cur
System software version : RGNOS V4.12 Build Dec 8 2006 Release
Building configuration...
Current configuration : 510 bytes
version 1.0
!
hostname SwitchC
vlan 1
!
vlan 10
!
vlan 20
!
enable secret level 1 5 $2,1u_;C3&-8U0<D4'.tj9=GQ+/7R:>H
enable secret level 14 5 'T,1u_;C3U-8U0<D4^.tj9=G54/7R:>H
enable secret level 15 5 $2H.Y*T73C,tZ[V/4D+S(\W&QG1X)sv'
!
interface FastEthernet 0/23
switchport mode trunk
!
interface FastEthernet 0/24
switchport mode trunk
!
interface Vlan 10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan 20
ip address 192.168.20.1 255.255.255.0