配置双出口实例(附图)

配置里用了策略路由与OSPF协议


路由双出口配置_职场

r1:配置如下:

interface Ethernet0/0
ip address 100.100.100.1 255.255.255.0
ip policy route-map
!
interface Serial1/0
ip address 10.10.10.1 255.255.255.0
!
interface Serial2/0
ip address 20.20.20.1 255.255.255.0
!
router ospf 1

!--- OSPF is not configured on Serial1/0.

log-adjacency-changes
network 20.20.20.0 0.0.0.255 area 0
network 100.100.100.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
access-list 100 permit ip host 100.100.100.3 host 200.200.200.4
!
route-map blah permit 10
match ip address 100
set ip default next-hop 10.10.10.2

R2:配置如下:

interface Ethernet0/0
ip address 200.200.200.2 255.255.255.0
ip policy route-map blah
!
interface Serial1/0
ip address 10.10.10.2 255.255.255.0
fair-queue
!
interface Serial2/0
ip address 20.20.20.2 255.255.255.0
!
router ospf 1

!--- OSPF is not configured on Serial1/0.

log-adjacency-changes
network 20.20.20.0 0.0.0.255 area 0
network 200.200.200.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
access-list 100 permit ip host 200.200.200.4 host 100.100.100.3
!
route-map blah permit 10
match ip address 100
set ip default next-hop 10.10.10.1