2.5 QinQ技术
QinQ即Dot1Q in Dot1Q,是一种双层VLAN TAG技术。在之前的章节我们已经学习了Trunk封装,而QinQ封装的核心理念就是再增加一层Qot1Q的封装。其示意图见图2-19,QinQ把接入运营商的用户的VLAN信息(即内层TAG)之外再增加一层TAG,内层TAG在运营商内部交换时并不被识别,运营商设备仅仅识别外层TAG即可。这一点非常类似后续我们将学习的MPLS ×××多层标签机制。
2.5.1 QinQ报文转发
读者已经意识到QinQ很多时候用于运营商场景,确实它是一种简单的L2×××(2层×××)技术,因为用户的内层标签在运营商内部被隐藏的同时还解决了在运营商网络公网VLAN数目紧缺问题,当然用户无法感知到这一点,因为客户正常的在客户端实施常规的VLAN配置即可,这一点也类似于MPLS ×××技术。
乾颐堂安德HCIE章节:QinQ技术原理和实现实现
图2-19 QinQ报文封装示意图
QinQ报文转发示意图如图2-20所示:1)客户的PC通过交换机A的接入端口被增加PVID(200-300 VLAN中的某一个) 2)交换机A连接交换机B的接口实施常规的Trunk,并不做修改的把携带VLAN TAG的帧转发到交换机B;3)交换机B连接客户的交换接口为QinQ模式同时指定默认VLAN为3,此时增加了一层VLAN TAG;4)在运营商内部通过外层TAG中的VLAN ID3交换真帧 5)交换机C连接客户的接口和步骤3中的交换机B配置相同,会去掉外层TAG,把常规的客户的DoT1Q帧发送出去;6)客户侧交换机D连接运营商的接口为常规的Trunk配置,接收来自运营商一侧的原始的DoT1Q帧;7)交换机D连接终端的接口为常规接入接口,去掉VLAN TAG,把原始帧发送给终端PC。
乾颐堂安德HCIE章节:QinQ技术原理和实现实现
图2-20 QinQ转发报文示意图
QinQ技术在华为设备上实现还有灵活配置模式,该模式并不在本书讨论之列,QinQ在现网中多和交换机子接口VLAN终结以及VPLS(运营商流行的2层×××技术)合用。
2.5.2 QinQ实现案例
一.拓扑图
如图2-21所示,SW1和SW4为客户端接入专线的设备,通过运营商SW2和SW3实施QinQ来转发PC1到PC2的VLAN内部的流量。
乾颐堂安德HCIE章节:QinQ技术原理和实现实现
图2-21 QinQ技术拓扑图
二.需求和目的
实验目的:掌握QinQ的实施以及理解QinQ中报文的转发过程
需求1.客户端VLAN内的流量可以通过运营商转发到另一站点
需求2.转去QinQ承载流量的报文并进一步认识QinQ
三.实验步骤
1.配置客户站点交换机的VLAN并实施对应的trunk和接入接口
SW1的实施:
[SW1-Client]vlan batch 200 300 //在交换机1上创建对应的VLAN,本例模拟终端客户属于VLAN200
[SW1-Client-GigabitEthernet0/0/10]dis th
#
interface GigabitEthernet0/0/10
port link-type access
port default vlan 200 //连接终端的接口划入VLAN 200
[SW1-Client-GigabitEthernet0/0/1]dis th
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 200 300 //连接运营商接口常规的实施Trunk封装
#
SW4的实施:
[SW4-Client]vlan batch 200 300
[SW4-Client-GigabitEthernet0/0/10]dis th
#
interface GigabitEthernet0/0/10
port link-type access
port default vlan 200
[SW4-Client-GigabitEthernet0/0/1]dis th
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 200 300
2.运营商侧QinQ的实施
SW2:
vlan 3
description ISP-ACCESS //创建VLAN3,作为外层TAG
[SW2-ISP-GigabitEthernet0/0/1]dis th
#
interface GigabitEthernet0/0/1
port link-type dot1q-tunnel //接口设置为QinQ模式
port default vlan 3 //运营商设备连接客户设备的链路的默认VLAN为3,即增加的外层TAG标识
[SW2-ISP-GigabitEthernet0/0/5]dis th
#
interface GigabitEthernet0/0/5
port link-type trunk
port trunk allow-pass vlan 2 to 4094 //运营商内部实施常规的Trunk并允许VLAN通过
!!
[SW3-ISP-vlan3]dis th
#
vlan 3
description ISP-ACCESS
[SW3-ISP-GigabitEthernet0/0/1]dis th
#
interface GigabitEthernet0/0/1
port link-type dot1q-tunnel //接口设置为QinQ模式
port default vlan 3 //运营商设备连接客户设备的链路的默认VLAN为3,即增加的外层TAG标识
[SW3-ISP-GigabitEthernet0/0/5]dis th
#
interface GigabitEthernet0/0/5
port link-type trunk
port trunk allow-pass vlan 2 to 4094
验证实施结果:
[SW3-ISP]display port vlan GigabitEthernet 0/0/1 active //连接客户交换机的接口为QinQ默认,PVID为3,即default vlan命令
T=TAG U=UNTAG

Port Link Type PVID VLAN List

GE0/0/1 dot1q-tunnel 3 U: 3
[SW2-ISP]display port vlan active GigabitEthernet 0/0/1
T=TAG U=UNTAG

Port Link Type PVID VLAN List

GE0/0/1 dot1q-tunnel 3 U: 3
3.验证终端的通信并验证报文
请读者自行配置终端的IP,本例为10.1.1.1和10.1.1.2。如图2-22所示,终端完成通信。请抓取SW2和SW3之间的链路上的报文,分析如图2-23所示,读者可以看到2层VLAN TAG。
乾颐堂安德HCIE章节:QinQ技术原理和实现实现
图2-22 终端设备完成通信
乾颐堂安德HCIE章节:QinQ技术原理和实现实现
图2-23 一个实际的QinQ报文
到此QinQ讲解完毕
本章中我们实施了VLAN技术相关的一些高级技术,读者可以参考本章通过实验理解理论,并在现网中针对特定场景应用