一.RSPAN概述

1.rspan 概念

RSPAN(Remote Switched Port Analyzer,远程交换端口分析),即远程端口镜像,突破了被镜像端口和镜像端口必须在同一台交换机上的限制,使被镜像端口和镜像端口可以跨越网络中的多个设备,从而方便网管人员对远程交换机设备进行管理。将远端的网络中的数据流传到指定的网络方向。从而进行监控网络的监。

2.rspan 的实现角色

①.交换机角色

源交换机:被监测的端口所在的交换机,负责将需要镜像的流量在Remote-probe VLAN上做二层转发,转发给中间交换机或目的交换机。

中间交换机:网络中处于源交换机和目的交换机之间的交换机,通过Remote-probe VLAN把镜像流量传输给下一个中间交换机或目的交换机。如果源交换机与目的交换机直接相连,则不存在中间交换机。

目的交换机:远程镜像目的端口所在的交换机,将从Remote-probe VLAN接收到的镜像流量通过镜像目的端口转发给监控设备。

②.端口角色

源端口(Source Port):被监测的用户端口,通过本地端口镜像把用户数据报文复制到指定的反射端口(Reflector port)。源端口可以有多个。此端口仅在源交换机上,如果与trunk传输通道所经过的交换机上存在该端口则会照成网络流量的混乱

Trunk端口:将镜像报文发送到目的交换机。中间交换机上要配置两个Trunk端口,和两侧的设备相连

反射端口(Reflector port):接收本地端口镜像的用户数据报文。

镜像目的端口(Destination port):远程镜像报文的监控端口:

③.Remote-probe VLAN

简介:所有被镜像的报文通过该VLAN从源交换机传递到目的交换机的镜像端口,实现在目的交换机上对源交换机的远程端口的报文进行监控的功能。

建议将该VLAN中的设备互连端口都配置为Trunk端口;
不能将缺省VLAN、管理VLAN设置成Remote-probe VLAN;
需要通过配置保证Remote-probe VLAN从源交换机到目的交换机的二层互通性;
交换机作为中间设备或者目的设备的时候,不能支持双向(both)镜像。

二.RSPAN实验案例

1.实验简介

①实验原理:

利用远端交换机上的反射接口 将远端的指定端口方向上的数据同个一个指定的vlan trunk通道传输到目标交换机上。再从目标交换机上的目标端口进入目标地。利用在远端主机上安装的监控工具完成对数据的监控。从而方便管理员对远端的接口数据进行监控。

原理图:

p_w_picpath

②.实验设备:

二层交换机   华为     serial 2000  HI  

防火墙         华为      serialpath F-100(此设备仅用于终端的辅助测试)

③.实验拓扑

p_w_picpath

④.实验目的

测试监控F1与F3之间的数据流

2.目标交换机S3的配置

mirroring-group 1 remote-destination   // 镜像组1中指定交换机的角色

vlan 10
remote-probe vlan enable   //定义remote-probe vlan

interface Ethernet1/0/1
port access vlan 10
mirroring-group 1 monitor-port  //镜像组1中监控流量的目的端口

interface Ethernet1/0/24   //流量的trunk通道
port link-type trunk
port trunk permit vlan 1 10 //允许vlan 10 通过

mirroring-group 1 remote-probe vlan 10   //在镜像组1中调用vlan 10

3.中间交换机S6的配置

 

vlan 10
remote-probe vlan enable  //启用远程 vlan 10

 

interface Ethernet1/0/1  //流量的trunk通道

port link-type trunk 
port trunk permit vlan 1 10  //允许vlan 10 通过

interface Ethernet1/0/24  //流量的trunk通道
port link-type trunk
port trunk permit vlan 1 10  //允许vlan 10 通过

4.源交换机S2的配置

mirroring-group 1 remote-source // 镜像组1中指定交换机的角色

vlan 10
remote-probe vlan enable  //定义Remote-probe VLAN

interface Ethernet1/0/1 

port link-type trunk   //将端口设置为trunk模式

port trunk permit vlan 1 10  //设置允许vlan

interface Ethernet1/0/5
mirroring-group 1 reflector-port  //配置反射接口,不可使用,不用插网线。自动启用。

interface Ethernet1/0/23
mirroring-group 1 mirroring-port inbound //传输镜像组1传输23口的入口流量

interface Ethernet1/0/24
mirroring-group 1 mirroring-port outbound //传输镜像组1传输24口的出口流量

mirroring-group 1 remote-probe vlan 10 //镜像组1中调用vlan 10

5.测试监控

从F1 telnet到 F3 。结果是在F1或F3上连接对方抓到的数据包如下:

wps_clip_p_w_picpath-11268

由图可以看出是单向的数据

6.实验总结

在一个交换机上监控两个端口时不能完全将outbound或inbound.

只能针对某一方向上!!!