最近在运行项目的时候 Jetty 出现了一个比较奇葩的错误。

一直显示是 503 错误,但是又找不到错误的原因。

Jetty 运行的时候出现 503 异常的原因_服务器

后来通过查看可能的原因是 Jetty 的版本和 JDK 的版本没有办法支持导致的。

从上面的图片我们知道,当前运行 Jetty 的版本是 9.4。

但是我们服务器上装的 JDK 版本是 11。

Jetty 9 是没有办法运行在 JDK 11 上的。

Jetty 运行的时候出现 503 异常的原因_java_02

上面的图片显示了 Jetty 可以支持的容器的版本。

在部署服务的时候,这个比较重要,否则你会遇到一些莫名其妙的错误。