今天把一个拓扑图放出来,然后配置全网互联互通!

准备把前面所学都应用到这个大型点的拓扑图上! 以便大家巩固一下所学的知识!

【实验拓扑】

 

 

【实验步骤】

设备比较多! 我们从左下 一直往上配置(看的时候注意设备名)

PC的IP地址 末尾都为2 网关为1 (例:VLAN2 PC192.168.2.2 255.255.255.0网关192.168.2.1)以此类推!

Switch1

Switch>enable
Switch#configure terminal
Switch(config)#vlan 4
Switch(config-vlan)#exit
Switch(config)#vlan 5
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/4
Switch(config-if)#switchport access vlan 4
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/5
Switch(config-if)#switchport access vlan 5
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport mode trunk

Multilayer Switch1

Switch>enable
Switch#configure terminal
Switch(config)#vlan 4
Switch(config-vlan)#exit
Switch(config)#vlan 5
Switch(config-vlan)#exit
Switch(config)#interface vlan 4

Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.4.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 5

Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.5.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#no switchport
Switch(config-if)#no shutdown
Switch(config-if)#ip address 172.16.2.2 255.255.255.252

Switch(config-if)#exit
Switch(config)#router ospf 1
Switch(config-router)#network 192.168.4.0 0.0.0.255 area 0
Switch(config-router)#network 192.168.5.0 0.0.0.255 area 0
Switch(config-router)#network 172.16.2.0 0.0.0.3 area 0

Router1

Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 1/0
Router(config-if)#no shutdown

Router(config-if)#ip address 172.16.2.1 255.255.255.252
Router(config-if)#exit
Router(config)#interface serial 2/0
Router(config-if)#no shutdown

Router(config-if)#ip address 60.12.3.6 255.255.255.252
Router(config-if)#exit
Router(config)#router ospf 1
Router(config-router)#network 172.16.2.0 0.0.0.3 area 0
Router(config-router)#network 60.12.3.4 0.0.0.3 area 0

Router2

Router>enable
Router#configure terminal
Router(config)#interface serial 2/0
Router(config-if)#no shutdown

Router(config-if)#clock rate 64000
Router(config-if)#ip address 60.12.3.5 255.255.255.252
Router(config-if)#exit
Router(config)#interface fastEthernet 1/0
Router(config-if)#no shutdown

Router(config-if)#ip address 172.16.1.1 255.255.255.252
Router(config-if)#exit
Router(config)#router ospf 1
Router(config-router)#network 60.12.3.4 0.0.0.3 area 0
Router(config-router)#network 172.16.1.0 0.0.0.3 area 0

Multilayer Switch2

Switch>enable
Switch#configure terminal
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#no switchport

Switch(config-if)#no shutdown
Switch(config-if)#ip address 172.16.1.2 255.255.255.252
Switch(config-if)#exit
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#exit
Switch(config)#interface vlan 2

Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.2.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 3

Switch(config-if)#no shutdown
Switch(config-if)#ip address 192.168.3.1 255.255.255.0
Switch(config-if)#exit
Switch(config)#router ospf 1
Switch(config-router)#network 192.168.2.0 0.0.0.255 area 0
Switch(config-router)#network 192.168.3.0 0.0.0.255 area 0
Switch(config-router)#network 172.16.1.0 0.0.0.3 area 0

Switch2

Switch>enable
Switch#configure terminal
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/24
Switch(config-if)#switchport mode trunk

此时全网互联互通!下面我上传一个PT5.0做的这个TP 有未配置前 和配置后  供大家学习!(由于上传的文件类型不正确,上传不了  如有需要请加我好友!问我索要)

原创:胡斌   

 我会从简单到难的发表一些我学过的知识,希望能给一些想入门的朋友帮助,也希望找一些志同道合的朋友、老师 给我些指教。 QQ 276200261!