可能是我的项目比较简单吧,并没有遇到所谓“莫名其妙”的问题。也是在今天我导入的项目也正常运行了,算是阶段性的成果。现在有时间回头看,算是使用体验吧。

       第一天

       2013年的google IO大会上,发布了专属andriod 的开发环境,我没有马上下载,而是看了一下IT网站的报道,提到as虽然相比其他开发环境将更快更好用,可因为是“未完全”版本,所以会出莫名其妙的错误,真的如此吗?还是决定体验了。到csdn-移动-android栏目下找到了官方链接,进入下载!我的系统是还是xp,安装后有图标显示在开始菜单下,点击小绿人!好家伙,没有反应?我也装好了最新的jdk1.7呀,马上搜索,发现c122532318的文章(http://blog.csdn.net/whuancai/article/details/8934898),检查了自己的系统,发现确实没有设置 java_home环境变量。后来我继续查了一下资料,总结了一下安装之后打不开andriod studio的问题的解决办法,按照实用程度整理排序(大部分来自网友),能打开就不用试下一个了:

首次运行,建立好项目需要下载一些东西,如果提示一些错误,请核实错误再次打开下载,即可运行,可能是下载的时候没有下载完全

2 检查jdk路径是否配置,1.6和1.7都没有问题。

如果没能打开~ 那么就要开始配置环境了~  我的电脑->属性->高级-->环境变量(这个是针对XP,相信用win7的朋友也知道怎么走这个流程吧~^_^)

在“系统变量(s)”选项点击处新建,在弹出的对话框中有两个输入框----(变量名 和 变量值 )  ,在变量名输入框中输入:java_home,在变量值输入框中

输入你 JDK 的路径,我的路径是C:\Program Files\Java\jdk1.7.0_17,如下图

 之后就是点击确定或者应用~~( 试试看能否跑起来,能的话就不需要再往下看了~否则继续往下 ^_^)

  如果到这里你的Android Studio 还不能跑起来,那就将Android Studio的bin路劲加到path 变量下,方法如下:

      1>我的电脑->属性->高级-->环境变量,

      2>在“系统变量”双击 “Path” ,然后将你的Android Studio的bin路径加到最前面,并用分号(英文的分号)将

           其和其他路径分开~在点击确定或者应用!(默认Android Studio 的bin路径如下:C:\Program Files\Android\android-studio\bin)


3 win7的话用管理员身份运行试试

4 在bin目录中找到studio.exe.vmoptions去掉里面包含UseCodeCacheFlushing的那行

5用记事本打开android-studiobin 目录下的studio.bat
将 SET VM_OPTIONS_FILE=%IDE_BIN_DIR%studio%BITS%.exe.vmoptions
改为 SET VM_OPTIONS_FILE=%IDE_BIN_DIR%studio%BITS%.exe
就可以使用了

6 用文本工具打开
studio.bat
line25 to line 28:
SET JRE=%JDK%
IF EXIST "%JRE%jre" SET JRE=%JDK%jre
SET BITS=
IF EXIST "%JRE%libamd64" SET BITS=64

可以看到里面设置软件支持系统位数是64位,而我自己所用电脑是32位的 jre/lib目录下只有i386文件
尝试把

IF EXIST "%JRE%libamd64" SET BITS=64 改为
IF EXIST "%JRE%libi386" SET BITS=32


当我设置好环境变量后再去试着打开andriod studio的时候就能够成功运行了!