不管是安装软件,还是卸载软件,就会报以下错误,通过ubuntu自带的“更新管理器”更新软件包,也是报错误无法更新。

[abc@ ~]$sudo apt-get remove libapache2-svn
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
软件包 libapache2-svn 还未安装,因而不会被卸载
下列软件包是自动安装的并且现在不需要了:
libsvn1
使用'apt-get autoremove'来删除它们
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
有 1 个软件包没有被完全安装或卸载。
解压缩后会消耗掉 0B 的额外空间。
正在设置 dkimproxy (1.2-3) ...
addgroup: 组"dkimproxy"已经是系统组。退出。
系统用户"dkimproxy"已经存在,退出。
* Starting inbound DomainKeys-filter dkimproxy.in Unknown option: hostname
Usage:
dkimproxy.in [options] LISTENADDR:PORT RELAYADDR:PORT
smtp options:
--conf_file=FILENAME
--listen=LISTENADDR:PORT
--relay=RELAYADDR:PORT
--reject-error

verification options:
--reject-fail
--hostname=HOSTNAME

daemon options:
--daemonize
--user=USER
--group=GROUP
--pidfile=PIDFILE

dkimproxy.in --help
to see a full description of the various options

[fail]
invoke-rc.d: initscript dkimproxy, action "start" failed.
dpkg:处理 dkimproxy (--configure)时出错:
子进程 已安装的 post-installation 脚本 返回了错误号 2
在处理时有错误发生:
dkimproxy
E: Sub-process /usr/bin/dpkg returned an error code (1)

在线等了很久,没有信息,就在本论坛上搜索了下相关的页面。发现以下贴很符合我的需要:

viewtopic.php?f=86&t=90547

以下步骤解决了我的问题:

cd /var/lib/dpkg
sudo mv info info.bak
sudo mkdir info
重新安装,在此为:
sudo apt-get --reinstall install ttf-dustin khangman kdeedu kde


在此感谢各位对本帖的关注。但还不是很明白为什么会解决掉。