由于在安装JDK的过程中的某一些原因 有一些组件没有被安装上去可能会造成这样的错误,我安装的时候是360提示禁止安装限制住了我,弄了半天,还是找别人帮我解决了这个问题,从字面的意思上看是tool 文件之类的错误,

解决方法:再其他错误排除的情况下 如:配置问题都解决了  也能在cmd下  java  -version 能现实正确的版本信息的情况下,执行测试例子出错就是缺少一个.jar文件,

在你java安装目录下lib文件里,没有tools.jar文件,找一个相同版本的附加上去就可以了!