the VMware Client Integration Plugin has updated its SSL certificate in Firefox

随着最近发布的Mozilla Firefox和Google Chrome,启动VMware Client Integration Plugin的能力再次被打破。vSphere Web Client 6.0不断显示弹出消息,如下所示:

the VMware Client Integration Plugin has updated

这是因为两个浏览器都删除了对NPAPI插件的支持。因此,它会删除Web客户端中的某些操作,例如部署OVF或OVA模板以及使用数据存储浏览器传输文件。

我发现这个问题唯一可行的解决方案是使用Firefox 52扩展支持版本(32位版本),它将 支持NPAPI插件, 直到2018年初。

或者,应将vCenter Server Appliance升级到版本6.5,其中“ VMware增强的身份验证插件将替换vSphere 6.0及更早版本中的客户端集成插件 ”,并且不需要NPAPI支持。

21/06/2017 - 更新1:当Web浏览器配置为使用代理服务器时,也会弹出此消息。切换到“无代理”模式会使其无法显示。