由于最近比特币被炒到近乎不可思议的价格,所以网络上的肉鸡都被黑产们一个个培养成了挖矿鸡。今儿就聊聊如何进行WebLogic10的反序列化漏洞的升级方法。

1、修改bsu.sh 把内存调大
vi /home/weblogic/bea/utils/bsu/bsu.sh
把这段修改成
MEM_ARGS="-Xms1G -Xmx2G"
2、下载补丁
mkdir -p /home/weblogic/bea/utils/bsu/cache_dir
把最新补丁包CVE-2017-10271p26519424_1036_Generic.zip放到cache_dir下
3、升级补丁

cd /home/weblogic/bea/utils/bsu/cache_dir
unzip -nq CVE-2017-10271p26519424_1036_Generic.zip
cd ..

如果之前打过反序列化补丁的话,那么需要把以前的补丁挨个都卸载掉,而且一定要注意顺序,顺序反了也会失败。而且他要校验半天才会报错,每个补丁大概30分钟的样子。。。(很二逼吧)
删除补丁的命令:

./bsu.sh -remove -patchlist=ZLNA -prod_dir=/home/weblogic/bea/wlserver_10.3 -log=/tmp/remove.log
./bsu.sh -remove -patchlist=EJUW -prod_dir=/home/weblogic/bea/wlserver_10.3 -log=/tmp/remove.log

删除成功会出现succeed的字样
安装新的补丁包:
./bsu.sh -install -patch_download_dir=/home/weblogic/bea/utils/bsu/cache_dir -patchlist=FMJJ -prod_dir=/home/weblogic/bea/wlserver_10.3 -verbose

注意:如果不会打补丁,临时救急的解决办法就是把curl和wget命令删除或者禁用,原因是反序列化漏洞只能通过shell反弹进行***的下载,说的通俗点就是***只能通过被***的服务器主动的去下载***,无法进行上传操作,而且权限只限于运行weblogic中间件的用户。