如何配置三层交换机创建VLAN
以下的介绍都是基于Cisco交换机的VLANCiscoVLAN实现通常是以端口为中心的。与节点相连的端口将确定它所驻留的VLAN。将端口分配给VLAN的方式有两种,分别是静态的和动态的.形成静态VLAN的过程是将端口强制性地分配给VLAN的过程。即我们先在VTP VLAN Trunking ProtocolServer上建立VLAN,然后将每个端口分配给相应的VLAN的过程。这是我们创建VLAN最常用的方法。

动态VLAN形成很简单,由端口决定自己属于哪个VLAN即我们先建立一个VMPSVLAN Membership Policy ServerVLAN管理策略服务器,里面包含一个文本文件,文件中存有与VLAN映射的MAC地址表。交换机根据这个映射表决定将端口分配给何种VLAN这种方法有很大的优势,但是创建数据库是一项非常艰苦而且非常繁琐的工作。

下面以实例说明如何在一个典型的快速以太局域网中实现VLAN。所谓典型的局域网就是指由一台具备三层交换功能的核心交换机接几台分支交换机(不一定具备三层交换能力)。我们假设核心交换机名称为:MAIN;分支交换机分别为:SW-ASW-BSW-C……,分别通过Port 1的光线模块与核心交换机相连;并且假设VLAN名称分别为SALESMARKETPRODUCTION……

1
、设置VTP DOMAIN VTP DOMAIN 称为管理域。交换VTP更新信息的所有交换机必须配置为相同的管理域。如果所有的交换机都以中继线相连,那么只要在核心交换机上设置一个管理域,网络上所有的交换机都加入该域,这样管理域里所有的交换机就能够了解彼此的VLAN列表。

MAIN#vlan database 进入VLAN配置模式

MAIN(vlan)#vtp domain MAIN
设置VTP管理域名称
MAIN
MAIN(vlan)#vtp server
设置交换机为服务器模式

SW-A#vlan database
进入VLAN配置模式

SW-A(vlan)#vtp domain MAIN
设置VTP管理域名称
MAIN
SW-A(vlan)#vtp Client
设置交换机为客户端模式

SW-B#vlan database
进入VLAN配置模式

SW-B(vlan)#vtp domain MAIN
设置VTP管理域名称
MAIN
SW-B(vlan)#vtp Client
设置交换机为客户端模式

SW-C#vlan database
进入VLAN配置模式

SW-C(vlan)#vtp domain MAIN
设置VTP管理域名称
MAIN
SW-C(vlan)#vtp Client
设置交换机为客户端模式

注意:这里设置交换机为Server模式是指允许在本交换机上创建、修改、删除VLAN及其他一些对整个VTP域的配置参数,同步本VTP域中其他交换机传递来的最新的VLAN信息;Client模式是指本交换机不能创建、删除、修改VLAN配置,也不能在NVRAM中存储VLAN配置,但可以同步由本VTP域中其他交换机传递来的VLAN信息。

2、配置中继

为了保证管理域能够覆盖所有的分支交换机,必须配置中继。Cisco交换机能够支持任何介质作为中继线,为了实现中继可使用其特有的ISL标签。ISLInterSwitch Link)是一个在交换机之间、交换机与路由器之间及交换机与服务器之间传递多个VLAN信息及VLAN数据流的协议,通过在交换机直接相连的端口配置ISL封装,即可跨越交换机进行整个网络的VLAN分配和进行配置。

在核心交换机端配置如下:

MAIN(config)#interface gigabitEthernet 2/1
MAIN(config-if)#switchport
MAIN(config-if)#switchport trunk encapsulation isl
MAIN(config-if)#switchport mode trunk
MAIN(config)#interface gigabitEthernet 2/2
MAIN(config-if)#switchport
MAIN(config-if)#switchport trunk encapsulation isl
MAIN(config-if)#switchport mode trunk
MAIN(config)#interface gigabitEthernet 2/3
MAIN(config-if)#switchport
MAIN(config-if)#switchport trunk encapsulation isl
MAIN(config-if)#switchport mode trunk
在分支交换机端配置如下:

SW-A(config)#interface gigabitEthernet 0/1
SW-A(config-if)#switchport mode trunk
SW-B(config)#interface gigabitEthernet 0/1
SW-B(config-if)#switchport mode trunk
SW-C(config)#interface gigabitEthernet 0/1
SW-C(config-if)#switchport mode trunk
……
此时,管理域算是设置完毕了。

3
、创建
VLAN
一旦建立了管理域,就可以创建VLAN了。

MAIN(vlan)#Vlan 2 name SALES 创建了一个编号为2名字为SALES
VLAN
MAIN(vlan)#Vlan 3 name MARKET
创建了一个编号为3名字为MARKET
VLAN
MAIN(vlan)#Vlan 4 name PRODUCTION
创建了一个编号为4名字为PRODUCTION
VLAN
……
注意,这里的VLAN是在核心交换机上建立的,其实,只要是在管理域中的任何一台VTP 属性为Server的交换机上建立VLAN,它就会通过VTP通告整个管理域中的所有的交换机。但是如果要将交换机的端口划入某个VLAN,就必须在该端口所属的交换机上进行设置。

4、将交换机端口划入
VLAN
例如,要将SW-ASW-BSW-C……分支交换机的端口1划入SALES VLAN,端口2划入MARKET VLAN,端口3划入
PRODUCTION VLAN……
SW-A(config)#interface fastEthernet 0/1
配置端口
1
SW-A(config-if)#switchport access Vlan 2
归属
SALES VLAN
SW-A(config)#interface fastEthernet 0/2
配置端口
2
SW-A(config-if)#switchport access Vlan 3
归属
MARKET VLAN
SW-A(config)#interface fastEthernet 0/3
配置端口
3
SW-A(config-if)#switchport access Vlan 4
归属
PRODUCTION VLAN
SW-B(config)#interface fastEthernet 0/1
配置端口
1
SW-B(config-if)#switchport access Vlan 2
归属
SALES VLAN
SW-B(config)#interface fastEthernet 0/2
配置端口
2
SW-B(config-if)#switchport access Vlan 3
归属
MARKET VLAN
SW-B(config)#interface fastEthernet 0/3
配置端口
3
SW-B(config-if)#switchport access Vlan 4
归属
PRODUCTION VLAN
SW-C(config)#interface fastEthernet 0/1
配置端口
1
SW-C(config-if)#switchport access Vlan 2
归属
SALES VLAN
SW-C(config)#interface fastEthernet 0/2
配置端口
2
SW-C(config-if)#switchport access Vlan 3
归属
MARKET VLAN
SW-C(config)#interface fastEthernet 0/3
配置端口
3
SW-C(config-if)#switchport access Vlan 4
归属
PRODUCTION VLAN
……
5、配置三层交换

到这里,VLAN已经基本划分完毕。但是,VLAN间如何实现三层(网络层)交换呢?这时就要给各VLAN分配网络(IP)地址了。给VLAN分配IP地址分两种情况,其一,给VLAN所有的节点分配静态IP地址;其二,给VLAN所有的节点分配动态IP地址。下面就这两种情况分别介绍。

我们假设给VLAN SALES分配的接口Ip地址为172.16.58.1/24,网络地址为:172.16.58.0VLAN MARKET分配的接口Ip地址为172.16.59.1/24,网络地址为172.16.59.0VLAN PRODUCTION分配的接口Ip地址为172.16.60.1/24,网络地址为172.16.60.0……。如果动态分配IP地址,则设网络上的DHCP服务器IP地址为172.16.1.11

(1)VLAN所有的节点分配静态IP地址

首先在核心交换机上分别设置各VLAN的接口IP地址,如下所示:

MAIN(config)#interface Vlan 2
MAIN(config-if)#ip address 172.16.58.1 255.255.255.0 VLAN
2接口
IP
MAIN(config)#interface Vlan 3
MAIN(config-if)#ip address 172.16.59.1 255.255.255.0 VLAN
3接口
IP
MAIN(config)#interface Vlan 4
MAIN(config-if)#ip address 172.16.60.1 255.255.255.0 VLAN
4接口
IP
……
再在各接入VLAN的计算机上设置与所属VLAN的网络地址一致的IP地址,并且把默认网关设置为该VLAN的接口地址。这样,所有的VLAN也可以互访了。

(2)
VLAN所有的节点分配动态IP地址

首先在核心交换机上分别设置各VLAN的接口IP地址和DHCP服务器的IP地址,如下所示:

MAIN(config)#interface Vlan 2
MAIN(config-if)#ip address 172.16.58.1 255.255.255.0 VLAN
2接口
IP
MAIN(config-if)#ip helper-address 172.16.1.11 DHCP Server IP
MAIN(config)#interface Vlan 3
MAIN(config-if)#ip address 172.16.59.1 255.255.255.0 VLAN
3接口
IP
MAIN(config-if)#ip helper-address 172.16.1.11 DHCP Server IP
MAIN(config)#interface Vlan 4
MAIN(config-if)#ip address 172.16.60.1 255.255.255.0 VLAN
4接口
IP
MAIN(config-if)#ip helper-address 172.16.1.11 DHCP Server IP
……
再在DHCP服务器上设置网络地址分别为172.16.58.0172.16.59.0172.16.60.0的作用域,并将这些作用域的路由器选项设置为对应VLAN的接口IP地址。这样,可以保证所有的VLAN也可以互访了。

最后在各接入VLAN的计算机进行网络设置,将IP地址选项设置为自动获得IP地址即可。

总结
:
用通俗易懂的文字来阐述创建VLAN的全过程,并且给出了详细的设置步骤,只要你对Cisco交换机的IOS有所了解,看懂本文并不难,按照本文所示的步骤一步一步地做,你完全可以给一个典型的快速以太网络建立多个VLAN.