今天把win10电脑上的VMware装了个最新的14版本,为了测试所以装了两个centos系统分别是centons6.6和centos7.5,这两个系统都是双网卡的,一个是静态地址,一个是NAT,但是在系统安装完成后,两个系统都无法上网,
遇到的问题都是
centos6和7配置双网卡不能上网的问题
centos6和7配置双网卡不能上网的问题
目标地址无法到达
1.首先开始检查VMware的win10服务是否开启
win+R,输入services.msc检查服务是否都是开启的
centos6和7配置双网卡不能上网的问题
服务都是开启的,说明没问题,但是为了以防万一我还是都重启了一次
2.检查虚拟机的网络配置和centos配置是否有问题
centos6和7配置双网卡不能上网的问题
这里看出网卡一是nat的dhcp地址,网卡二是静态地址
centos6和7配置双网卡不能上网的问题
系统里面与之对应的也没问题

3.检查虚拟机网络的配置是否有问题

centos6和7配置双网卡不能上网的问题
进入编辑器里面
centos6和7配置双网卡不能上网的问题
这里的nat也没问题,
4.检查windows的网络配置是否有问题
centos6和7配置双网卡不能上网的问题
centos6和7配置双网卡不能上网的问题
这里的配置也没问题
5.到这里都没问题那就说明了windows和VMware都没问题,那就是centos系统的问题了,在网上找了半天都是关于上面几个步骤的重复,我重启系统,重启虚拟机都不好使,还是上不了网
6.最后在别人的提示下,我查看了下centos的路由,发现了两个系统都是路由的问题导致了无法上网
centos6和7配置双网卡不能上网的问题
这里的默认路由是静态地址的,静态地址是我本地的地址,所以会出现目标地址无法到达的情况,
既然明白了原因那就好解决了,把默认的路由给删了,把nat的的网卡改为默认路由的网卡就没问题了
centos6和7配置双网卡不能上网的问题

[root@centos6 ~]# route del -net 0.0.0.0
[root@centos6 ~]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.65.0    *               255.255.255.0   U     0      0        0 eth0
192.168.18.0    *               255.255.255.0   U     0      0        0 eth1
link-local      *               255.255.0.0     U     1002   0        0 eth0
link-local      *               255.255.0.0     U     1003   0        0 eth1
[root@centos6 ~]# route add gw 192.168.65.2 eth0
gw: 未知的主机
[root@centos6 ~]# route add default gw 192.168.65.2 eth0
[root@centos6 ~]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.65.0    *               255.255.255.0   U     0      0        0 eth0
192.168.18.0    *               255.255.255.0   U     0      0        0 eth1
link-local      *               255.255.0.0     U     1002   0        0 eth0
link-local      *               255.255.0.0     U     1003   0        0 eth1
default         bogon           0.0.0.0         UG    0      0        0 eth0

到此大功告成可以上外网了!

虽然现在是没问题了,但是重启了之后又不能上外网了,可以吧这个默认网关加到开机启动项里面去(或许还有别的什么方法,但是我目前还不知道!)

echo -e ' route del -net 0.0.0.0 2>/dev/null\n route add default gw 192.168.65.2 eth0 2>/dev/null' >>/etc/rc.d/rc.local

centos6和7配置双网卡不能上网的问题

注:不管是win7还是win10,打开VMware的方式最好都是用右键以管理员方式运行,不然回报很多莫名其妙的错误的!
就拿我遇到的问题来说吧!我的配置都没问题,但是VMware我是双击打开的,无论是NAT还是桥接重启网卡的时候都失败了,但是我用右键以管理员运行的时候,不管是NAt还是桥接都没问题了!