实验目的:

了解自动隧道6to4隧道的配置

实验拓扑:

 

实验说明:

在这个实验中I边缘路由器都是一个前缀为/48地址,该前缀由2002::/16和边缘路由器的IPV4(十六进制表示)地址组合而成,使用6to4隧道可以再公司网络中快速部署ipv6,而无需申请地址。

配置:

R1:

ipv6 unicast-routing
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Tunnel1
 no ip address
 no ip redirects
 ipv6 unnumbered FastEthernet0/1
 tunnel source Loopback0
 tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0

interface FastEthernet0/1

 ipv6 address 2002:101:101::1/64
!
router ospf 100
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0

ipv6 route ::/0 Tunnel1

 

R2:

ipv6 unicast-routing

interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface Tunnel2
 no ip address
 no ip redirects
 ipv6 unnumbered FastEthernet0/1
 tunnel source Loopback0
 tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0

interface FastEthernet0/1
 ipv6 address 2002:202:202::2/64
!
router ospf 100
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0

ipv6 route ::/0 Tunnel2

 

R3:

interface FastEthernet0/1

 ipv6 address 2002:101:101::3/64

ipv6 route ::/0 2002:101:101::1

R4:

interface FastEthernet0/1
 ipv6 address 2002:202:202::4/64
!
ipv6 route ::/0 2002:202:202::2

分析:

验证: