一,高可用性概述

高可用性H.A.(High Availability)指的是通过尽量缩短因日常维护操作(计划)和突发的系统崩溃(非计划)所导致的停机时间,以提高系统和应用的可用性。它与被认为是不间断操作的容错技术有所不同。HA系统是目前企业防止核心计算机系统因故障停机的最有效手段。

随着IT信息系统的不断发展,数据在企业的应用越来越广,如何提高IT系统的高可用性成为建设稳健的计算机算系统的首要任务之一。构成计算机网络系统的三大要素是:网络系统,服务器系统,存储系统。网络系统包括防火墙,路由器等网络设备,服务器系统主要指用户使用的各种服务器系统,存储系统,则是用户最主要的数据存储放的地点。

因此IT系统的高可用建设应包括网络设备高可用性,服务器设备高可用性,及存储设备的高可用性三个方面。

二,应用实例

3.链路  LAN  stp  rstp  mstp   聚合
广域网wan

利用华为设备实现

拓扑:

clip_image002

 

浮动静态路由:

[Router]sysname r6

[r6]int s0

[r6-Serial0]ip address 192.168.3.1 24

[r6-Serial0]int s1

[r6-Serial1]ip address 192.168.4.1 24

[r6-Serial1]int s0

[r6-Serial0]shut

[r6-Serial0]undo shut

[r6-Serial0]int s1

[r6-Serial1]shut

[r6-Serial1]undo shut

[r6]ospf enable 动态路由协议

[r6-ospf]int e0

[r6-Ethernet0]ospf enable area 0

[r6-Ethernet0]int s0

[r6-Serial0]ospf enable area 0

[r6]ip route-static 192.168.2.0 24 192.168.4.2

[R10]int s0

[R10-Serial0]ip add 192.168.3.2 24

[R10-Serial0]int s1

[R10-Serial1]ip add 192.168.4.2 24

[R10]ospf enable ##开启ospf

[R10]int e0

[R10-Ethernet0]ospf enable area 0 ##将e0加入骨干区域

Interface has already been enabled

[R10-Ethernet0]int s0

[R10-Serial0]ospf enable area 0 ##将s0加入骨干区域

Interface has already been enabled

[R10]ip route-static 192.168.1.0 24 192.168.4.1 ##配置静态路由

查看路由表

clip_image006

Standby interface:

[r6]undo ospf enable

[r6]ip route 192.168.2.0 24 192.168.3.2

[r6-Serial0]standby interface s1

[r6-Serial0]standby timer enable-delay 10启用备份延迟

[r6-Serial0]standby timer disable-delay 10启用骨干延迟

[R10]undo ospf enable ##取消ospf

Terminate OSPF task...

OSPF disabled

[R10]ip route 192.168.1.0 24 192.168.3.1 ##配置静态路由

[R10]int s0 ##骨干接口

[R10-Serial0]standby int s1 ##备份接口

[R10-Serial0]standby timer enable-delay 10 ##启用备份接口的延迟

[R10-Serial0]standby timer disable-delay 10 ##启用骨干接口的延迟

clip_image008[1]

 

链路捆绑:

[r6]int s0

[r6-Serial0]undo standby int s1

[r6-Serial0]int s0

[r6-Serial0]undo ip add

[r6-Serial0]int s1

[r6-Serial1]undo ip add

[r6-Serial1]int virtual-template 1开启虚拟接口

[r6-Virtual-Template1]ip address 192.168.6.1 24

[r6-Virtual-Template1]int s0

[r6-Serial1]ppp mp interface virtual-template 1

[r6-Serial0]int s1

[r6-Serial1]ppp mp interface virtual-template 1

[r6-Serial1]int s0启用PPP链路协商

[r6-Serial0]ppp mp

[r6-Serial0]int s1

[r6-Serial1]ppp mp

[r6-Serial1]quit

[r6]undo ip route-static all

[r6]ip route-static 192.168.2.0 24 192.168.6.2

[R10]int s0

[R10-Serial0]undo standby int s1

[R10]undo ip route-static all

[R10]int s0

[R10-Serial0]un ip add

[R10-Serial0]

%01:41:51: Line protocol ip on the interface Serial0 is DOWN

[R10-Serial0]int s1

[R10-Serial1]un ip add

[R10-Serial1]int virtual-template 1

[R10-Virtual-Template1]ip add 192.168.6.2 24

[R10-Virtual-Template1]int s0

[R10-Serial0]ppp mp int vir 1

[R10-Serial0]int s1

[R10-Serial1]ppp mp int vir 1

[R10-Serial1]int s0

[R10-Serial0]ppp mp

[R10-Serial0]

%01:45:13: Line protocol ip on the interface Virtual-Template1(Virtual-Template1:0) is UP

[R10-Serial0]int s1

[R10-Serial1]ppp mp

[R10]ip route 192.168.1.0 24 192.168.6.1