在中小型企业网互联中连接以帧中继网路 使用比较多,因为它的传输方式还类似于专线,并且支持流量输发,如果是 帧中继网络,则连接交换机接口都是各种帧中继节点;这样就形成了多条虚拟链接通道而附在一根网络线路里面;所以这种相对于专线还是比较节省的。

  帧中继是在用户--网络接口之间提供用户信息流的双向传送, 并保持信息顺序不变的一种承承载业务。帧中继网络的由帧中继节点机和传输链路构成的。网络提供两个或多个用户终端之间的连接,以便进行通信。在帧中继网中,无论从经济上还是建设方面考虑目前难以使每个帧中继节点机两两相连,所以如何合理地组建网络是非常重要的。


  帧中继网络它的特点:也就是采用的是 VC 概念 ;也就是虚连接 虚通道。但是还是和专线网络 还是有本质的区别;这个虚连接虚通道只认为是一个逻辑的连接。而专线是确定有网络特定专线接口的;而且专线网络接口上的通道是专用的。

  而VC只是个连接;也只是一个逻辑的虚连接,采用是统计服务;和专线是不同的,所以这个效率也会略有不同。


VC也有两种方式:一种是svc传递方式逻辑的通道每一次都是不太固定的;这种就是一次性的数据传输完成之后、这个通道就会自动断开;另一类是pvc 是 永久性 虚通道;设置固定的虚通道;会一直存在;要注意的是,VC这种虚通道是不支持广播的;所以这种连接方式 非广播方式;既NMBA非广播多路访问网络。


举例实验:

114145724.jpg

  在这一个企业互联网下,一个总部两个分支,为了把他们连接起来,中间云图连接采用网络的帧中继网来进行连接;因为呢其它是以太网、而中间的广域网是帧中继,因此中间的互联网云图是运行商调制;

 所以实现限制也不能使用三层交换机了;所以也只能采用路由器连接(具有帧中继交换作用);

总部和分支以以太网接口连接到网络中;因为间的网络设置为帧中继网,所以连接交换机接口都是 各种帧中继节点;这样就形成了多条VC虚拟链接通道 附在一根网络线路里面;所以这种相对于专线还是比较节省的。

  从总部到分支有两条vc虚链接线缆;如要试验需要把帧中继交换机给模拟出来;可以把路由设置作为帧中继节点使用;所以6台路由器就可以进行模拟实验操作。


路径:

总部 -- 路由转发-- 帧中继接口-- 帧中继网 -- 路由转发 -- 分支

设置总部R1、分支R2、分支R3 ,而相对应的连接帧中继节点路由分别为 FR1/FR2/FR3;

总部到通往分支的 VC虚通道的编号: 100-- 101-- 102 ;另一设置编号: 200-- 201--202 。


端口设置:

R1、R2、R3、都是一个以太网接口4个串行口;然后 FR1、FR2、FR3也是以太网网路接口也是4个串行口;


地址和端口连接:

总部 R1地址: 192.168.1.0

地址管道 总部R1 :S1/0 192.168.4.1 -->>>> 分支R2 S1/0 192.168.4.2

地址管道 总部R1 :S1/0 192.168.5.1 -->>>> 分支R3 S1/0 192.168.5.2

分支 R2 192.168.2.0

分支 R3 192.168.3.0


连接端口:

R1--S1/0 -->> FR1-- S0/0

R2--S1/0 -->> FR2 --S0/0

R3--S1/0 -->> FR3 --S0/0


(帧中继网络)

FR1--S0/1 -->> FR2 --S0/1 (帧中继节点间的连接)

FR1--S0/2 -->> FR3 --S0/2

节点直接也是全部互连的网路;规划拓扑

114658103.jpg

描述配置过程:

设置帧中继节点/第一个节点也是第FR1路由设置设备;

FR1

可以设置一个名字叫 fr1

对路由设置称为帧中继节点先:

farm-relay switching

( 目的是把这个路由设备变成交换机来工作 )

然后开始设置端口;

int s0/0

( 这个端口它处理的结构是帧中继帧结构,所以要进行分装;)

来说明我的帧是一个什么样的帧:

有atm-dxi / frame-relay / hdlc /lapb/ppp/smds/x25

encapsulation frame-relay ietf

因为这里做的是帧中继网络,所以叫分装帧中继(ietf 标准格式)

运营商的端口是DCE因为可以控制数率,设备的端口DTE;所以还要设置它的类型。

(其实还有一种nni叫网络对网络接口)

frame-relay intf-type dce

设置端口通道类型

clock rate 64000

描述管道的状态是怎样设置的;整个管道的维护是否需要一个信令进行维护的,

这个信令叫lmi 也叫本地管理接口,是一种维护信令、主要传递状态信息;

有3中格式 :cisco ansi q.933a 这是用来维护管道信号的;

这里是思科模拟的所以用 cisco;

frame-relay lmi-type cisco

然后就是转发表、设置管道走经过的接口;

frame-relay route 100 interface s0/1 101

总部到两各分支的虚拟链接的逻辑通道编号;

frame-relay route 200 interface s0/2 201

然后设置开启s0/0端口

int s0/0

no shutdown

配置完成可以查看配置内容是否起效:

show runningconfig

( 设置帧中继端口之后,接口都变成了一种交换式帧中继接口、所以也不用配置地址的;)



然后同样的进入配置 s0/1 和 s0/2

int s0/1

no shutdown

然后 分装帧中继 接口类型 转发接口 管道

encapsulation frame-relay

frame-relay intf-type dce

clock rate 64000

因为信令只存在一段网络之中,所以接口的每一段都要配置

frame-relay lmi-type cisco

frame-relay route 101 int s0/0 100

(线路接口)


接着s0/2 端口

步骤 分装中继

config

int s0/2

no shutdown

encapsulation frame-relay

frame-relay intf-type dce

clock rate 64000

frame-relay lmi-type cisco

frame-relay route 201 int s0/0 200



帧中继节点2

FR2

为了便于观察、可以整改下名称;

enable

config

host

hostname fr-2

link console 0

logg

logging synchronous

no exec-timeout

exit


frame-relay switching

int s0/0

encapsulation frame-relay

frame-relay intf-type dce

clock rate 64000

frame-relay lmi-type cisco

frame-relay route 102 int s0/1 101

( 设置说明进来的和出去的通过虚拟管道的编号 )


int s0/1

no shutdown

encapsulation frame-relay

frame-relay intf-type dte

( 因为在上游的线是dce需同设备的保持一致 )


frame-relay lmi-type cisco

frame-relay route 101 int s0/0 102


show frame-relay pvc

( 查看管道状态如果测试配置正确;则会有所提示有一个什么编号的虚拟链接管道在这个交换式的网络;如果是路由器、它的名字就叫local,是本地的;也会显示状态和连接端口。)


然后帧中继节点3

【 FR3 】

enable

config

host

hostname fr-3

exit

frame-relay switching

int s0/0

no shutdown

encapsulation frame-relay

frame-relay intf-type dce

(面向是用户的端口 是dce;)

clock rate 64000

因为什么样的交换机构建什么样的网络、如果是帧中继网络,也就是帧中继交换机、如果是以太网技术的交换机,那就是以太网的;很明显这里是帧中继网络

frame-relay lmi-type cisco

frame-relay route 202 int s0/2 201


int s0/2

no shutdown

encapsulation frame-relay

frame-relay intf-type dte

frame-relay lmi-type cisco

接下来还是转发表:

frame-relay route 201 int s0/0 202





接下来路由配置 :

【 R1 】

enable

config

host

hostname r1


link console 0

logg

logging synchronous

no exec-timeout

exit


int f0/0 ( 配置以太网接口 )

ip add 192.168.1.1 255.225.255.0

no shutdown


int s1/0

看图谱设置操作 端口下应该两个地址

ip add 192.168.4.1 255.255.255.0

ip add 192.168.5.1 255.255.255.0 secondary

 ( 表明是辅助地址 ;还有如果不加则就会把 4.1 的地址给down掉;)

no shutdown


encapsulation frame-relay

frame-relay intf-type dte ( 然接下的接口类型 就不用配了)

frame-relay lmi-type cisco

然后开始做映射;R1 要想获得 R2 的地址、100管道

frame-relay map ip 192.168.4.2 100

frame-relay map ip 192.168.5.2 200

exit


端口的配置就至此而后开始 做路由表;依然全局配置下:

config

ip route 192.168.2.0 255.255.255.0 192.168.4.2

ip route 192.168.3.0 255.255.255.0 192.168.5.2


然后 show runningconfig;

( 查看有地址转发表的访问下一跳的地址通过是 100管道;同样的 R1 访问到分支 3.0 到5.2的 下一跳是 通过200 管道;而且还可以看一下 管道状态;)

show frame-relay pvc

(测试会看到 两条管道 在一条物理链路上 )



分支路由上配置

【 R2 】

int f0/0

ip add 192.168.2.1 255.255.255.0

no shut down


int s1/0

ip add 192.168.4.2 255.255.255.0

no shut down


然后要进行分装;

encapsulation frame-relay

frame-relay lmi-type cisco

frame-relay map ip 192.168.4.1 102

( 这种网络叫多路访问、叫MV 网络,;为了到4.1 要走 102 的管道;

然后在进行配置 路由;

exit

依然全局配置模式 config 下:

ip route 0.0.0.0 0.0.0.0 192.168.4.1

(其实可以做一下测试 :在 R2 上访问 R1 网络地址;如果通了,说明 100 101 102 的整条管道 都可以通讯了;还可以 show frame-relay pvc ;看一下这个编号的管道、用法是local、状态是激活的、绑定在哪个端口;还可以看到下面是进来多少包、出去多少包、有少个错误等详细;)



另一分支路由上配置:

【 R3 】


enable

config

host

hostname r3


link console 0

logg

logging synchronous

no exec-timeout

exit



int f0/0

ip add 192.168.3.1 255.255.255.0

no shutdown


int s1/0

ip add 192.168.5.2 255.255.255.0

no shutdown


encapsulation frame-relay

frame-relay lmi-type cisco

( 信令格式 )

frame-relay map ip 192.168.5.1 202

(指明通向的下一跳地址 和 需要走的202 管道)

exit


接下来路由表;

ip route 0.0.0.0 0.0.0.0 192.168.5.1

(地址 经过 下一跳)