预善其事、先厉其器

ABIs [armeabi] are not supported for platform. Supported ABIs are [armeabi-v7a, arm64-v8a, x86, x86_64]

起因:

Android studio升级到3.1.2,然后顺便升级了sdk、ndk(v17.0)然后编译出现了异常

原因:

    ndk(v17)已不在支持mips、armeabi等CPU架构
    只支持armeabi-v7a, arm64-v8a, x86, x86_64。
    然后所有涉及到mips和armeabi集体斯巴达了!!!!!!

解决办法一:

剔除mips、armeabi等CPU架构
添加armeabi-v7a, arm64-v8a, x86, x86_64
理想很丰满,现实很骨感。项目里涉及的so大部分都只支持armeabi;于是请看解决二

解决二(亲测顺利解决):
Youtobe视频地址:https://youtu.be/G9oPug80oe0

NDK降级到v16 
替换AS里NDK或者修改ndk-bundle路径即可

【MAC】NDK-v16百度网盘下载
链接: https://pan.baidu.com/s/1F9HKBYwcoW2DXdH6zZYb4w 密码: 4fnu
【win-32】链接: https://pan.baidu.com/s/18Bw-c4rHiPr2evYBB87iig 密码: pp1w
【win-64】链接: https://pan.baidu.com/s/1cWh99MYJJtjY2nKOC6F2Lw 密码: g5gv

【亲测】【Android Studio】升级3.1.2异常记录

下载地址:https://developer.android.com/ndk/downloads/older_releases

找到如下历史版本NDK列表,选择合适当前平台的下载包
【亲测】【Android Studio】升级3.1.2异常记录

Gradle-4.4-all.zip下载异常

百度网盘下载地址:链接: https://pan.baidu.com/s/1x1QdYb8WOOeY3lE2PP2zyg 密码: tmer

【MAC】下可参考如下路径
【亲测】【Android Studio】升级3.1.2异常记录

联系我

QQ群:94297366

公众号推荐:

【亲测】【Android Studio】升级3.1.2异常记录