安装rrdtool之前确保安装了这些库zlib libpng freetype libart_lgpl

验证如下

[root@localhost rrdtool-1.2.6]# rpm -qa |grep zlib

zlib-1.2.3-3

zlib-devel-1.2.3-3

[root@localhost rrdtool-1.2.6]# rpm -qa |grep libpng

libpng-devel-1.2.10-7

libpng-1.2.10-7

[root@localhost rrdtool-1.2.6]# rpm -qa |grep freetype

freetype-2.2.1-16.el5

freetype-devel-2.2.1-16.el5

[root@localhost rrdtool-1.2.6]# rpm -qa |grep libart_lgpl

libart_lgpl-2.3.17-4

libart_lgpl-devel-2.3.17-4

安裝rrdtool時必須要安裝cgilib這個庫,以下是正確的安裝方法

rrdtool 1.2.*

Download:

http://oss.oetiker.ch/rrdtool/

Dependent package:

http://oss.oetiker.ch/rrdtool/pub/libs/

Difficulty:

install libcgi

wget http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/libs/cgilib-0.5.tar.gz

tar zxvf cgilib-0.5.tar.gz

cd cgilib-0.5

make

cp libcgi.a /usr/local/lib

cp cgi.h /usr/include

cd rrdtool-1.2.6

./configure

进行配置

如果./configure时出现下面这个错误

 

  1. configure: error: Please fix the library issues listed above and try again.

 

就要安装libart_lgpl-devel这个包

make   进行编译

make install  将编译好的安装到/usr/local/rrdtool-1.2.6/

ls /usr/local/rrdtool-1.2.6/ 查看该目录

bin examples include lib man share shared 应该有这些目录才正至此rrdtool安装成功

如果已经被安装,而你freetype又是通过2进制包编译安装的,那么他的包也不能通过,必须安装rpm的开发包:

 

  1. yum install freetype-devel

 

再进行rrdtool的编译安装.