DHCP中继

eNSP中拓扑图:

华为DHCP中继实战

SW1:

<Huawei>sys
[Huawei]sysname SW1
[SW1]vlan bat 10 20
Info: This operation may take a few seconds. Please wait for a moment...done.
[SW1]int e0/0/1
[SW1-Ethernet0/0/1]port link-type access 
[SW1-Ethernet0/0/1]port default vlan 10
[SW1-Ethernet0/0/1]un sh
[SW1-Ethernet0/0/1]int e0/0/2
[SW1-Ethernet0/0/2]port link-type access    
[SW1-Ethernet0/0/2]port default vlan 20
[SW1-Ethernet0/0/2]un sh
[SW1-Ethernet0/0/2]int e0/0/3
[SW1-Ethernet0/0/3]port link-type access 
[SW1-Ethernet0/0/3]port default vlan 10
[SW1-Ethernet0/0/3]un sh
[SW1-Ethernet0/0/3]int e0/0/4
[SW1-Ethernet0/0/4]port link-type access
[SW1-Ethernet0/0/4]port default vlan 20
[SW1-Ethernet0/0/4]un sh
[SW1-Ethernet0/0/4]dis vlan
The total number of vlans is : 3
--------------------------------------------------------------------------------
U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
MP: Vlan-mapping;               ST: Vlan-stacking;
#: ProtocolTransparent-vlan;    *: Management-vlan;
--------------------------------------------------------------------------------
VID  Type    Ports                                                          
--------------------------------------------------------------------------------
1    common  UT:Eth0/0/5(D)     Eth0/0/6(D)     Eth0/0/7(D)     Eth0/0/8(D)     
                Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    Eth0/0/12(D)    
                Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    Eth0/0/16(D)    
                Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    Eth0/0/20(D)    
                Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(U)      GE0/0/2(D)      

10   common  UT:Eth0/0/1(U)     Eth0/0/3(U)                                     
20   common  UT:Eth0/0/2(U)     Eth0/0/4(U)                                     

VID  Status  Property      MAC-LRN Statistics Description      
--------------------------------------------------------------------------------
1    enable  default       enable  disable    VLAN 0001                         
10   enable  default       enable  disable    VLAN 0010                         
20   enable  default       enable  disable    VLAN 0020 
[SW1-Ethernet0/0/4]int g0/0/1
[SW1-GigabitEthernet0/0/1] port link-type trunk 
[SW1-GigabitEthernet0/0/1]port trunk allow-pass vlan all
[SW1-GigabitEthernet0/0/1]un sh

R1:

[R1]int g0/0/1.10
[R1-GigabitEthernet0/0/1.10]dot1q termination vid 10
[R1-GigabitEthernet0/0/1.10]ip add 192.168.10.1 24
[R1-GigabitEthernet0/0/1.10]arp broadcast enable    
[R1-GigabitEthernet0/0/1.10]dhcp select relay 
[R1-GigabitEthernet0/0/1.10]dhcp relay server-ip  14.0.0.2
[R1-GigabitEthernet0/0/1.10]int g0/0/1.20
[R1-GigabitEthernet0/0/1.20]dot1q termination vid 20
[R1-GigabitEthernet0/0/1.20]ip add 192.168.20.1 24
[R1-GigabitEthernet0/0/1.20]arp broadcast enable 
[R1-GigabitEthernet0/0/1.20]dhcp select relay 
[R1-GigabitEthernet0/0/1.20]dhcp relay server-ip 14.0.0.2
[R1-GigabitEthernet0/0/1.20]q
[R1]int g0/0/2
[R1-GigabitEthernet0/0/2]ip add 14.0.0.1 24
[R1-GigabitEthernet0/0/2]un sh
[R1-GigabitEthernet0/0/2]int g0/0/0
[R1-GigabitEthernet0/0/0]ip add 12.0.0.1 24
[R1-GigabitEthernet0/0/0]un sh
[R1-GigabitEthernet0/0/0]dis ip int b
*down: administratively down
!down: FIB overload down
^down: standby
(l): loopback
(s): spoofing
(d): Dampening Suppressed
The number of interface that is UP in Physical is 6
The number of interface that is DOWN in Physical is 7
The number of interface that is UP in Protocol is 5
The number of interface that is DOWN in Protocol is 8
Interface                         IP Address/Mask      Physical   Protocol  
Ethernet0/0/0                     unassigned           down       down      
Ethernet0/0/1                     unassigned           down       down      
GigabitEthernet0/0/0              12.0.0.1/24          up         up        
GigabitEthernet0/0/1              unassigned           up         down      
GigabitEthernet0/0/1.10           192.168.10.1/24      up         up        
GigabitEthernet0/0/1.20           192.168.20.1/24      up         up        
GigabitEthernet0/0/2              14.0.0.1/24          up         up        
GigabitEthernet0/0/3              unassigned           down       down      
NULL0                             unassigned           up         up(s)   
[R1]ip route-static 15.0.0.0 24 12.0.0.2

R2:


<Huawei>sys
[Huawei]sysname R2
[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip add 12.0.0.2 24
[R2-GigabitEthernet0/0/0]un sh
[R2-GigabitEthernet0/0/0]q
[R2]dhcp enable 
[R2]int g0/0/1
[R2-GigabitEthernet0/0/1]ip add 15.0.0.1 24
[R2-GigabitEthernet0/0/1]dhcp select relay 
[R2-GigabitEthernet0/0/1]dhcp relay server-ip 14.0.0.2
[R2-GigabitEthernet0/0/1]un sh
[R2-GigabitEthernet0/0/1]q  
[R2]ip route-static 0.0.0.0 0.0.0.0 12.0.0.1
[R2]dis ip int b
*down: administratively down
!down: FIB overload down
^down: standby
(l): loopback
(s): spoofing
(d): Dampening Suppressed
The number of interface that is UP in Physical is 3
The number of interface that is DOWN in Physical is 8
The number of interface that is UP in Protocol is 3
The number of interface that is DOWN in Protocol is 8
Interface                         IP Address/Mask      Physical   Protocol  
Ethernet0/0/0                     unassigned           down       down      
Ethernet0/0/1                     unassigned           down       down      
GigabitEthernet0/0/0              12.0.0.2/24          up         up        
GigabitEthernet0/0/1              15.0.0.1/24          up         up        
GigabitEthernet0/0/2              unassigned           down       down      
GigabitEthernet0/0/3              unassigned           down       down      
NULL0                             unassigned           up         up(s)

R4:

<Huawei>sys
[Huawei]sysname R4
[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]ip add 14.0.0.2 24
[R4-GigabitEthernet0/0/0]q
[R4]dhcp enable
[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]dhcp select global 
[R4-GigabitEthernet0/0/0]un sh
[R4-GigabitEthernet0/0/0]dis this
#
interface GigabitEthernet0/0/0
 ip address 14.0.0.2 255.255.255.0
 dhcp select global
#
return
[R4-GigabitEthernet0/0/0]dis ip int b
*down: administratively down
!down: FIB overload down
^down: standby
(l): loopback
(s): spoofing
(d): Dampening Suppressed
The number of interface that is UP in Physical is 2
The number of interface that is DOWN in Physical is 9
The number of interface that is UP in Protocol is 2
The number of interface that is DOWN in Protocol is 9
Interface                         IP Address/Mask      Physical   Protocol  
Ethernet0/0/0                     unassigned           down       down      
Ethernet0/0/1                     unassigned           down       down      
GigabitEthernet0/0/0              14.0.0.2/24          up         up        
GigabitEthernet0/0/1              unassigned           down       down      
GigabitEthernet0/0/2              unassigned           down       down      
GigabitEthernet0/0/3              unassigned           down       down      
NULL0                             unassigned           up         up(s) 
[R4-GigabitEthernet0/0/0]q
[R4]ip pool DHCPV10
[R4-ip-pool-DHCPV10]network 192.168.10.0 mask 24    
[R4-ip-pool-DHCPV10]gateway-list 192.168.10.1
[R4-ip-pool-DHCPV10]dns-list 8.8.8.8 2.2.2.2
[R4-ip-pool-DHCPV10]q
[R4]ip pool DHCPV20
[R4-ip-pool-DHCPV20]network 192.168.20.0 mask 24
[R4-ip-pool-DHCPV20]gateway-list 192.168.20.1
[R4-ip-pool-DHCPV20]dns-list 8.8.8.8 2.2.2.2
[R4-ip-pool-DHCPV20]q
[R4]ip route-static 0.0.0.0 0.0.0.0 14.0.0.1

PC机获取IP地址

PC1:
PC>ipconfig /release
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:fea1:3b9e
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 0.0.0.0
Subnet mask.......................: 0.0.0.0
Gateway...........................: 0.0.0.0
Physical address..................: 54-89-98-A1-3B-9E
DNS server........................:
PC>ipconfig /renew
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:fea1:3b9e
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 192.168.10.254
Subnet mask.......................: 255.255.255.0
Gateway...........................: 192.168.10.1
Physical address..................: 54-89-98-A1-3B-9E
DNS server........................: 8.8.8.8
                                    2.2.2.2

PC2:
PC>ipconfig /release
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:feb4:ce3
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 0.0.0.0
Subnet mask.......................: 0.0.0.0
Gateway...........................: 0.0.0.0
Physical address..................: 54-89-98-B4-0C-E3
DNS server........................:
PC>ipconfig /renew
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:feb4:ce3
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 192.168.20.254
Subnet mask.......................: 255.255.255.0
Gateway...........................: 192.168.20.1
Physical address..................: 54-89-98-B4-0C-E3
DNS server........................: 8.8.8.8
                                    2.2.2.2

PC3:
PC>ipconfig /release
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:feff:10f2
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 0.0.0.0
Subnet mask.......................: 0.0.0.0
Gateway...........................: 0.0.0.0
Physical address..................: 54-89-98-FF-10-F2
DNS server........................:
PC>ipconfig /renew
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:feff:10f2
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 192.168.10.253
Subnet mask.......................: 255.255.255.0
Gateway...........................: 192.168.10.1
Physical address..................: 54-89-98-FF-10-F2
DNS server........................: 8.8.8.8
                                    2.2.2.2

PC4:
PC>ipconfig /release
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:fea9:2cf2
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 0.0.0.0
Subnet mask.......................: 0.0.0.0
Gateway...........................: 0.0.0.0
Physical address..................: 54-89-98-A9-2C-F2
DNS server........................:
PC>ipconfig /renew
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:fea9:2cf2
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 192.168.20.253
Subnet mask.......................: 255.255.255.0
Gateway...........................: 192.168.20.1
Physical address..................: 54-89-98-A9-2C-F2
DNS server........................: 8.8.8.8
                                    2.2.2.2
PC5:
PC>ipconfig /release
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:feed:3b15
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 0.0.0.0
Subnet mask.......................: 0.0.0.0
Gateway...........................: 0.0.0.0
Physical address..................: 54-89-98-ED-3B-15
DNS server........................:
PC>ipconfig /renew
IP Configuration
Link local IPv6 address...........: fe80::5689:98ff:feed:3b15
IPv6 address......................: :: / 128
IPv6 gateway......................: ::
IPv4 address......................: 15.0.0.254
Subnet mask.......................: 255.255.255.0
Gateway...........................: 15.0.0.1
Physical address..................: 54-89-98-ED-3B-15
DNS server........................: 2.2.2.2
                                    8.8.8.8

验证全网互通如下图:

华为DHCP中继实战

此时全网互通,试验成功!谢谢观看!