简单配置基于桥接,RIP,NAT,PAT的网络拓扑
推荐步骤:

  • WEB_Server、PC1用路由器模拟、桥接Server和客户端,设置和路由接口IP地址
  • 在R1和R2配置RIPv2全网互通
  • 在R1上开启基于端口PAT,将内部所有的流量映射到R1的f0/0接口
  • 配置静态NAT将web服务器发布到R1的f0/0接口上修改网站默认端口为8080,客户端PC2访问验证
  • 配置静态NAT将FTP服务器发布到R1的f0/0接口上发布端口21,客户端访问测试
    实验步骤:
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
  • WEB_Server、PC1用路由器模拟、桥接Server和客户端,设置和路由接口IP地址
    在R1进入0/0接口配置IP地址192.168.100.1
    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip address 192.168.100.1 255.255.255.0
    R1(config-if)#no shutdown
    在R1进入1/0接口配置IP地址192.168.10.254
    R1(config)#interface fastEthernet 1/0
    R1(config-if)#ip address 192.168.10.254 255.255.255.0
    R1(config-if)#no shutdown
    在R1进入3/0接口配置IP地址192.168.30.254
    R1(config)#interface fastEthernet 3/0
    R1(config-if)#ip address 192.168.30.254 255.255.255.0
    R1(config-if)#no shutdown
    在R1进入2/0接口配置IP地址192.168.20.254
    R1(config)#interface fastEthernet 2/0
    R1(config-if)#ip address 192.168.20.254 255.255.255.0
    R1(config-if)#no shutdown
    Show ip inter b查看IP是否配置成功
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    配置PC2桥接vm8的IP地址和网关
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    配置FTP-SERVER桥接vm1的IP地址和网关
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
  • 在R1和R2配置RIPv2全网互通
    在R1启动RIP进程,配置RIP版本2,宣告10.0 20.0 30.0 100.0直连路由
    R1(config)#router rip
    R1(config-router)#version 2
    R1(config-router)#network 192.168.10.0
    R1(config-router)#network 192.168.20.0
    R1(config-router)#network 192.168.30.0
    R1(config-router)#network 192.168.100.0
    R1(config-router)#no auto-summary
    Show ip route 查看路由表
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    Ping全网互通
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    在R2启动RIP进程,配置RIP版本2,宣告100.0 200.0直连网络
    R2(config)#router rip
    R2(config-router)#version 2
    R2(config-router)#network 192.168.100.0
    R2(config-router)#network 192.168.200.0
    R2(config-router)#no auto-summary
    Show ip route查看路由表
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    Ping全网互通
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    用VM1ping全网互通
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    在桥接VM8虚拟机ping全网互通
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
  • 在R1上开启基于端口PAT,将内部所有的流量映射到R1的f0/0接口
    开启内部接口
    R1(config)#interface fastEthernet 1/0
    R1(config-if)#ip nat inside
    R1(config-if)#exit
    R1(config)#interface fastEthernet 2/0
    R1(config-if)#ip nat inside
    R1(config-if)#exit
    R1(config)#interface fastEthernet 3/0
    R1(config-if)#ip nat inside
    R1(config-if)#exit
    开启外部接口
    R1(config)#interface fastEthernet 0/0
    R1(config-if)#ip nat outside
    R1(config-if)#exit
    创建ACL抓取流量
    R1(config)#access-list 10 permit 192.168.10.0 0.0.0.255
    R1(config)#access-list 10 permit 192.168.20.0 0.0.0.255
    R1(config)#access-list 10 permit 192.168.30.0 0.0.0.255
    将ACL抓取的流量映射到F0/0接口上
    R1(config)#ip nat inside source list 10 interface fastEthernet 0/0 overload
    R1(config)#exit
    开启PAT流量转换监控
    R1#debug ip nat
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
  • 配置静态NAT将web服务器发布到R1的f0/0接口上修改网站默认端口为8080,客户端PC2访问验证
    将内网WEB服务器10.10发布到100.1上,端口修改为8080
    R1(config)#ip nat inside source static tcp 192.168.10.10 80 192.168.100.1 8080 extendable
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    访问8080端口
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
  • 配置静态NAT将FTP服务器发布到R1的f0/0接口上发布端口21,客户端访问测试
    创建FTP目录
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    默认端口21
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    将内网的FTP服务192.168.20.10发布到外网192.168.100.1
    R1(config)#ip nat inside source static tcp 192.168.20.10 21 192.168.100.1 21 extendable
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑
    简单配置基于桥接,RIP,NAT,PAT的网络拓扑