一、H3C的前世今生

H3C的前身华为3COM公司,是华为与美国3COM公司的合资公司(有传言说是当时Cisco起诉华为抄袭它的东西,所以华为找了一家美国挺有实力而且关系不错的公司来给证明没有抄袭,这个公司就是3COM)。2006年,华为将在华为3COM中的49%股权以8.8亿美元出售给3COM公司。2007年,公司正式更名为“杭州华三通信技术有限公司”,简称“H3C”。

当前数据通信市场主要分为电信运营商和企业网市场,华为一直专注于运营商市场,而H3C主要专注于企业网市场。CISCO的业务则跨运营商和企业网市场,并在这两个市场上保持一定的领先地位。在运营商市场上华为是cisco的主要对手,而在企业网市场H3C是cisco的主要对手。Cisco在能源、金融、国际企业、电力等行业有优势,而H3C在政府、烟草、交通、中小企业及相关的政府采购有优势。在中国路由器与交换机领域,H3C的市场份额已位居第一。

依托在ip技术领域的深厚积累,H3C的产品体系主要包括:ip网络产品、ip无线产品、ip安全产品、ip存储产品、ip多媒体产品、ip管理产品和培训产品。下面简要介绍ip网络产品包含的路由系列产品和交换系列产品。

1、路由系列产品

H3C的路由器产品线与cisco路由器存在许多相似之处,其主要产品系列也都是针对不同网络规模用户而开发的,如针对小型企业的ER(enterprise router,企业路由器)、针对中型企业的MSR(multiple services router,多业务路由器)系列、针对大型企业和运行商的SR(service router,业务路由器)系列,具体型号如下:

H3C的前世今生及它的基础配置

其对应的应用环境和主要功能如下:

  • ER系列路由器:主要用于中小型企业的宽带接入低端路由器系列,主要定位与以太网、光纤和adsl wan接入的SMB市场和政府、企业机构、网吧等网络环境,如需要高速internet宽带的网吧、企业、学校和酒店等。

  • MSR系列路由器:是主要应用于大中型企业和集团公司分支机构的中端路由器系列。该系列路由器集数据、语音、安全、交换和用户开放的业务等于一体,是真正意义上的集成了多业务的路由器产品。这是在企业应用中最广的一类路由器系列,相当于思科的ISR系列路由器。

  • SR系列路由器:是主要应用于大型企业,或者一些行业用户,如电信,电力,金融,教育,政府机关等的万兆高端系列路由器系列。其中又根据目标用户分为两大部分,针对大型企业,以及像金融、教育、政府机关等这些网络规模较小,应用需求不是很高的用户推出了SR6600系列路由器,而针对运行商的IP骨干网、城域网及各种大型IP网络的核心和汇聚位置推出了SR8800系列路由器。

2、交换系列产品

H3C以太网交换机产品线分常齐全,从园区到数据中心,从十万兆到百兆,从高端到低端,从核心层到接入层有许多可选产品方案,可以灵活满足不同层次用户的需求。其中核心层基本上都是路由式交换机,带有强劲的路由功能,代表系列有S10500、S9500E、S7500E、S7500等;在汇聚层主要是全千兆智能交换机,代表系列主要有S5500-EI/SI、S5510、S5120-EI/SI、S5600等。在接入层基本上是上行支持千兆以太网技术,下行基本上都是百兆的,代表系列和机型主要有S3100-EI/SI、S3600-EI/SI、S3610、E328、E126等。SMB交换机是指应用于中小型企业的交换机系列,代表系列和机型有S1000/1200、S1500/E、S1650、S2100、S5000P、S5000E等。交换系列的产品如下所示:
H3C的前世今生及它的基础配置

除了为广大的园区和企业用户提供全系列的园区以太网交换机产品外,H3C还专门为大中型企业或者互联网企业提供专门为数据中心开发的交换机产品。因为数据中心规模一般不大,主要用于互联网或者数据库管理,不是一般交换机可以随便胜任的。规模稍大的一些数据中心网络汇聚层也可以选用核心层的交换机、毕竟这类网络中对设备的数据处理性能等各方面的要求都非常高。具体产品如下所示:

H3C的前世今生及它的基础配置

二、H3C的基础配置

上面啰嗦了那么一大堆,还是来看一看关于H3C的一些基础配置吧!

H3C的基础配置包括接口配置、Telnet接入、静态路由、ACL、VLAN与Trunk和NAT(其实配置起来和华为的设备一样)。

1、接口配置:

<h3c> system-view       //进入特权模式
[h3c] interface ethernet 0/0/0      //进入接口
[h3c-ethernet0/0/0] ip address 192.168.10.1 255.255.255.0   //配置接口ip地址
[h3ct-ethernet0/0/0] undo shutdown      //启用接口,默认开启
[h3c-ethernet0/0/0] description to LAN  //接口描述,可选配置
[h3c-ethernet0/0/0]quit     //退出

2、配置Telnet接入:

[h3c]telnet server enable       //默认开启
[h3c]local-user admin           //创建用户admin
[h3c-luser-admin]password cipher 2019.com       //配置密码
[h3c-luser-admin]service-type telnet        //指定服务器类型为telnet
[h3c-luser-admin]authorization-attribute level 3    //指定命令级别为3级
[h3c-luser-admin]quit
[h3ct]user-interface vty 0      //进入vty线路
[h3c-ui-vty 0]authentication-mode scheme    //配置用户认证方式
[h3c-ui-vty0]protocol inbound telnet    //支持telnet
[h3c-ui-vty0]quit

3、配置静态路由:

[h3c]ip rout-static 172.16.0.0 255.255.0.0 192.168.1.2   //配置静态路由
[h3c]ip route-static 0.0.0.0 0.0.0.0 200.0.0.2          //配置默认路由

4、配置vlan与Trunk:

[SW]VLAN 2      //创建vlan2
[sw-valn2]name caiwu        //配置vlan2名
[sw-vlan2]port e1/0/3 to e1/0/4 //将端口加入vlan
[sw-vlan2]quit
[sw]interface e1/0/5
[sw-ethernet1/0/5]port access vlan2 
[sw-ethernet1/0/5]quit
[sw]interface e1/0/1
[sw-ethernet1/0/1]port link-type trunk      //指定接口为trunk模式
[sw-ethernet1/0/1]port trunk permit vlan all    //允许所有vlan通过该trunk接口
[sw-ethernet1/0/1]quit

5、配置ACL:

H3C的ACL分为basic(标准)和advanced(扩展)两类:basic是基本acl编号2000-2999,对源地址控制,advanced是高级acl,编号3000-3999

命令如下:

acl advanced 3000    //创建一个高级ACL
rule 0 permit ip source 192.168.3.0 0.0.0.255  destination any
//允许源地址3.0网段去往任何目标地址

6、配置NAT:

NAT主要分为以下两类:
easy_ip(PAT):直接使用接口的ip地址作为转换后的报文源地址。
nat_server(静态PAT):将外部地址端口映射到内部服务器端口。

相关命令如下:

easy_ip的配置:
acl basic 2001
rule 5 permit source 192.168.2.0 255.255.255.0
int g0/0
ip add 202.202.202.2 255.255.255.0
undo shutdown
nat outbound 2001
nat_server的配置:
int g0/1
nat server protocol tcp global 200.200.200.3 80 inside 192.168.3.250 80
查看nat转换关系:dis nat session verbose