***的应用
×××的定义:×××(Virtual Private Network,虚拟专用网)

 广域网存在各种安全隐患
网上传输的数据有被窃听的风险
网上传输的数据有被篡改的危险
通信双方有被冒充的风险

×××的作用:

×××建立“保护”网络实体之间的通信
使用加密技术防止数据被窃听
数据完整性验证防止数据被破坏、篡改
通过认证机制确认身份,防止数据被截获、回放

配置步骤及思路:

1.分支公司的网关路由器
     路由方面的配置    
                           R1(config)#ip routing                                                                 开启路由功能
                   R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.20.2                             配置路由条目
            配置 ISAKMP 策略
                    R1(config)#crypto isakmp policy 1
                    R1(config-isakmap)#encryption 3des
                    R1(config-isakmap)#hash sha
                    R1(config-isakmap)#authentication pre-share
                    R1(config-isakmap)#group 2
                    R1(config)#crypto isakmp key tedu address 192.168.30.2
            配置 ACL
                    R1(config)#access-list 100 permit ip 192.168.10.0 0.0.0.255 192.168.10.0 0.0.0.255
            配置 IPSec 策略(转换集)
                    R1(config)#crypto ipsec transform-set yf-set esp-des ah-sha-hmac
            配置加密映射集
                    R1(config)#crypto map yf-map 1 ipsec-isakmp
                    R1(config-crypto-map)#set peer 192.168.30.2
                    R1(config-crypto-map)#set transform-set yf-set
                    R1(config-crypto-map)#match address 100
            将映射集应用在接口
                    R1(config)#interface f0/1
                    R1(config-if)#crypto map yf-map
    2.总公司的网关路由器
            注;加密和认证算法要与分公司匹配
            路由方面的配置
                    R2(config)#ip routing                                                                     开启路由功能
                   R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.20.2                          配置路由条目
                    R2(config)#ip route 0.0.0.0 0.0.0.0 192.168.30.1                          
            IPSec ××× 方面的配置
                    R2(config)#crypto isakmp policy 1
                    R2(config-isakmap)#encryption 3des
                    R2(config-isakmap)#hash sha
                    R2(config-isakmap)#authentication pre-share
                    R2(config-isakmap)#group 2
                    R2(config)#crypto isakmp key tedu address 192.168.20.1
            配置ACL
                    R2(config)#access-list 100 permit ip 192.168.10.0  0.0.0.255  192.168.1.0  0.0.0.255
            配置 IPSec 策略(转换集)
                    R2(config)#crypto ipsec transform-set yf-set esp-des ah-sha-hmac
            配置加密映射集
                    R2(config)#crypto map yf-map 1 ipsec-isakmp
                    R2(config-crypto-map)#set peer 192.168.20.1
                    R2(config-crypto-map)#set transform-set yf-set
                    R2(config-crypto-map)#match address 100
            将映射集应用在接口
                    R2(config)#interface f0/0
                    R2(config-if)#crypto map yf-map
        3.R3路由器的配置
              R3(config)#ip routing                                                                                       
              R3(config)#ip route 192.168.1.0  255.255.255.0  192.168.20.1                       开启路由功能
                   R1(config)#ip route 0.0.0.0 0.0.0.0 192.168.20.2                                       配置路由条目
                    R3(config)#ip route 192.168.10.0  255.255.255.0   192.168.30.2            配置路由条目
        4.验证,测试

ping服务器
***的应用
访问服务器
***的应用