vrrp的应用
配置步骤及思路:
一.配置pc机的ip
pc1:
ip 192.168.1.1
子网掩码:255.255.255.0
网关:192.168.1.254
pc2:
ip 192.168.2.1
子网掩码:255.255.255.0
网关:192.168.1.254
pc3:
ip 192.168.3.1
子网掩码:255.255.255.0
网关:192.168.1.254
pc4:
ip 192.168.4.1
子网掩码:255.255.255.0
网关:192.168.1.254
二.创建vlan并将端口加入设置trunk
创建vlan并将端口加入:

                  vlan batch  10 20 30 40               创建vlan10,20.30,40
                        interface  GE0/0/1                     进入端口
                              port link-type access                设置access模式
                                port default vlan 10                 将vlan10 加入
                       interface  GE0/0/2                     进入端口
                              port link-type access                设置access模式
                                port default vlan 20                 将vlan20 加入
                          interface  GE0/0/5                     进入端口
                              port link-type access                设置access模式
                                port default vlan 10                 将vlan30 加入
                       interface  GE0/0/6                    进入端口
                              port link-type access                设置access模式
                                port default vlan 20                 将vlan40 加入
            设置trunk:
                sw1:
                     interface   GE0/0/3                  进入端口
                                   port link-type trunk            设置trunl模式
                                            port trunk allow-pass vlan all    允许所有vlan通过
                            interface   GE0/0/4                  进入端口
                                   port link-type trunk            设置trunl模式
                                            port trunk allow-pass vlan all    允许所有vlan通过

                    sw2:
                          interface   GE0/0/1                  进入端口
                                   port link-type trunk            设置trunl模式
                                            port trunk allow-pass vlan all    允许所有vlan通过
                 sw3:
                       interface   GE0/0/1                  进入端口
                                   port link-type trunk            设置trunl模式
                                            port trunk allow-pass vlan all    允许所有vlan通过
        三.配置网关
               在sw2上:
                         interface vlan 10                  进入vlan10的虚拟端口
                                 ip address  192.168.1.254    255.255.255.0    配置ip
                         interface vlan 20                  进入vlan20的虚拟端口
                                 ip address  192.168.2.254    255.255.255.0    配置ip
                         interface vlan 30                    进入vlan30的虚拟端口
                                ip address  192.168.3.254    255.255.255.0    配置ip
                         interface vlan 40                  进入vlan20的虚拟端口
                                 ip address  192.168.4.254    255.255.255.0    配置ip
               在sw3上:
                      在sw3上配置网关主要起一个备份的作用,防止sw2上的链路中断
                         interface vlan 10                  进入vlan10的虚拟端口
                                 ip address  192.168.1.253    255.255.255.0    配置ip
                         interface vlan 20                  进入vlan20的虚拟端口
                                 ip address  192.168.2.253    255.255.255.0    配置ip
                         interface vlan 30                    进入vlan30的虚拟端口
                                ip address  192.168.3.253    255.255.255.0    配置ip
                         interface vlan 40                  进入vlan20的虚拟端口
                                 ip address  192.168.4.253    255.255.255.0    配置ip
四.配置VRRP(虚拟网关)
        在sw2上:
                         interface vlan 10                  进入vlan10的虚拟端口
                                 vrrp vrip 1 virtual-ip  192.168.1.250   配置虚拟网关
                                      vrrp vrip 1 priority 150            设置优先级
                                        vrrp vrip 1 track interface GE0/0/2 reduces  100   跟踪端口GE0/0/2的端口状态,如果down掉,则降低100,变为50
                             interface vlan 20                  进入vlan20的虚拟端口
                                 vrrp vrip 1 virtual-ip  192.168.2.250   配置虚拟网关
                                      vrrp vrip 1 priority 150            设置优先级
                                        vrrp vrip 1 track interface GE0/0/2 reduces  100   跟踪端口GE0/0/2的端口状态,如果down掉,则降低100,变为50         
                           interface vlan 30                  进入vlan30的虚拟端口
                                 vrrp vrip 1 virtual-ip  192.168.3.250   配置虚拟网关
                             interface vlan 40                  进入vlan40的虚拟端口
                                 vrrp vrip 1 virtual-ip  192.168.4.250   配置虚拟网关
               在sw3上:
                         interface vlan 10                  进入vlan10的虚拟端口
                                 vrrp vrip 1 virtual-ip  192.168.1.250   配置虚拟网关         
                             interface vlan 20                  进入vlan20的虚拟端口
                                 vrrp vrip 1 virtual-ip  192.168.2.250   配置虚拟网关     
                           interface vlan 30                  进入vlan30的虚拟端口
                                 vrrp vrip 1 virtual-ip  192.168.3.250   配置虚拟网关
                                      vrrp vrip 1 priority 150            设置优先级
                                        vrrp vrip 1 track interface GE0/0/2 reduces  100   跟踪

GE0/0/2的端口状态,如果down掉,则降低100,变为50
interface vlan 40 进入vlan40的虚拟端口
vrrp vrip 1 virtual-ip 192.168.4.250 配置虚拟网关
vrrp vrip 1 priority 150 设置优先级
vrrp vrip 1 track interface GE0/0/2 reduces 100 跟踪GE0/0/2的端口状态,如果down掉,则降低100,变为50
如果两条线路都没故障v10,v20从左面走,v30.v40从右面走既可以实现备份功能又能减轻单台服务器的压力
五.验证,测试
1.把pc机上的网关修改为虚拟网关
pc1:
ip 192.168.1.1
子网掩码:255.255.255.0
网关:192.168.1.250
pc2:
ip 192.168.2.1
子网掩码:255.255.255.0
网关:192.168.1.250
pc3:
ip 192.168.3.1
子网掩码:255.255.255.0
网关:192.168.1.250
pc4:
ip 192.168.4.1
子网掩码:255.255.255.0
网关:192.168.1.250
2.在命令行ping自己虚拟网关
ping 192.168.x.250 x代表不同网段
vrrp的应用
然后拼其它主机看是否能全网拼通
vrrp的应用
能拼成功说明实验成功