实验名称:网络的优化

vlan,trunk,stp,vrrp,ospf的多应用来实现网络的优化
配置步骤及思路:
一.给pc机配置ip
pc1:
ip 192.168.1.1
子网掩码:255.255.255.0
网关:192.168.1.254
pc2:
ip 192.168.2.1
子网掩码:255.255.255.0
网关:192.168.2.254
pc3:
ip 192.168.1.2
子网掩码:255.255.255.0
网关:192.168.1.254
pc4:
ip 192.168.2.2
子网掩码:255.255.255.0
网关:192.168.2.254
server1:
ip : 192.168.20.1
子网掩码:255.255.255.0
网关:192.168.20.254
二.创建vlan并将端口加入设置trunk
1.在sw1上创建vlan将对应端口加入设置trunk
vlan batch 10 20 创建vlan10 20
interface Eth0/0/1 进入端口
port link-type aceess 设置access模式
port default vlan 10 将端口加入vlan
设置trunk:
interface Eth0/0/11 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
interface Eth0/0/13 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
2.在sw2上创建vlan将对应端口加入设置trunk(要与sw1数据库保持一致)
vlan batch 10 20 创建vlan10 20
interface Eth0/0/1 进入端口
port link-type aceess 设置access模式
port default vlan 20 将端口加入vlan
设置trunk:
interface Eth0/0/11 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
interface Eth0/0/14 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
3.在sw3上创建vlan设置trunk(要与sw1,sw2数据库保持一致)
vlan batch 10 20 创建vlan10 20
设置trunk:
interface Eth0/0/13 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
interface Eth0/0/14 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
interface Eth0/0/12 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
4.在sw4上创建vlan将对应端口加入设置trunk
vlan batch 10 20 创建vlan10 20
interface Eth0/0/1 进入端口
port link-type aceess 设置access模式
port default vlan 10 将端口加入vlan
设置trunk:
interface Eth0/0/11 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
interface Eth0/0/13 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
5.在sw5上创建vlan将对应端口加入设置trunk(要与sw4数据库保持一致)
vlan batch 10 20 创建vlan10 20
interface Eth0/0/1 进入端口
port link-type aceess 设置access模式
port default vlan 20 将端口加入vlan
设置trunk:
interface Eth0/0/11 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
interface Eth0/0/14 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
6.在sw6上创建vlan设置trunk(要与sw4,sw5数据库保持一致)
vlan batch 10 20 创建vlan10 20
设置trunk:
interface Eth0/0/13 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
interface Eth0/0/14 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
interface Eth0/0/12 进入端口
port link-type trunk 设置trunk
port trunk allow-pass vlan all 允许所有vlan通过
三.修改STP(生成树协议)
1.在sw1,sw2,sw3上修改
display stp 查看sw1,sw2,sw3的stp,确定根交换机和非根交换机,找出阻塞端口(阻塞端口为ALTE)
这里查出阻塞端口为Eth0/0/13,sw2为根交换机,sw1为非根交换机,为了给交换机减压将sw3设置成根交换机。配置如下:
stp priorty 0 修改优先级为0(stp优先级越小越优先)
然后再输入display stp 查看那个是根交换机和非根交换机。
2.在sw4,sw5,sw6上修改
display stp 查看sw1,sw2,sw3的stp,确定根交换机和非根交换机,找出阻塞端口(阻塞端口为ALTE)
这里查出阻塞端口为Eth0/0/13,sw2为根交换机,sw1为非根交换机,为了给交换机减压将sw3设置成根交换机。配置如下:
stp priorty 0 修改优先级为0(stp优先级越小越优先)
然后再输入display stp 查看那个是根交换机和非根交换机。
四.配置VRRP(相当于备份)
1.在sw3上将端口加入vlan10
interface GE0/01 进入端口
port link-type access 设置access模式
port default vlan 10 将vlan10加入端口
interface GE0/0/2 进入端口
port link-type access 设置access模式
port default vlan 10 将vlan10加入端口
interface GE0/0/3 进入端口
port link-type access 设置access模式
port default vlan 10 将vlan10加入端口
2.在sw6上将端口加入vlan20
interface GE0/01 进入端口
port link-type access 设置access模式
port default vlan 20 将vlan20加入端口
interface GE0/0/2 进入端口
port link-type access 设置access模式
port default vlan 20 将vlan20加入端口
interface GE0/0/3 进入端口
port link-type access 设置access模式
port default vlan 20 将vlan20加入端口
在路由器AR1配置vlan10的网关和ARRP
在接口下配置网关:
interface GE0/0/0
ip address 192.168.1.254
在接口下配置虚拟网关(VRRP)
interface GE0/0/0
vrrp 1 ip 192.168.1.250 开启vrrp,配置虚拟网关
vrrp 1 priority 150 配置vrrp主机设备优先级。默认是100(vrrp优先级越大越优先)
vrrp vrid 1 track interface gi0/0/2 reduced 100 跟踪端口 gi0/0/2 的状态,如果 down, 则降低100,优先级变为 50;
在路由器AR2上配置vlan10的网关和ARRP
在接口下配置网关:
interface GE0/0/0
ip address 192.168.1.253
在接口下配置虚拟网关(VRRP)
interface GE0/0/0
vrrp 1 ip 192.168.1.250 开启vrrp,配置虚拟网关
vrrp 1 priority 130 配置vrrp主机设备优先级。默认是100(vrrp优先级越大越优先)
vrrp vrid 1 track interface gi0/0/2 reduced 100 跟踪端口 gi0/0/2 的状态,如果 down, 则降低100,优先级变为 30;
在路由器AR3上配置vlan10的网关和ARRP
在接口下配置网关:
interface GE0/0/0
ip address 192.168.1.252
在接口下配置虚拟网关(VRRP)
interface GE0/0/0
vrrp 1 ip 192.168.1.250 开启vrrp,配置虚拟网关
vrrp vrid 1 track interface gi0/0/2 reduced 100 跟踪端口 gi0/0/2 的状态,如果 down, 则降低100,优先级变为 10;
在路由器AR1配置vlan20的网关和ARRP
在接口下配置网关:
interface GE0/0/0
ip address 192.168.2.254
在接口下配置虚拟网关(VRRP)
interface GE0/0/0
vrrp 1 ip 192.168.2.250 开启vrrp,配置虚拟网关
vrrp 1 priority 150 配置vrrp主机设备优先级。默认是100(vrrp优先级越大越优先)
vrrp vrid 1 track interface gi0/0/2 reduced 100 跟踪端口 gi0/0/2 的状态,如果 down, 则降低100,优先级变为 50;
在路由器AR2上配置vlan20的网关和ARRP
在接口下配置网关:
interface GE0/0/0
ip address 192.168.2.253
在接口下配置虚拟网关(VRRP)
interface GE0/0/0
vrrp 1 ip 192.168.2.250 开启vrrp,配置虚拟网关
vrrp 1 priority 130 配置vrrp主机设备优先级。默认是100(vrrp优先级越大越优先)
vrrp vrid 1 track interface gi0/0/2 reduced 100 跟踪端口 gi0/0/2 的状态,如果 down, 则降低100,优先级变为 30;
在路由器AR3上配置vlan20的网关和ARRP
在接口下配置网关:
interface GE0/0/0
ip address 192.168.2.252
在接口下配置虚拟网关(VRRP)
interface GE0/0/0
vrrp 1 ip 192.168.2.250 开启vrrp,配置虚拟网关
vrrp 1 priority 110 配置vrrp主机设备优先级。默认是100(vrrp优先级越大越优先)
vrrp vrid 1 track interface gi0/0/2 reduced 100 跟踪端口 gi0/0/2 的状态,如果 down, 则降低100,优先级变为 10;
然后在pc机上将网管改成VRRP的虚拟网关
pc1:
网关:192.168.1.250
pc2:
网关:192.168.2.250
pc3:
网关:192.168.1.250
pc4:
网关:192.168.2.250
最后在pc机上ping修改后的网关看能拼通不,能拼通说明VRRP创建成功
五。配置交换机和路由器间的网址
路由器(路由器上不能创建vlan只能在端口下配置ip):
AR1:
interface GE0/0/2 进入端口
ip address 192.168.12.1 255.255.255.0 配置ip
AR2:
interface GE0/0/2 进入端口
ip address 192.168.13.1 255.255.255.0 配置ip
AR3:
interface GE0/0/3 进入端口
ip address 192.168.14.1 255.255.255.0 配置ip
交换机sw7上(交换机上不能在端口配置ip,只能在vlan的虚拟端口配置ip):
1.创建vlan 30 40 50 60
vlan batch 30 40 50 60
2.在vlan上的虚拟端口配置ip
interface vlan 30
p address 192.168.12.2 255.255.255.0
interface vlan 40
ip address 192.168.13.2 255.255.255.0
interface vlan 50
p address 192.168.14.2 255.255.255.0
interface vlan 60
ip address 192.168.19.1 255.255.255.0
路由器AR4(路由器上不能创建vlan只能在端口下配置ip)
interface GE0/0/1 进入端口
ip address 192.168.19.2 255.255.255.0 配置ip
interface GE0/0/0
ip address 192.168.20.254 255.255.255.0 配置server1的网关
六.创建OSPF区域
在路由器AR1上:
ospf {1} 创建ospf区域(id默认是1,可写可不写)
area 0 创建主区域0(0是主干区域,其它为非主干区域)
network 192.168.1.254 建立邻居表
network 192.168.2.254 建立邻居表
network 192.168.12.1 建立邻居表
在路由器AR2上:
ospf {1} 创建ospf区域(id默认是1,可写可不写)
area 0 创建主区域0(0是主干区域,其它为非主干区域)
network 192.168.1.253 建立邻居表
network 192.168.2.253 建立邻居表
network 192.168.13.1 建立邻居表
在路由器AR3上:
ospf {1} 创建ospf区域(id默认是1,可写可不写)
area 0 创建主区域0(0是主干区域,其它为非主干区域)
network 192.168.1.252 建立邻居表
network 192.168.2.252 建立邻居表
network 192.168.14.1 建立邻居表
在交换机sw7上:
ospf {1} 创建ospf区域(id默认是1,可写可不写)
area 0 创建主区域0(0是主干区域,其它为非主干区域)
network 192.168.12.2 建立邻居表
network 192.168.13.2 建立邻居表
network 192.168.14.2 建立邻居表
network 192.168.19.1 建立邻居表
在路由器AR4上:
ospf {1} 创建ospf区域(id默认是1,可写可不写)
area 0 创建主区域0(0是主干区域,其它为非主干区域)
network 192.168.19.2 建立邻居表
network 192.168.20.254 建立邻居表
查看邻居表的命令:
display ospf peer 查看ospf邻居表详细信息
display ospf brief 查看本地设备的ospf相关信息
七。验证,测试
拿任何一台pc机访问其他主机实现全网互通
然后在路由和交换机之间进任意一个端口输入shutdown,让此路不通看是否还能拼通(内网)
命令:ping x.x.x.x x.x.x.x代表ip地址