stp生成树协议
1、确定交换机的角色
根交换机:整个交换网络中,有且只有一个;
非根交换机:剩余的其他交换机,都称之为非根交换机

    注意:
        每一个非根交换机都会计算出一条去往根交换机的最短的、
        无环、2层数据转发路径,并且最终该路径是“转发”状态;

        选举原则:
              比较每个交换机的 BID (bridge ID):优先级+MAC地址
              优先级:默认值为 32768 ; 2个字节;
              MAC地址:使用的是交换机的主板MAC;6个字节;
                 比较原则 - 
                       首先比较优先级,越小越好;
                       其次比较MAC地址,越小越好;

2、确定端口的角色
        根端口:在每一个非根交换机上,有且只有一个;
                距离根交换机最近的端口;

        指定端口:在每一个"网段/segment"中,有且只有一个;
                距离根交换机最近的端口;

        非指定端口:其他所有端口,都叫做“非指定端口”

3、确定端口的状态
        down       -关闭(指的是当前端口没有启动STP)

        listening  -侦听,此时侦听的是网络中的所有的BPDU
                          目的是为了确定交换机和端口的角色;
                          端口在该状态停留15s;

        learning   -学习,该阶段主要是学习端口上收到的数据帧
                           的源MAC地址,从而形成 MAC地址表;
                           端口在该状态停留15s;

        forwarding -转发(最终状态),该状态实现数据包的发送和接收

        blocking   -阻塞(最终状态),该状态不能发送和接收数据包;
                                    只能接收 BPDU。

实验步骤及思路:
一.配置pc机的ip
pc14:
ip: 192.168.1.1
子网掩码:255.255.255.0
网关:192.168.1.254
pc15:
ip: 192.168.2.1
子网掩码:255.255.255.0
网关:192.168.2.254
pc16:
ip: 192.168.3.1
子网掩码:255.255.255.0
网关:192.168.3.254
pc17:
ip: 192.168.4.1
子网掩码:255.255.255.0
网关:192.168.4.254
pc18:
ip: 192.168.1.2
子网掩码:255.255.255.0
网关:192.168.1.254
pc19:
ip: 192.168.2.2
子网掩码:255.255.255.0
网关:192.168.2.254
pc20:
ip: 192.168.3.2
子网掩码:255.255.255.0
网关:192.168.3.254
pc21:
ip: 192.168.4.2
子网掩码:255.255.255.0
网关:192.168.4.254
pc10:
ip: 192.168.1.3
子网掩码:255.255.255.0
网关:192.168.1.254
pc11:
ip: 192.168.2.3
子网掩码:255.255.255.0
网关:192.168.2.254
pc12:
ip: 192.168.3.3
子网掩码:255.255.255.0
网关:192.168.3.254
pc13:
ip: 192.168.4.3
子网掩码:255.255.255.0
网关:192.168.4.254
二.创建vlan并将端口加入并设置trunk
1.在sw1上创建vlan并将端口加入:
vlan batch 10 20 30 40
interface g0/0/3
port link type-access
port default vlan 10
interface g0/0/4
port link type-access
port default vlan 20
interface g0/0/5
port link type-access
port default vlan 30
interface g0/0/6
port link type-access
port default vlan 40
设置trunk:
interface ge0/0/1
port link-type trunk
port trunk allow-pass vlan all
interface ge0/0/2
port link-type trunk
port trunk allow-pass vlan all
2.在sw2上创建vlan并将端口加入:
vlan batch 10 20 30 40
interface g0/0/3
port link type-access
port default vlan 10
interface g0/0/4
port link type-access
port default vlan 20
interface g0/0/5
port link type-access
port default vlan 30
interface g0/0/6
port link type-access
port default vlan 40
设置trunk:
interface ge0/0/1
port link-type trunk
port trunk allow-pass vlan all
interface ge0/0/2
port link-type trunk
port trunk allow-pass vlan all
3.在sw3上创建vlan并将端口加入:
vlan batch 10 20 30 40
interface g0/0/6
port link type-access
port default vlan 10
interface g0/0/5
port link type-access
port default vlan 20
interface g0/0/4
port link type-access
port default vlan 30
interface g0/0/3
port link type-access
port default vlan 40
设置trunk:
interface ge0/0/1
port link-type trunk
port trunk allow-pass vlan all
interface ge0/0/2
port link-type trunk
port trunk allow-pass vlan all
三.配置MSTP生成树
1.首先在sw1,sw2,sw3上确定根交换机和辅根交换机
display stp brief 查看stp
这里sw2是根交换机,sw1是辅根交换机
2.STP参数修改(华为):
(1)修改交换机的 STP 优先级:
[SW] stp priority {value} -> 必须得是4096的倍数
(2)修改交换机的 STP 模式
[SW] stp mode {stp | rstp | mstp }
(3)修改交换机的端口的 STP cost :
[SW]interface fas0/13
[sw-fas0/13]stp cost {value}
(4)在交换机上关闭/开启 STP :
[sw]stp disable -> 关闭 STP ;
[sw]stp enable -> 开启 STP ,默认是开启的;
3.配置MSTP

  • MST域(region),同一个域中,可以同时包含多个实例;
    • MSTI(instance),即MST 实例,一个MSTI 可以同时关联多个 VLAN
      1.在sw1上配置 MST region
      stp region-configuration
      region-name aaa 配置 region 的名字;
      instance 1 vlan 10 20
      instance 2 vlan 30 40
      active region-configuration
      1. .在sw2上配置 MST region
        stp region-configuration
        region-name aaa 配置 region 的名字;
        instance 1 vlan 10 20
        instance 2 vlan 30 40
        active region-configuration
        3.配置主根和辅根
        1.在sw2上配置主根
        stp instance 1 priority 0
        stp instance 2 priority 4096 将 SW2设置为 实例id 的根;
        2.在sw1上配置主根
        stp instance 2 priority 0
        stp instance 1 priority 4096 将 SW1设置为 实例id 的根;
        4.验证
        display stp instance (id)
        四。验证,测试
        堵塞i交换机之间的任何一根线看是否能全网通
        能实现全网通,说明实验成功