如何创建DHCP中继让电脑自动获得IP?(化为)
实验步骤及思路:
一.先给pc机配置ip
pc1:
ip 192.168.1.1
子网掩码:255.255.255.0
网关:192.168.1.254
pc2:
ip 192.168.2.1
子网掩码:255.255.255.0
网关:192.168.2.254
pc3:
ip 192.168.1.2
子网掩码:255.255.255.0
网关:192.168.1.254
pc4:
ip 192.168.2.2
子网掩码:255.255.255.0
网关:192.168.2.254
二.在lsw8上创建vlan并将端口加入
vlan batch 10 20 创建vlan10,20
interface ge0/0/1 进入端口
port link-type access
port default vlan 10 将vlan10加入端口
interface ge0/0/3 进入端口
port link-type access
port default vlan 20 将vlan20加入端口
interface ge0/0/2
port link-type trunk 将ge0/0/2端口设置为trunk模式
port trunk allow-pass vlan all 允许所有vlan通过
三.在lsw9上创建vlan并将端口加入
vlan batch 10 20 创建vlan10,20
interface ge0/0/1 进入端口
port link-type access
port default vlan 10 将vlan10加入端口
interface ge0/0/3 进入端口
port link-type access
port default vlan 20 将vlan20加入端口
interface ge0/0/2
port link-type trunk 将ge0/0/2端口设置为trunk模式
port trunk allow-pass vlan all 允许所有vlan通过
四.在lsw7上配置网关设置trunk
设置trunk:
interface ge0/0/2
port link-type trunk 将ge0/0/1端口设置为trunk模式
port trunk allow-pass vlan all 允许所有vlan通过
interface ge0/0/2
port link-type trunk 将ge0/0/2端口设置为trunk模式
port trunk allow-pass vlan all 允许所有vlan通过
配置网关:
vlan batch 10,20 创建vlan10,20
interface vlan 10 进入vlan10的虚拟端口
ip address 192.168.1.254 配置网关
interface vlan 20 进入vlan20的虚拟端口
ip address 192.168.2.254 配置网关
因为ge0/0/3端口下不能配置ip所以要创建一个vlan30在虚拟端口上配置ip
vlan 30 创建vlan30
interface vlan 30 进入vlan10的虚拟端口
ip address 192.168.12.1 255.255.255.0 配置ip
五.在路由器上配置ip设置静态路由
配置ip
interface ge0/0/0 进入端口
ip address 192.168.12.2 255.255.255.0 配置ip
设置静态路由:
因为路由器在回包时不知去往哪个网段所以用B类地址来让它既包含1.0网段又包含2.0的网段,然后交给它的下一跳192.168.12.1
ip rout-static 192.168.0.0 255.255.0.0 192.168.12.1
六.验证,测试
用任何一个pc机访问别的网段,实现全网通(创建DHCP的前提)
七.创建DHCP地址池
一个地址池只能包含一个vlan
为vlan10创建 地址池
ip pool vlan-10 创建 IP dhcp 地址池;
network 192.168.1.0 mask 255.255.255.0 配置网段;
gateway-list 192.168.1.254 配置网关;
dns-list 8.8.8.8 配置 DNS 服务器
lease day 3 配置租用期限

                    为vlan20创建 地址池
                        ip  pool  vlan-20            创建 IP dhcp 地址池;
                               network 192.168.2.0 mask  255.255.255.0   配置网段;
                                    gateway-list  192.168.2.254          配置网关;
                         dns-list 8.8.8.8                                配置 DNS 服务器
                          lease day 3                                   配置租用期限
                            dhcp  enable                                 在全局模式下 开启 DHCP 服务
                    interface vlan  10                       进入vlan10的虚拟端口
                                 dhcp select global           表示的是当端口上收到 DHCP 报文以后 直接去 DHCP 服务器在全局配置的IP 地址池中选择一个可用的IP地址;    
                             interface vlan  20                       进入vlan20的虚拟端口
                                 dhcp select global           表示的是当端口上收到 DHCP 报文以后 直接去 DHCP 服务器在全局配置的IP 地址池中选择一个可用的IP地址;    
八.在lsw8上配置中继(当DHCP服务器与DHCP 客户端在不同网段的时候,使用该技术。可以让 DHCP 客户端发送的 DHCP 请求以 “单播”的方式,转发 到 DHCP 服务器上。)
            dhcp enable                        在全局模式下 开启DHCP 服务
          interface vlan 10                 进入vlan10的虚拟端 
                        dhcp select relay                    
        dhcp relay server-ip 192.168.20.1       该地址表示的是DHCP服务器地址
                       interface vlan 20                 进入vlan10的虚拟端口
         dhcp select relay                    
        dhcp relay server-ip 192.168.20.1       该地址表示的是DHCP服务器地址
九.验证,测试,保存
      把pc机设置成DHCP模式,如下:

如何创建DHCP中继让电脑自动获得IP?(化为)
然后再pc机中的命令行输入ipconfig,效果如下:
如何创建DHCP中继让电脑自动获得IP?(化为)