实验名称:不连续区域的互通以及数据的备份

不连续区域的互通以及数据的备份
配置步骤及思路:
一。配置路由器的IP
1.配置AR1的IP
system-view 进入系统模式
interface ge0/0/1 进入接口
ip address 192.168.1.1 255.255.255.0 配置ip
interface ge0/0/0 进入接口
ip address 192.168.3.1 配置ip
2.配置AR2的IP
system-view 进入系统模式
interface ge0/0/0 进入接口
ip address 192.168.1.2 255.255.255.0 配置ip
interface ge0/0/1 进入接口
ip address 192.168.2.1 25.255.255.0 配置ip
interface ge0/0/1 进入接口
ip address 192.168.5.2 255.255.255.0 配置ip
3..配置AR3的IP
system-view 进入系统模式
interface ge0/0/0 进入接口
ip address 192.168.2.2 255.255.255.0 配置ip
interface ge0/0/1 进入接口
ip address 192.168.4.1 配置ip
4..配置AR4的IP
system-view 进入系统模式
interface ge0/0/0 进入接口
ip address 192.168.3.2 255.255.255.0 配置ip
interface ge0/0/1 进入接口
ip address 192.168.6.1 配置ip
给pc1配置ip
100.1.1.1
子网掩码:255.255.255.0
网关:100.1.1.254
interface Ethernet4/0/0 进入接口
ip address 100.1.1.254 配置pc1的网关
5.配置AR5的IP
system-view 进入系统模式
interface ge0/0/0 进入接口
ip address 192.168.4.2 255.255.255.0 配置ip
给pc3配置ip
100.1.3.1
子网掩码:255.255.255.0
网关:100.1.3.254
interface ge0/0/1 进入接口
ip address 100.1.3.254 配置pc3的网关
6.配置AR6的IP
system-view 进入系统模式
interface ge0/0/0 进入接口
ip address 192.168.5.1 255.255.255.0 配置ip
interface ge0/0/1 进入接口
ip address 192.168.6.1 255.255.255.0 配置ip
7.配置AR7的IP
system-view 进入系统模式
interface ge0/0/0 进入接口
ip address 192.168.7.2 255.255.255.0 配置ip
给pc2配置ip
100.1.2.1
子网掩码:255.255.255.0
网关:100.1.2.254
interface ge0/0/1 进入接口
ip address 100.1.2.254 配置pc2的网关
二.配置虚拟端口
1.配置AR1的虚拟端口
interface loopback
192.168.10.1 255.255.255.0
2.配置AR2的虚拟端口
interface loopback
192.168.20.1 255.255.255.0
3.配置AR3的虚拟端口
interface loopback
192.168.30.1 255.255.255.0
4.配置AR4的虚拟端口
interface loopback
192.168.40.1 255.255.255.0
5.配置AR5的虚拟端口
interface loopback
192.168.50.1 255.255.255.0
6.配置AR6的虚拟端口
interface loopback
192.168.60.1 255.255.255.0
7.配置AR7的虚拟端口
interface loopback
192.168.70.1 255.255.255.0
三.创建ospf区域
1.创建AR1的ospf区域
ospf 创建ospf
area 0 创建主干区域(主干区域必须是0)
network 192.168.1.1 0.0.0.0 宣告路由
network 192.168.10.1 0.0.0.0 宣告路由
ospf 创建ospf
area 25 创建非干区域(非主干区域可以是其他任意值)
network 192.168.3.1 0.0.0.0 宣告路由
2.创建AR2的ospf区域
ospf 创建ospf
area 0 创建主干区域(主干区域必须是0)
network 192.168.1.2 0.0.0.0 宣告路由
network 192.168.2.1 0.0.0.0 宣告路由
network 192.168.20.1 0.0.0.0 宣告路由
3.创建AR3的ospf区域
ospf 创建ospf
area 0 创建主干区域(主干区域必须是0)
network 192.168.2.2 0.0.0.0 宣告路由
network 192.168.30.1 0.0.0.0 宣告路由
ospf 创建ospf
area 35 创建非干区域(非主干区域可以是其他任意值)
network 192.168.4.1 0.0.0.0 宣告路由
4.创建AR4的ospf区域
ospf 创建ospf
area 25 创建非主干区域
network 192.168.3.2 0.0.0.0 宣告路由
network 192.168.6.1 0.0.0.0 宣告路由
5.创建AR5的ospf区域
ospf 创建ospf
area 35 创建非主干区域
network 192.168.4.2 0.0.0.0 宣告路由
network 192.168.50.1 0.0.0.0 宣告路由
network 100.1.3.254 0.0.0.0 宣告路由
6 .创建AR6的ospf区域
AR6路由器的作用是起备份作用,可以防止AR1出现问题,不影响整个链路的互通
ospf 创建ospf
area 0 创建主干区域
network 192.168.5.1 0.0.0.0 宣告路由
network 192.168.60.1 0.0.0.0 宣告路由
ospf 创建ospf
area 25 创建非干区域
network 192.168.6.1 0.0.0.0 宣告路由

三.让不连续区域实现互通
    因为非骨干区域必须同时连接着骨干区域和非骨干区域,所以AR4和AR5不能通信
        解决办法:
    1.  在AR7创建新的的ospf进程
         ospf   2       创建ospf
                 area 45        创建非主干区域
                 network 192.168.7.2    0.0.0.0    宣告路由
                 network 192.168.70.1  0.0.0.0    宣告路由
                 network 100.1.2.254   0.0.0.0  宣告路由
        2.在AR4上创建
          ospf 2
            area 45
            network   192.168.7.1 0.0.0.0       宣告路由
            network   100.1.1.254   0.0.0.0       宣告路由
            3.在AR4建立邻居关系
                ospf 1
                         import-route ospf  2  
                  ospf 2
                        import-route ospf  1     
                    注:   ospf不同进程是相互包含关系,构建不同的 OSPF 进程,让路由的传递是以外部路由的方式呈现。
四。验证,测试
    在pc1上ping 任意一个ip地址让它能互通,最终实现全网互通