一、拓扑展示——华为OSPF区域划分

中型企业网络构建——OSPF区域划分(特殊域)

所需设备:9台路由器,5台PC机

PS:此拓扑结构并非适用所有物理环境

实验目的:按照拓扑图配置相关区域,并实现全网互通



二、什么是OSPF

OSPF(SPF)是一种基于链路状态的且具有公有标准的路由协议,其核心思想就是,每台路由器都将自己的链路状态共享给其它路由器,在此基础上,每台路由器就可以根据自己的链路状态以及其他路由器的链路状态计算出自己去往各个目的地的路由。

OSPF理论上是没有网络规模限制的,并且支持网络的层次化设计,可以将网络分为2层。
而层是通过“区域”的概念进行区分的;分为两个区域:骨干区域和非骨干区域。
且所有非骨干区域必须与骨干区域直接连接,才能互相通讯

非骨干区域分为普通区域和特殊区域,那么什么是特殊区域呢?

OSPF 特殊区域是指的是那些不允许 5 类 LSA 存在的区域
分类:
1)STUB区域 : 末节区域,该区域中是不允许存在4、5类LSA的,所以该区域的所有路由器都没有外部路由,那么,为了与外部路由进行数据互通,STUB区域的ABR,向stub自动产生了一个默认路由。
2)Totally STUB区域 : 完全末节区域,该区域中不允许存在3、4、5类LSA(仅保留一个特殊的3类LSA,表示默认路由);
该区域可以减小STUB区域中的数据库的大小,同时,还可以减少其他区域的不稳定,对该区域造成的不良影响。
3)NSSA(No So STUB Area)区域:该区域不允许4、5类LSA,但是是允许外部路由存在的;外部路由的表现方式为7类LSA。
#7类LSA,仅仅能存在于 NSSA 区域,所以只有1、2、3、7类LSA
4) Totally NSSA区域:与NSSA相比,也是少了明细的3类LSA表示的路由;所以只有1、2、7类LSA;
该区域仅仅通过NSSA区域中的ABR自动产生的一个7类LSA表示的默认路由,就可以实现NSSA区域与其他区域和外部路由的互通



三、IP网段划分

路由器区间编号 网段划分
R1<——>R2 192.168.12.0/24
R1<——>R5 192.168.15.0/24
R2<——>R3 192.168.23.0/24
R2<——>R5 192.168.25.0/24
R2<——>R6 192.168.26.0/24
R3<——>R7 192.168.37.0/24
R4<——>R8 192.168.48.0/24
R5<——>R9 192.168.59.0/24
R5<——>PC1 192.168.1.0/24
R9<——>PC2 192.168.2.0/24
R6<——>PC3 192.168.3.0/24
R7<——>PC4 192.168.4.0/24
R8<——>PC5 192.168.5.0/24


四、实验相关配置

1.首先,给所有路由器的每个直连端口及测试端口(loopback,虚拟端口)配置IP地址

 [R1]interface g 0/0/1
 [R1-GigabitEthernet0/0/1]ip address 192.168.12.1 24 
 [R1-GigabitEthernet0/0/1]undo shutdown        //  激活端口
 Info: Interface GigabitEthernet0/0/1 is not shutdown.    //  端口已激活
 [R1-GigabitEthernet0/0/1]quit
 [R1]interface GigabitEthernet 0/0/0
 [R1-GigabitEthernet0/0/0]ip address 192.168.15.1 24
 [R1-GigabitEthernet0/0/0]undo shutdown 
 Info: Interface GigabitEthernet0/0/0 is not shutdown.
 [R1-GigabitEthernet0/0/0]quit  
 [R1]interface LoopBack 0
 [R1-LoopBack0]ip address 1.1.1.1 24

 [R2]interface GigabitEthernet 0/0/1
 [R2-GigabitEthernet0/0/1]ip address 192.168.12.1 24
 [R2-GigabitEthernet0/0/1]undo shutdown
 [R2-GigabitEthernet0/0/1]quit
 [R2]interface GigabitEthernet 0/0/2
 [R2-GigabitEthernet0/0/2]ip address 192.168.23.2 24
 [R2-GigabitEthernet0/0/2]undo shutdown 
 [R2-GigabitEthernet0/0/2]quit 
 [R2]interface GigabitEthernet 0/0/0
 [R2-GigabitEthernet0/0/0]ip address 192.168.26.2 24
 [R2-GigabitEthernet0/0/0]undo shutdown .
 [R2-GigabitEthernet0/0/0]quit
 [R2]in g 4/0/0
 [R2-GigabitEthernet4/0/0]ip ad 192.168.25.2 24
 [R2-GigabitEthernet4/0/0]undo shutdown
 [R2-GigabitEthernet4/0/0]quit
 [R2]interface LoopBack 0
 [R2-LoopBack0]ip address 2.2.2.2 24

 [R3]interface GigabitEthernet 0/0/2
 [R3-GigabitEthernet0/0/2]ip address 192.168.23.3 24 
 [R3-GigabitEthernet0/0/2]undo shutdown
 [R3-GigabitEthernet0/0/2]quit 
 [R3]interface GigabitEthernet 0/0/1
 [R3-GigabitEthernet0/0/1]ip address 192.168.34.3 24 
 [R3-GigabitEthernet0/0/1]undo shutdown
 [R3-GigabitEthernet0/0/1]quit
 [R3]interface GigabitEthernet 0/0/0
 [R3-GigabitEthernet0/0/0]ip address 192.168.37.3 24 
 [R3-GigabitEthernet0/0/0]undo shutdown
 [R3-GigabitEthernet0/0/0]quit
 [R3]interface Loopback 0
 [R3-LoopBack0]ip address 3.3.3.3 24

 [R4]interface GigabitEthernet 0/0/1
 [R4-GigabitEthernet0/0/1]ip add
 [R4-GigabitEthernet0/0/1]ip address 192.168.34.4 24
 [R4-GigabitEthernet0/0/1]undo shutdown 
 [R4-GigabitEthernet0/0/1]quit
 [R4]interface GigabitEthernet 0/0/0
 [R4-GigabitEthernet0/0/0]ip address 192.168.48.4 24     
 [R4-GigabitEthernet0/0/0]undo shutdown
 [R4-GigabitEthernet0/0/0]interface loopback 0
 [R4-LoopBack0]ip add 4.4.4.4 24

 [R5]int g 0/0/0
 [R5-GigabitEthernet0/0/0]ip ad 192.168.15.5 24
 [R5-GigabitEthernet0/0/0]un sh
 [R5-GigabitEthernet0/0/0]in g 4/0/0
 [R5-GigabitEthernet4/0/0]ip ad 192.168.25.5 24
 [R5-GigabitEthernet4/0/0]un sh
 [R5-GigabitEthernet4/0/0]in g 0/0/2
 [R5-GigabitEthernet0/0/2]ip ad 192.168.59.5 24
 [R5-GigabitEthernet0/0/2]un sh
 [R5-GigabitEthernet0/0/2]in g 0/0/1
 [R5-GigabitEthernet0/0/1]ip ad 192.168.1.254 24   //  PC1的网关
 [R5-GigabitEthernet0/0/1]un sh
 [R5-GigabitEthernet0/0/1]in loo 0
 [R5-LoopBack0]ip ad 5.5.5.5 24

 [R6]in g 0/0/0
 [R6-GigabitEthernet0/0/0]ip ad 192.168.26.6 24
 [R6-GigabitEthernet0/0/0]un sh
 [R6-GigabitEthernet0/0/0]in g 0/0/1           
 [R6-GigabitEthernet0/0/1]ip ad 192.168.3.254 24    //  PC3的网关
 [R6-GigabitEthernet0/0/1]un sh
 [R6-GigabitEthernet0/0/1]in loo 0
 [R6-LoopBack0]ip ad 6.6.6.6 24

 [R7]interface GigabitEthernet 0/0/0
 [R7-GigabitEthernet0/0/0]ip address 192.168.37.7 24
 [R7-GigabitEthernet0/0/0]undo shutdown
 [R7-G]in g 0/0/1
 [R7-GigabitEthernet0/0/1]ip ad 192.168.4.254 24   //   PC4的网关
 [R7-GigabitEthernet0/0/1]un sh
 [R7-GigabitEthernet0/0/1]in loo 0
 [R7-LoopBack0]ip ad 7.7.7.7 24

 [R8]interface GIgabitEthernet 0/0/0
 [R8-GigabitEthernet0/0/0]ip address 192.168.48.8 24
 [R8-GigabitEthernet0/0/0]
 [R8-GigabitEthernet0/0/0]undo shutdown
 [R8-GigabitEthernet0/0/0]in g 0/0/1
 [R8-GigabitEthernet0/0/1]ip ad 192.168.5.254 24   //   PC5的网关
 [R8-GigabitEthernet0/0/1]un sh
 [R8-GigabitEthernet0/0/1]in loo 0
 [R8-LoopBack0]ip ad 8.8.8.8 24

 [R9]interface GigabitEthernet 0/0/2
 [R9-GigabitEthernet0/0/2]ip address 192.168.59.9 24
 [R9-GigabitEthernet0/0/2]undo shutdown
 [R9-GigabitEthernet0/0/2]in g 0/0/0
 [R9-GigabitEthernet0/0/0]ip ad 192.168.2.254 24     //    PC2的网关
 [R9-GigabitEthernet0/0/0]un sh
 [R9-GigabitEthernet0/0/0]in loo 0
 [R9-LoopBack0]ip ad 9.9.9.9 24