简单到让人发指   配置起来确让人头痛   (思科)

要求:
20个vlan
dhcp服务器分配ip地址
全网互通

配置思路
1,首先配置vlan
注意:各自的vlan中的所有交换机都需配上各自的vlan
汇聚层的交换机需要拥有所有接入层的交换机的vlan

vlan配置:
Switch>enable
Switch#configure //进入配置界面
Switch(config)#vlan 5 //创建vlan3
Switch(config-vlan)#exit //退回上一步

Switch(config)#interface vlan 5 //进入vlan
Switch(config-if)#ip address 192.168.5.254 255.255.255.0 // 在三层交换机上配置SVI,交换机上的虚拟端口用做vlan的网关

2,配置端口
注意:交换机之间相连的端口都需要配置为trunk
接入pc的端口需配置为access
至于汇聚层的三层交换机之间可以开启三层功能配置IP地址
然后配置静态路由

trunk端口配置命令:

Switch>enable
Switch#configure
Configuring from terminal, memory, or network [terminal]? //回车就行了
Switch(config)#interface fastEthernet 0/5 //进入端口
Switch(config-if)#switchport trunk encapsulation dot1q //定义vlan封装方式
Switch(config-if)#switchport mode trunk //定义端口模式

access 端口配置:

Switch>enable
Switch(config)#interface fastEthernet 0/5 //进入端口
Switch(config-if)#switchport mode access //定义端口模式
Switch(config-if)#switchport access vlan 5 // 将端口加入vlan

4,配置静态路由

配置命令
Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.80.1 //自己跳向对方

Switch(config)#ip route 0.0.0.0 0.0.0.0 192.168.80.2 //对方跳向自己

5,配置dhcp服务器
注意需要配置中继
进入每个vlan的虚拟网关中配置

中继配置命令
Switch(config-if)#ip helper-address 192.168.20.1 注意这个地址需为dhcp服务器的地址 在vlan的虚拟网关中配置

dhcp服务器用每个vlan的网关区分IP地址该配给谁
所以网关需要仔细配置

注:本拓扑汇聚层的三层交换机之间可开启三层交换功能来用
也可以做成 trunk但是需要他们有相同的vlan才能互通(三次交换机开启路由功能//ip routing)