VLAN配置思路:
1、创建vlan
sw1(config)#vlan 12
sw1(config-vlan)#name CAIWU
2、配置端口模式
sw1(config)#interface fas0/1 | fas0/2
sw1(config-if)#no shutdown
sw1(config-if)#switchport mode access
3、配置端口属于的vlan
sw1(config)#interface fas0/1 | fas0/2
sw1(config-if)#switchport access vlan 12
4、验证与测试
PC-1: 192.168.12.1 255.255.255.0
PC-2: 192.168.12.2 255.255.255.0
PC-1: ping 192.168.12.2

同样的操作步骤,完成 VLAN 34 的配置与主机之间的连通性测试;

删除VLAN:
1、将 VLAN 中的成员端口移除掉;
interface fas0/1
no switchport access vlan 12
2、删除 vlan ;
no vlan 12
3、验证(实际工作中 - 验证并保存配置)


华为交换机配置 VLAN :
1、创建VLAN
[sw1]vlan 10 //创建一个VLAN,并进入 VLAN 10 ;
[sw1-vlan10]description AAA // 为vlan配置一个名字;
2、配置端口模式
[sw1]interface gi0/0/1
[sw1-gi0/0/1]port link-type access //指定端口为access模式
3、将端口放入指定的 VLAN
[sw1]interface gi0/0/1
[sw1-gi0/0/1]port default vlan 10 //将端口放入vlan10
4、验证、测试、保存
[sw1]display vlan
PC-1 :
192.168.10.1 255.255.255.0
PC-2 :
192.168.10.2 255.255.255.0
删除 VLAN :
[sw1]undo vlan 10 //删除以后,成员端口会自动的回归到vlan1;
批量创建/删除 VLAN :
[sw1]vlan batch 10 20 30 40 50// 创建vlan 10,20,30,40,50;
[sw1]vlan batch 10 to 20 // 创建vlan 10,11,12,.....,20;
[sw1]undo vlan batch 10 to 20 // 批量删除10,11,12,....,20;


Trunk:
为了能够在同一个链路上同时传输多个 VLAN 的数据,
必须将链路的模式配置为 trunk 模式。

该类型的链路上的数据,是需要携带 vlan 标签的;
该链路为数据打标签的方式,分为两种:
      1、ISL  : inter-switch link ,交换机之间的链路协议,
                 思科的私有协议;现在很多交换机已经不支持了;
                 标签总长度为30个字节,
                 其中ISL头部是26个字节,ISL尾部是4个字节;

      2、802.1q :是公有标准,任何厂家的设备都支持使用该协议
                  为2层数据打标签。
                  标签长度为4个字节;
一般用来链接“交换机”设备。

Access:
这种类型的链路,同一时刻,只能属于一个 VLAN ;
传输的数据,是没有任何标签的。

一般用来连接“非交换机”设备!

配置 Trunk链路:(华为)
1、配置端口的链路类型
interface gi0/0/24
port link-type trunk
2、设置 Trunk 链路上允许通过的 VLAN
interface gi0/0/24
port trunk allow-pass vlan all
3、验证 、测试、保存
display port vlan


配置 Trunk链路:(思科)
1、配置链路的 trunk 封装协议(ISL或者 802.1q) [可选]
interface fas0/24
switchport trunk encapsulation dot1q | isl

 2、配置链路的模式为 trunk 
        interface fas0/24 
            switchport  mode  trunk 

 3、验证、测试与保存
        show interface trunk //查看思科交换机上的 trunk 链路;

华为交换机处理数据帧的过程:

1、当交换机收到的一个数据帧时,会为该数据帧打一个标签:
display port vlan
依靠的是该显示结果中的对应端口下的 PVID 参数;

2、当交换机将一个数据帧转发出去时候,查看的是以下对应表:
display vlan
在对应的 VLAN (即数据帧的入端口的PVID表示的VLAN)
后面的成员端口(这些端口,表示的是数据帧的出端口)
,同时要关注这些端口在发送出去数据时,是否携带标
签(TG/UT)

Hybird 配置过程:
1、创建VLAN 10
[sw]vlan 10
2、配置链接 PC 的链路类型为 hybrid
[sw]interface gi0/0/1
[sw-gi0/0/1]port link-type hybrid
3、配置每个端口上的 PVID 为 10 ;
[sw]interface gi0/0/1
[sw-gi0/0/1]port hybrid pvid vlan 10 [如何使用默认值,是否通]
4、配置每个端口上的不封装标签的 VLAN ;
[sw]interface gi0/0/1
[sw-gi0/0/1]port hybrid untagged vlan 10
5、配置 PC 的IP地址为: 192.168.10.x/24
6、验证、测试、保存
display port vlan // 查看 gi0/0/1 | 2 的 PVID 是否为 10 ;
display vlan // 查看 vlan 后面是否对应 gi0/0/1 | 2 ;
Ping 192.168.10.2
<sw>save

案例:

1 案例1:配置VLAN
笔记    VLAN TrUNK GARP
1.1 问题

2)将端口加入VLAN

3)查看VLAN信息

1.2 方案
使用eNSP搭建实验环境,如图-1所示。

1.3 步骤
实现此案例需要按照如下步骤进行。

<Huawei>system-view
[Huawei]vlan 10
[Huawei]vlan 20
[Huawei]vlan 30
[Huawei]interface Ethernet0/0/1
[Huawei-Ethernet0/0/1]port link-type access
[Huawei-Ethernet0/0/1]port default vlan 10
[Huawei]interface Ethernet0/0/2
[Huawei-Ethernet0/0/2]port link-type access
[Huawei-Ethernet0/0/2]port default vlan 10
[Huawei]interface Ethernet0/0/3
[Huawei-Ethernet0/0/3]port link-type access
[Huawei-Ethernet0/0/3]port default vlan 20
[Huawei]interface Ethernet0/0/4
[Huawei-Ethernet0/0/4]port link-type access
[Huawei-Ethernet0/0/4]port default vlan 20
[Huawei]interface Ethernet0/0/5
[Huawei-Ethernet0/0/5]port link-type access
[Huawei-Ethernet0/0/5]port default vlan 20
[Huawei]interface Ethernet0/0/6
[Huawei-Ethernet0/0/6]port link-type access
[Huawei-Ethernet0/0/6]port default vlan 30
[Huawei]interface Ethernet0/0/7
[Huawei-Ethernet0/0/7]port link-type access
[Huawei-Ethernet0/0/7]port default vlan 30
[Huawei]dis vlan
The total number of vlans is : 4

U: Up; D: Down; TG: Tagged; UT: Untagged;
MP: Vlan-mapping; ST: Vlan-stacking;
#: ProtocolTransparent-vlan; *: Management-vlan;

VID Type Ports

1 common UT:Eth0/0/8(D) Eth0/0/9(D) Eth0/0/10(D) Eth0/0/11(D)
Eth0/0/12(D) Eth0/0/13(D) Eth0/0/14(D) Eth0/0/15(D)
Eth0/0/16(D) Eth0/0/17(D) Eth0/0/18(D) Eth0/0/19(D)
Eth0/0/20(D) Eth0/0/21(D) Eth0/0/22(D) GE0/0/1(D)
GE0/0/2(D)
10 common UT:Eth0/0/1(D) Eth0/0/2(D)
20 common UT:Eth0/0/3(D) Eth0/0/4(D) Eth0/0/5(D)
30 common UT:Eth0/0/6(D) Eth0/0/7(D)
VID Status Property MAC-LRN Statistics Description

1 enable default enable disable VLAN 0001
10 enable default enable disable VLAN 0010
20 enable default enable disable VLAN 0020
30 enable default enable disable VLAN 0030
[Huawei]dis port vlan
Port Link Type PVID Trunk VLAN List

Ethernet0/0/1 access 10 -
Ethernet0/0/2 access 10 -
Ethernet0/0/3 access 20 -
Ethernet0/0/4 access 20 -
Ethernet0/0/5 access 20 -
Ethernet0/0/6 access 30 -
Ethernet0/0/7 access 30 -
Ethernet0/0/8 hybrid 1 -
Ethernet0/0/9 hybrid 1 -
Ethernet0/0/10 hybrid 1 -
Ethernet0/0/11 hybrid 1 -
Ethernet0/0/12 hybrid 1 -
Ethernet0/0/13 hybrid 1 -
Ethernet0/0/14 hybrid 1 -
Ethernet0/0/15 hybrid 1 -
Ethernet0/0/16 hybrid 1 -
Ethernet0/0/17 hybrid 1 -
Ethernet0/0/18 hybrid 1 -
Ethernet0/0/19 hybrid 1 -
Ethernet0/0/20 hybrid 1 -
Ethernet0/0/21 hybrid 1 -
Ethernet0/0/22 hybrid 1 -
GigabitEthernet0/0/1 hybrid 1 -
GigabitEthernet0/0/2 hybrid 1 -
2 案例2:VLAN与Trunk配置
2.1 问题
参照如下网络拓扑实现跨交换机的相同vlan的通信。

2.2 方案
使用eNSP搭建实验环境,如图-2所示。

笔记    VLAN TrUNK GARP

2.3 步骤
实现此案例需要按照如下步骤进行。

[SW1]vlan 5
[SW1]vlan 10
[SW1]interface Ethernet0/0/1
[SW1-Ethernet0/0/1]port link-type access
[SW1-Ethernet0/0/1]port default vlan 5
[SW1]interface Ethernet0/0/2
[SW1-Ethernet0/0/2]port link-type access
[SW1-Ethernet0/0/2]port default vlan 10
[SW1]interface Ethernet0/0/24
[SW1-Ethernet0/0/24]port link-type trunk
[SW1-Ethernet0/0/24]port trunk allow-pass vlan 5 10
[SW2]vlan 5
[SW2]vlan 10
[SW2]interface Ethernet0/0/3
[SW2-Ethernet0/0/3]port link-type access
[SW2-Ethernet0/0/3]port default vlan 5
[SW2]interface Ethernet0/0/4
[SW2-Ethernet0/0/4]port link-type access
[SW2-Ethernet0/0/4]port default vlan 10
[SW2]interface Ethernet0/0/24
[SW2-Ethernet0/0/24]port link-type trunk
[SW2-Ethernet0/0/24]port trunk allow-pass vlan 5 10
VLAN 5的2台主机能够互通,VLAN 10的2台主机能够互通。

VLAN 5与VLAN 10的2台主机不能够互通。

3 案例3:配置Hybrid端口
笔记    VLAN TrUNK GARP
3.1 问题
实现不同vlan间PC不可互访,而不同vlan的PC均可访问服务器的特殊效果,具体要求如下。

在交换机中创建相关vlan
修改端口模式与pvid
修改端口允许通过的数据帧
结果验证,vlan5与vlan10的pc不可以互通,但它们均可与服务器互通
3.2 方案
使用eNSP搭建实验环境,如图-3所示。

图-3

3.3 步骤
实现此案例需要按照如下步骤进行。

[SW1]vlan batch 5 10 50
[SW1]interface Ethernet0/0/1
[SW1-Ethernet0/0/1]port hybrid untagged vlan 5 50
[SW1-Ethernet0/0/1]port hybrid pvid vlan 5
[SW1]interface Ethernet0/0/2
[SW1-Ethernet0/0/2]port hybrid untagged vlan 10 50
[SW1-Ethernet0/0/2]port hybrid pvid vlan 10
[SW1]interface Ethernet0/0/3
[SW1-Ethernet0/0/3]port hybrid tagged vlan 5 10 50
[SW1]dis vlan
The total number of vlans is : 4

U: Up; D: Down; TG: Tagged; UT: Untagged;
MP: Vlan-mapping; ST: Vlan-stacking;
#: ProtocolTransparent-vlan; *: Management-vlan;

VID Type Ports

1 common UT:Eth0/0/1(U) Eth0/0/2(U) Eth0/0/3(U) Eth0/0/4(D)
Eth0/0/5(D) Eth0/0/6(D) Eth0/0/7(D) Eth0/0/8(D)
Eth0/0/9(D) Eth0/0/10(D) Eth0/0/11(D) Eth0/0/12(D)
Eth0/0/13(D) Eth0/0/14(D) Eth0/0/15(D) Eth0/0/16(D)
Eth0/0/17(D) Eth0/0/18(D) Eth0/0/19(D) Eth0/0/20(D)
Eth0/0/21(D) Eth0/0/22(D) GE0/0/1(D) GE0/0/2(D)
5 common UT:Eth0/0/1(U)
TG:Eth0/0/3(U)
10 common UT:Eth0/0/2(U)
TG:Eth0/0/3(U)
50 common UT:Eth0/0/1(U) Eth0/0/2(U)
TG:Eth0/0/3(U)
VID Status Property MAC-LRN Statistics Description

1 enable default enable disable VLAN 0001
5 enable default enable disable VLAN 0005
10 enable default enable disable VLAN 0010
50 enable default enable disable VLAN 0050
[SW1]dis port vlan
Port Link Type PVID Trunk VLAN List

Ethernet0/0/1 hybrid 5 -
Ethernet0/0/2 hybrid 10 -
Ethernet0/0/3 hybrid 1 5 10 50
Ethernet0/0/4 hybrid 1 -
Ethernet0/0/5 hybrid 1 -
Ethernet0/0/6 hybrid 1 -
Ethernet0/0/7 hybrid 1 -
Ethernet0/0/8 hybrid 1 -
Ethernet0/0/9 hybrid 1 -
Ethernet0/0/10 hybrid 1 -
Ethernet0/0/11 hybrid 1 -
Ethernet0/0/12 hybrid 1 -
Ethernet0/0/13 hybrid 1 -
Ethernet0/0/14 hybrid 1 -
Ethernet0/0/15 hybrid 1 -
Ethernet0/0/16 hybrid 1 -
Ethernet0/0/17 hybrid 1 -
Ethernet0/0/18 hybrid 1 -
Ethernet0/0/19 hybrid 1 -
Ethernet0/0/20 hybrid 1 -
Ethernet0/0/21 hybrid 1 -
Ethernet0/0/22 hybrid 1 -
GigabitEthernet0/0/1 hybrid 1 -
GigabitEthernet0/0/2 hybrid 1 -
[SW2]vlan batch 5 10 50
[SW2]interface Ethernet0/0/1
[SW2-Ethernet0/0/1]port hybrid tagged vlan 5 10 50
[SW2]interface Ethernet0/0/2
[SW2-Ethernet0/0/2]port hybrid untagged vlan 5 10 50
[SW2-Ethernet0/0/2]port hybrid pvid vlan 50
[SW2]dis vlan
The total number of vlans is : 4

U: Up; D: Down; TG: Tagged; UT: Untagged;
MP: Vlan-mapping; ST: Vlan-stacking;
#: ProtocolTransparent-vlan; *: Management-vlan;

VID Type Ports

1 common UT:Eth0/0/1(U) Eth0/0/2(U) Eth0/0/3(D) Eth0/0/4(D)
Eth0/0/5(D) Eth0/0/6(D) Eth0/0/7(D) Eth0/0/8(D)
Eth0/0/9(D) Eth0/0/10(D) Eth0/0/11(D) Eth0/0/12(D)
Eth0/0/13(D) Eth0/0/14(D) Eth0/0/15(D) Eth0/0/16(D)
Eth0/0/17(D) Eth0/0/18(D) Eth0/0/19(D) Eth0/0/20(D)
Eth0/0/21(D) Eth0/0/22(D) GE0/0/1(D) GE0/0/2(D)
5 common UT:Eth0/0/2(U)
TG:Eth0/0/1(U)
10 common UT:Eth0/0/2(U)
TG:Eth0/0/1(U)
50 common UT:Eth0/0/2(U)
TG:Eth0/0/1(U)
VID Status Property MAC-LRN Statistics Description

1 enable default enable disable VLAN 0001
5 enable default enable disable VLAN 0005
10 enable default enable disable VLAN 0010
50 enable default enable disable VLAN 0050
[SW2]dis port vlan
Port Link Type PVID Trunk VLAN List

Ethernet0/0/1 hybrid 1 5 10 50
Ethernet0/0/2 hybrid 50 -
Ethernet0/0/3 hybrid 1 -
Ethernet0/0/4 hybrid 1 -
Ethernet0/0/5 hybrid 1 -
Ethernet0/0/6 hybrid 1 -
Ethernet0/0/7 hybrid 1 -
Ethernet0/0/8 hybrid 1 -
Ethernet0/0/9 hybrid 1 -
Ethernet0/0/10 hybrid 1 -
Ethernet0/0/11 hybrid 1 -
Ethernet0/0/12 hybrid 1 -
Ethernet0/0/13 hybrid 1 -
Ethernet0/0/14 hybrid 1 -
Ethernet0/0/15 hybrid 1 -
Ethernet0/0/16 hybrid 1 -
Ethernet0/0/17 hybrid 1 -
Ethernet0/0/18 hybrid 1 -
Ethernet0/0/19 hybrid 1 -
Ethernet0/0/20 hybrid 1 -
Ethernet0/0/21 hybrid 1 -
Ethernet0/0/22 hybrid 1 -
GigabitEthernet0/0/1 hybrid 1 -
GigabitEthernet0/0/2 hybrid 1 -
vlan5与vlan10的pc不可以互通,但它们均可与服务器互通。

4 案例4:配置GVRP
笔记    VLAN TrUNK GARP
4.1 问题
1)SW1创建静态VLAN 10 ,SW2和SW3没有配置VLAN

2)通过配置GVRP功能,让SW2和SW3自动学习VLAN

4.2 方案
使用eNSP搭建实验环境,如图-4所示。

图-4

4.3 步骤
实现此案例需要按照如下步骤进行。

[sw1]gvrp
[sw1]interface Ethernet 0/0/2
[sw1-Ethernet0/0/2]port link-type trunk
[sw1-Ethernet0/0/2]port trunk allow-pass vlan all
[sw1-Ethernet0/0/2]gvrp
[sw2]gvrp
[sw2]interface Ethernet 0/0/1
[sw2-Ethernet0/0/1]port link-type trunk
[sw2-Ethernet0/0/1]port trunk allow-pass vlan all
[sw2-Ethernet0/0/1]gvrp
[sw2]interface Ethernet 0/0/3
[sw2-Ethernet0/0/3]port link-type trunk
[sw2-Ethernet0/0/3]port trunk allow-pass vlan all
[sw2-Ethernet0/0/3]gvrp
[sw3]gvrp
[sw3]interface Ethernet 0/0/2
[sw3-Ethernet0/0/2]port link-type trunk
[sw3-Ethernet0/0/2]port trunk allow-pass vlan all
[sw3-Ethernet0/0/2]gvrp
[sw1]vlan 10
[sw2]dis vlan summary
static vlan:
Total 1 static vlan.
1
dynamic vlan:
Total 1 dynamic vlan.
10
reserved vlan:
Total 0 reserved vlan.
[sw3]dis vlan summary
static vlan:
Total 1 static vlan.
1
dynamic vlan:
Total 1 dynamic vlan.
10
reserved vlan:
Total 0 reserved vlan.

PVLAN:
private VLAN - 私有 VLAN
在节省IP网段的 情况下,确保终端设备之间的安全;
隔离了广播域;

Mux-vlan :
multiplex VLAN , 复合/混杂 VLAN

配置步骤:
1.确保有VLAN存在
vlan 100
vlan 10
vlan 20
vlan 30

2.确定VLAN之间的从属关系
vlan 100
mux-vlan <-----开启了 mux 功能,将该 VLAN 配置为了主VLAN;
subordinate separate 30
subordinate group 10 20

3.将连接终端的端口放入到指定VLAN,并开启 mux-vlan 功能;
interface gi0/0/1
port link-type access
port default vlan 10 <--- 将端口放入 group vlan 10 ;
port mux-vlan enable <--- 开启该端口的 mux-vlan 功能;

interface gi0/0/2
   port link-type access
   port default vlan 20 <--- 将端口放入 group vlan  10 ; 
   port mux-vlan enable <--- 开启该端口的 mux-vlan 功能;

interface gi0/0/3
   port link-type access
   port default vlan 30 <--- 将端口放入 group vlan  10 ; 
   port mux-vlan enable <--- 开启该端口的 mux-vlan 功能;       

4.验证与测试
display vlan
display mux-vlan <---- 专业命令;

5.注意:

mux-vlan 是一种2层技术,所以主vlan 是不可以配置 vlanif 的;

# mux-vlan 下的各个子vlan的主机,都是属于同一个IP网段的;
# mux-vlan 下的各个子vlan之间,都是不可以通信的;
# mux-vlan 下的相同 group vlan 内部的主机,可以通信;
# mux-vlan 下的相同 separate vlan 内部的主机,不可以互相通信;
# mux-vlan 下的各个 vlan 内部主机与外部 主 vlan 通信时,使用
           使用的是同一个网关IP,此时该网关应该属于主 vlan ;
           所以,连接网关的端口,应该是属于主vlan,并且开启mux-vlan功能;               
# mux-vlan 下的各个 vlan 内部主机,如果有的开启了 mux-vlan,有
            的没有开启,则是完全可以通信的,无法通过mux-vlan 
            实现主机的隔离。

============================================
Super vlan