11.6 MariaDB安装

  • MariaDB的安装过程和MySQL类似,不同的一点的是因为我们在同一台机器上同时安装了Mariadb和mysql,为了避免冲突,需要在配置文件和启动脚本中做些许调整.

安装Mariadb的简要步骤:

  • cd /usr/local/src
  • wget https://downloads.mariadb.com/MariaDB/mariadb-10.2.6/bintar-linux-glibc_214-x86_64/mariadb-10.2.6-linux-glibc_214-x86_64.tar.gz
  • tar zxvf mariadb-10.2.6-linux-glibc_214-x86_64.tar.gz
  • mv mariadb-10.2.6-linux-glibc_214-x86_64 /usr/local/maridb
  • cd /usr/local/mariadb
  • ./scripts/mysql_install_db --user=mysql --basedir=/usr/local/mariadb/ --datadir=/data/mariadb/
  • cp support-files/my-small.cnf /usr/local/mariadb/my.cnf #拷贝配置文件
  • vi /usr/local/mariadb/my.cnf #定义basedir和datadir
    basedir=/usr/local/mariadb
    datadir=/data/mariadb
  • cp support-files/mysql.server /etc/init.d/mariadb #拷贝启动脚本
  • vim /etc/init.d/mariadb #定义basedir,datadir,conf以及启动参数
    basedir=/usr/local/mariadb
    datadir=/data/mariadb
    conf=$basedir/my.cnf
    然后还要在启动命令语句中加上如下语句(如图)
    --defaults-file="$conf"
    2018-2-27 Linux学习笔记
  • /etc/init.d/mariadb start #启动mariadbl服务

11.7/8/9 Apache安装

  • Apache是一个基金会的名字,httpd才是我们要安装的软件包,早期它的名字就叫apache. Apache官网www.apache.org
  • apr和apr-util是一个通用的函数库,它让httpd可以不关心底层的操作系统平台,可以很方便的移植(从linux移植到windows),所以安装httpd需要先安装apr和apr-util.

下载httpd, apr和apr-util并解压:
wget http://mirrors.cnnic.cn/apache/httpd/httpd-2.4.29.tar.gz
wget http://mirrors.hust.edu.cn/apache/apr/apr-1.6.3.tar.gz
wget http://archive.apache.org/dist/apr/apr-util-1.5.4.tar.gz
tar zxvf httpd-2.4.29.tar.gz
tar zxvf apr-1.6.3.tar.gz
tar zxvf apr-util-1.5.4.tar.gz


安装apr-1.6.3:

cd /usr/local/src/apr-1.6.3
./configure --prefix=/usr/local/apr
make && make install


安装apr-util-1.5.4:

cd /usr/local/src/apr-util-1.5.4
./configure --prefix=/usr/local/apr-util --with-apr=/usr/local/apr
make && make install


安装httpd-2.4.29:
cd /usr/local/src/httpd-2.4.29
./configure \ //这里的反斜杠是脱义字符,加上它我们可以把一行命令写成多行
--prefix=/usr/local/apache2.4\
--with-apr=/usr/local/apr\
--with-apr-util=/usr/local/apr-util\
--enable-so\ //表示支持动态扩展模块
--enable-mods-shared=most
make & make install


  • ls /usr/local/apache2.4/modules #查看可用的扩展模块
    2018-2-27 Linux学习笔记
  • /usr/local/apache2.4/bin/httpd -M #查看加载的模块
    2018-2-27 Linux学习笔记
  • /usr/local/apache2.4/bin/apachectl start #启动httpd服务
  • ps aux|grep httpd #查看httpd进程
  • netstat -lntp #查看httpd监听的端口
    2018-2-27 Linux学习笔记

安装过程中遇到的问题:

  • 问题1:
    安装apr-util-1.6.1遇到的问题:
  • 解决方法: 缺少expat-devel包
    yum install expat-devel
    2018-2-27 Linux学习笔记
  • 问题2:
    安装httpd遇到的问题:
  • 解决方法: 网上搜到该问题是因为apr-util 用了最新的1.6版本导致的, 改回1.5.4版本,问题解决.
    (参考文章链接 https://www.cnblogs.com/zyos/p/7663717.html )
    2018-2-27 Linux学习笔记