网络工程师成长日记357-某城市烟草局项目

这是我的第357篇原创文章,记录网络工程师行业的点点滴滴,结交IT行业有缘之人

网络工程师成长日记357-某城市烟草局项目

9月15号星期二下我与老大及合作网络公司李总、连总午坐车去往某城市,天气晴。
此次前去某城市卷烟厂,了解CISCO设备,了解企业的设备应用,线路走向。
在坐车去往某城市的路上李总在与老大交谈着。细心的听取他们的谈话内容,谈话中涉及到CISCO的发展历史,看似很简单的问题但当时我就蒙着了。
真正要想成为好的CISCO工程师,不管是CCNA或者CCNP更或者是CCIE,我们都有必要知道CISCO的发展历史。
以前的再我的词典中定义的CISCO网络工程师就紧要掌握技术上的知识就可以大功告成的,突然之间想到cisco的发展历史晕了。
这或许你知道乘法运算5X5 但问你1+1时却不知道了,是否大巫见小巫。
也因此让我对CISCO工程师有了一个比较全面的认识。
除了技术重要的掌握好外,我们也有必要去了解Cisco的发展历史以及它的走向。
网络工程师成长日记357-某城市烟草局项目

当然这是我第一次的外出,话语相对较少。
一自己没有实战的经验。
二自己谈及真正触及设备的短缺,漏洞。
三自己跟公司的职员都很少有打交道的机会更别说这次是经理的他们。
说话当然是有所顾虑的。而且此次的任务也是比较重要的。

在老大、李总的交谈中当然还是学习的东西要多的,交谈中不管是谁我们首先要有自己的气势不卑不亢。
当然我们要有自己让别人称赞的地方,或许也可以说是自己的价值吧。
夜里一点多到达某城市,晚上住在商务酒店里熟睡一夜,第二天早上起来以饱满的精神去见面客户。
精神还是很重要的哈。呵呵、、
早上十点坐车前往项目地点某城市卷烟厂,到后他们的负责人出来接到我们。
进去后我主要是了解Cisco65系列设备。
这次并不是去给与设备的配置是卖出设备。
在Cisco设备的角度我们作为Cisco的网络工程师我们的话还是很有含量的。
在交谈中也出现了小的问题我们给与客户的模块序列号与模块有十多个没有匹配好,或许看上去是小问题,但每每都是在小问题上导致失败的。当然我们的模块是完全百分百的可用。
但就是序列号的问题客户就是发现到了问题。此时我们就要耐心的给与讲解,面对上百块的模块都是人为的给定义的序列号的难免是有匹配上的不对的,但我们保证我们所提供的模块绝对是没问题的。
同时我方也提出会回到公司后会再次核对校正给与对放正确的模块匹配正确的序列号的。
终于在再三的解释下对方同意了。至此经历了将近两个小时的谈话也告一段落。
最终双发都给与肯定。此次的任务也算是圆满完成。
此次的谈话中让我明白了,我们做什么事情都方方面面考虑到,或许大的方面我们都考虑好了,但每次重要的就是小细节方面的事情。
以后的工作生活中我们都要重视小细节上的事情。同时当我们出现了问题的时候我们并不是坐视不管、或者说不知道。我们要耐心的给对方解释争取获得对象的认可。
这也考虑到了我们做事态度。
我想说的是“外出做项目给就是一次真正的上班,考虑我们的综合方面,一个人的交谈、交际以及一个人的能力,这是一次综合的考察。对以后的工作有利无害。
谢谢这次上级给与我的机会,我会踏踏实实做好每次的实验。争取提高自己的个人能力。已获得更多的外出实践机会。
再次谢谢老大在这次项目上的照顾帮助。
下午3点坐车离开某城市返回西安,车上听着欢快的歌曲,欣赏沿途的风景,感觉真是不错,不适为一次美好的旅途,

企业里6500的配置与规划
一:目的
按照路由器在网络位置划分,路由器可分为核心路由器与接入路由器。接入路由器位于路由边缘,绝大部分用作中小企业。本次是了解企业的拓扑以及规划。

二:实验拓扑

三:实验地点
陕西省某城市卷烟厂

四:实验步骤:
1.端口设置  

  1. 端口基本设置   
    Cisco 65xx系列交换机的端口缺省都是路由模式,一般都会配置为交换端口使用,进
    入端口配置模式:  
    对于单一端口,在配置模式下输入:interface Ethernet,Fast Ethernet,Gigabit
    Ethernet x/y, x为槽位号,y为端口号。  
    对于一组端口,可以使用以下的命令进入,例如:  
    Router(config)# interface range fastethernet 5/1 - 5     或:  
    Router(config-if)# interface range gigabitethernet 2/1 - 2, gigabitethernet
    3/1 - 2  
    进行端口配置模式后,可以shutdown,或no shutdown端口,并可以对端口进行配置,
    快速以太端口有全双工、半双工和自动协商模式,如果知道对端连接的设备是采用何
    种方式,最好采用手工设置方式固定端口的模式和速率。缺省是自动协商模式。  
    快速以太端口的速率可以设置为100M,也可以设置为10M和自动协商。缺省是自动协
    商方式。如:  
    Router(config-if)#speed [10 | 100 | auto](速度)  
    Router(config-if)# duplex [auto | full | half](双工)  
    或添加注释,如:  
    Router(config-if)# description Channel-group to "Marketing"  
  2. 配置二层交换接口  
    (以fastethernet为例,gigabitethernet一样)  
    Router(config)# interface fastethernet x/y   
    Router(config-if)# shutdown   
    Router(config-if)# switchport  ;6500上缺省端口为路由端口,需要写switchport
    将端口设置为交换端口  
    Router(config-if)# switchport mode access   
    Router(config-if)# switchport access vlan x   
    Router(config-if)# no shutdown   
    Router(config-if)# end  

清除二层接口配置  
(以fastethernet为例,gigabitethernet一样)  
Router(config)# interface fastethernet x/y   
Router(config-if)# no switchport   
Router(config-if)# end  
注:使用default interface {ethernet | fastethernet | gigabitethernet}
slot/port,使端口回到原来的缺省配置。  

  1. 配置三层路由端口  
    6500的端口缺省就是具有三层交换的端口,用来跟其他设备的连接,当将一个端口配
    置成三层端口之后,就可以在此端口上分配IP地址了。  
    Router(config)# interface fastethernet x/y  
    Router(config)# ip add x.x.x.x x.x.x.x  
    Router(config)# no shutdown  
  2. 配置端口Trunk   
    将一个二层端口配置为Trunk模式:  
    Router(config)# interface fastethernet x/y (以fastethernet为例,
    gigabitethernet一样)  
    Router(config-if)# shutdown   
    Router(config-if)# switchport   
    Router(config-if)# switchport trunk encapsulation dot1q   
    Router(config-if)# switchport mode trunk  
    Router(config-if)# no shutdown   
    Router(config-if)# end   
    Router# exit  
  3. Ethernaet Channel  
    Router(config)# interface range gigabitethernet1/1 - 2  
    Router(config-if)#no ip address   
    Router(config-if)#switchport  
    Router(config-if)#switchport trunk encapsulation dot1q   
    Router(config-if)#switchport mode trunk  
    Router(config-if)#switchport trunk native vlan 1   
    Router(config-if)#channel-group 1 mode on  
    R>interface Port-channel1 ;自动产生,并且一定要如下所示,否则可能会有问题。  
    switchport  
    switchport trunk encapsulation dot1q  
    switchport mode trunk  
    !  
    interface GigabitEthernet1/1   
      no ip address   
      switchport   
      switchport trunk encapsulation dot1q   
      switchport trunk native vlan 1   
      channel-group 1 mode on   
    !   
    interface GigabitEthernet1/2   
      no ip address   
      switchport   
      switchport trunk encapsulation dot1q   
      switchport trunk native vlan 1   
      channel-group 1 mode on   
    如果有问题,使用命令#no int port-channel 1  ,#int g2/1 -2  ,#no switchport  
  4. 查看端口配置  
    Router# show running-config interface fastethernet 5/8  
    Router# show interfaces fastethernet 5/8 switchport  
    Router# show running-config interface port-channel 1  
    Router# show spanning-tree interface fastethernet 4/4  
    配置VLAN  
  5. 配置VTP  
    VTP是一个2层信息协议,包括版本1和2。一个网络设备只能属于一个VTP domain。
    缺省, Catalyst 6500交换机配置为VTP server mode,在没有管理域的状态。直到
    在一个trunk链路上收到其他域的宣告或手工配置管理域。VTP并不是一定要配置,
    但是配置可以简化配置复杂度和易于管理。  
    VTP pruning(VTP裁剪)增强了网络带宽利用率。结合VTP,使得没有必要接收某个
    vlan的广播信息的交换机被裁剪,免于接收包括broadcast, multicast, unknown,
    and flooded unicast的包。  
    Router(config)# vtp domain domain_name  
    Router(config)# vtp mode {client | server | transparent}  
    Router(config)# vtp version {1 | 2}  
    Router(config)# vtp password password_string  
    Router(config)# vtp pruning  
    Router# show vtp status  
  6. 配置VLAN端口  
  7. 创建VLAN  
    缺省状态下,所有的二层端口均属于vlan1,vlan的配置方法如下:  
    命令 目的   
    Step 1   Router# vlan database 进入vlan配置方式.  
    Step 2   Router(vlan)# vlan vlan_ID  加入一个VLAN.  
    Step 3 Router(vlan)# vtp domain  name 设置vtp域名  
    Step 3   Router(vlan)# exit  更新VLAN数据库,并在管理域内广播,退到全局模
    式  
    Step 4   Router# show vlan name vlan_name  验证VLAN配置  

删除配置好的vlan  
Router# vlan database  
Router(vlan)# no vlan x  
Deleting VLAN 3...  
Router(vlan)# exit  

  1. 给vlan分配端口  
    Router(config)# interface fastethernet x/y   
    Router(config-if)# shutdown   
    Router(config-if)# switchport   
    Router(config-if)# switchport mode access   
    Router(config-if)# switchport access vlan x  
    Router(config-if)# no shutdown   
    Router(config-if)# end   
    Router# exit  
  2. 配置vlan地址  
    Router(config)# interface vlan x   
    Router(config)# ip add x.x.x.x x.x.x.x  
    6。 配置HSRP  
    不同网段之间的通信都是通过在终端工作站上设定缺省网关来实现的,为了实现冗
    余,每台交换机上必然要配置相同的网段,那么就会在一个网段中出现2个不同地址
    的路由
    接口(对于工作站就是缺省网关),当1条上联链路失效时,数据必然会从另
    外1条链路传输到另外一台交换机上进行处理,这时就存在缺省网关变更的问题。  
    为了消除当一条链路失效导致的工作站缺省网关重新定义的问题,我们使用Cisco公
    司专有HSRP(Hot Standby Redundant Protocol)技术来解决这个问题。  
    HSRP技术就是将分布在2台交换机上相同网段的不同路由接口IP地址映射为一个虚
    拟IP地址来消除工作站缺省网关重新定义的问题。配置如下:  
    在其中一台65xx上按下面模版进行配置  
    interface Vlan x   
      ip address x.x.x.x x.x.x.x  
      no ip redirects   
      no ip directed-broadcast   
      standby 1 ip y.y.y.y  
      standby 1 priority 100   
      standby 1 preempt  
    standby 1 authentication secret  

在另一台65xx上按下面模版进行配置  
interface Vlan x   
  ip address x.x.x.x x.x.x.x   
  no ip redirects   
  no ip directed-broadcast   
standby 1 ip y.y.y.y  
  standby 1 priority 110 ;这个优先级高,成为Master  
  standby 1 preempt  
standby 1 authentication secret  
五:实验总结:
这次主要是了解下公司的拓扑图,以上配置只是经过自己的学习内容(现阶段所学习到的内容)与网站上的相关信息给与配置。
六:鸣谢
感谢老大在这次实践中的帮助与指点,了解到一个企业的拓扑。在以后的工作中做好准,打好基础。