网络工程师成长日记363-日立公司工程回忆录

这是我的第363篇原创文章,记录网络工程师行业的点点滴滴,结交IT行业有缘之人

网络工程师成长日记363-日立公司工程回忆录

本文章为保护客户隐私,配置文件删除掉涉及密码,IP等具体信息(使用X.X.X.X代替)

今天下午,接到公司电话。我风风火火的赶到了公司。
和老大做了简短的沟通。老大联系好了人以后。我们400路杀到了高薪2路。
在见到了接头人,在其带领下。我们来到了一座比较宏伟的大厦门口。
乘电梯上27楼。进入了日立公司西安分公司。
在休息室稍等片刻,管事人进来和我做了些简单的沟通。
老大询问了他们的需求。经过仔细了解后。
我们明白了。他们希望除了部分的ip可以上网以外其他的所有的ip 不允许连接外网只能连接内网。

这样,和老大简单的沟通以后。我们估计很简单。只用做一个访问控制列表就可以搞定了。
在管理人员的带领下。我们进入了机房。
看了看设备。分别是光端机,防火墙,cisco 1800router h3c switch of 2 layer D-Link switch 服务器。
路由上做了***和总部拉的光纤,公司内部的员工上网用的ADSL拨号上网。
管理人员拿来了公司的拓扑结构。我们看看了拓扑于是就开工了。我们使用console 登入路由。
但是路由的密码管理人员也不知道 所以我们只能先破掉密码才能继续。
他们需要有31个Ip可以上网。于是我们做了一条访问控制列表,并且应用于交换机连路由的f0/1口上。
随后出去找了台电脑实验后。说明成功了
工程整体上没有什么太大的难度,通过这次的工程经历。我明白了,当我们接手一个不管多大多小的项目。
首先要和客户进行沟通,详细了解他们的需求,在对当前网络的拓扑进行了解,然后列出实现客户需求的所有实现的方法,选择最合适,最简单,最安全的方法实现需求。
若需要断网,或者关闭设备的时候,要与管理员沟通,征求管理员的同意。
值得注意的是,今天见到的这个拓扑的连接方法比较经济。
因为cisco 1800router只有两个F口,因此如果在这个设备上连接连接总部在连接交换机 在连防火墙的话,口就不够用了
所以他们将防火墙了连在了交换机上,所有的员工上网的数据从交换机先发往路由在通过静态路由发到防火墙,用防火墙设置了拨号上网。虽然这样做增加了cisco 1 800router的工作负担,但是降低了成本。
网络工程师成长日记363-日立公司工程回忆录

在cisco1800上的f0/0是连接总部的以太网接口
interface FastEthernet0/0
description to_CT-MPLS-×××
ip address 172.31.0.X 255.255.255.252
ip access-group in_filter in
ip access-group out_filter out
duplex auto
speed auto

这些是总公司那边的路由的一点信息
SN-XA-XHM-S-1.CN2.CTCN2.NET
Fas 0/0 135 R 12416/PRP Gig 10/0.117
Router-XA1841#show cdp nei de
Router-XA1841#show cdp nei detail

Device ID: SN-XA-XHM-S-1.CN2.CTCN2.NET
Entry address(es):
IP address: 172.31.0.58
Platform: cisco 12416/PRP, Capabilities: Router
Interface: FastEthernet0/0, Port ID (outgoing port): GigabitEthernet10/0.117
Holdtime : 150 sec

!这里是连接h3c交换机的接口
interface FastEthernet0/1
description LAN-Gateway
ip address 10.96.155.1 255.255.255.128
ip access-group 100 in
duplex auto
speed auto
!
router bgp 65530
--More-- no synchronization
bgp log-neighbor-changes
network 10.96.155.0 mask 255.255.255.128
neighbor 172.31.0.58 remote-as 4809
neighbor 172.31.0.58 soft-reconfiguration inbound
neighbor 172.31.0.58 distribute-list 10 in
no auto-summary
!
ip classless
这里指了两条默认路由 10.96.155.2 应该是router to switch的地址
ip route 0.0.0.0 0.0.0.0 10.96.155.2
ip route 172.16.0.0 255.255.0.0 10.96.155.2 200 这条设置了200 又指定了和默认路由相同的地址,设置了管理距离为200,172 是他们的总部那边的内网地址,我有点不明白了。!
ip http server
no ip http secure-server
!

这些我们做的访问控制列表
Router-XA1841(config)#access-list 100
Router-XA1841(config)#access-list 100 per ip 10.96.155.0 0.0.0.31
Router-XA1841(config)#access-list 100 per ip 10.96.155.0 0.0.0.31 any
Router-XA1841(config)#access-list 100 per ip any 170.95.0.0 0.0.255.255
Router-XA1841(config)#access-list 100 per ip any 172.0.0.0 0.255.255.255
Router-XA1841(config)#access-list 100 per ip any 10.0.0.0 0.255.255.255
Router-XA1841(config)#access-list 100 per ip any 158.213.0.0 0.0.255.255
Router-XA1841(config)#access-list 100 per ip any 133.144.0.0 0.0.255.255

他们之前有的一些ip 由于我们也不知道到底是什么,所以就安全来有的ip 照抄了一份。
调用在路由 到router to switch 的接口out上。Ok
收工!!!!!