关于升级到Android Studio3.2版本的注意事项:

1、默认最低的Build Tools version 为 28.0.2
2、如果程序中使用了kotlin插件,需要将kotlin插件的最低版本号改为1.2.51
3、如果在gradle.properties文件中加入了android.overridePathCheck=true 设置,现在是不支持的要删除或注释掉

编译器给出的提示原文:
1、The specified Android SDK Build Tools version (27.0.3) is ignored, as it is below the minimum supported version (28.0.2) for Android Gradle Plugin 3.2.0.
Android SDK Build Tools 28.0.2 will be used.
To suppress this warning, remove "buildToolsVersion '27.0.3'" from your build.gradle file, as each version of the Android Gradle Plugin now has a default version of the build tools.

2、The Android Gradle plugin supports only Kotlin Gradle plugin version 1.2.51 and higher. Project 'baisonpda3' is using version 1.2.41.

3、The option setting 'android.overridePathCheck=true' is experimental and unsupported.
The current default is 'false'

另外一种情况:(在3.2的介绍说明也有提到,可能需要ladder的问题;或者也是刚发布不就有些事情还没沟通完全,需要时间)
1、如果在升级时出现kotlin下载超时,说明网络被限制;可能是电脑的防火墙,公司的保护伞,也有可能是长城的问题了,这时就只有使用代理。

2、或者你发现,直接使用浏览器可以进入maven信息,那么这就可能是as工具的问题了,
但可以通过在程序根目录的build.gradle文件里加入jcenter(){url "http://jcenter.bintray.com/"}多次尝试(对于没有[ladder的人员)

3、也有可能是你的kotlin版本使用过高,访问被受限如报错:

Caused by: org.gradle.api.resources.ResourceException: Could not get resource 'https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-gradle-plugin/1.2.60/kotlin-gradle-plugin-1.2.60.jar'.
Caused by: org.apache.http.conn.HttpHostConnectException: Connect to d29vzk4ow07wi7.cloudfront.net:443 failed: Connection timed out: connect
    at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:159)
    at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(PoolingHttpClientConnectionManager.java:373)
    at org.apache.http.impl.execchain.MainClientExec.establishRoute(MainClientExec.java:381)
    at org.apache.http.impl.execchain.MainClientExec.execute(MainClientExec.java:237)
    at org.apache.http.impl.execchain.ProtocolExec.execute(ProtocolExec.java:185)

也可以通过步骤2的配置jcenter(){url "http://jcenter.bintray.com/"}成功获取