实验一、VRRP主备备份的配置

vrrp简介

虚拟路由冗余协议VRRP(Virtual Router Redundancy Protocol)是通过把几台路由设备联合组成一台虚拟的路由设备,将虚拟路由设备的IP地址作为用户的默认网关实现与外部网络通信。当网关设备发生故障时,VRRP机制能够选举新的网关设备承担数据流量,从而保障网络的可靠通信。

本实验涉及内容:

  • vrrp 主备备份配置
  • vrrp 负载分担配置
  • ospf协议
  • 单臂路由
  • 二层转发

拓扑图

华为VRRP综合配置

实现效果:

正常情况下,主机以SW2为默认网关接入Internet,当SW2故障时,SW3接替SW2作为网关继续进行工作,实现网关的冗余备份。

当SW2故障恢复后,其延时20秒通过抢占的方式重新成为Master,承担数据传输。

一、配置各接口的IP地址、交换机的二层转发功能

sw1:

sys
sysname SW1
vlan batch 200 300 400
inter vlan 200
ip add 192.168.2.2 24    //配置vlan ip地址,实现三层转发
quit
inter vlan 300
ip add 192.168.1.2 24
inter vlan 400
ip add 172.16.1.2 24

inter g0/0/1 
port link-type trunk
port trunk allow vlan  300    //允许vlan300通过
quit
inter g0/0/2
port link-type trunk
port trunk allow vlan  200 
quit
inter g0/0/24
port link-type trunk
port trunk allow-pass vlan all
quit

sw2:

sys
sysname SW2
vlan batch 100 300
inter vlan 100
ip add 10.1.1.1 24
quit
inter vlan 300
ip add 192.168.1.1 24

inter g0/0/1 
port link-type trunk
port trunk allow vlan  300 
quit
inter g0/0/3 
port link-type trunk
port trunk allow vlan  100 
quit

SW3:

sys
sysname SW3
vlan batch 200 100
inter vlan 200
ip add 192.168.2.1 24
quit
inter vlan 100
ip add 10.1.1.2 24

inter g0/0/2 
port link-type trunk
port trunk allow vlan  200 
quit
inter g0/0/4
port link-type trunk
port trunk allow vlan  100 
quit

SW4:

sys
sysname SW4
vlan 100
quit
inter g0/0/3 
port link-type trunk
port trunk allow vlan  100 
quit
inter g0/0/4 
port link-type trunk
port trunk allow vlan  100 
quit

inter g0/0/5 
port link-type access  //配置为access模式,连接电脑终端
port default vlan 100
quit

二、配置交换机ospf协议,实现SW1、SW2、SW3网络互通

SW1:

ospf 1
area 0
network 192.168.1.0 0.0.0.255      //发布直连的网络段
network 192.168.2.0 0.0.0.255
network  172.16.1.0  0.0.0.255
quit
quit

SW2:

ospf 1
area 0
network 192.168.1.0 0.0.0.255
network 10.1.1.0 0.0.0.255
network  172.16.1.0  0.0.0.255
quit
quit

SW3:

ospf 1
area 0
network 192.168.2.0 0.0.0.255
network 10.1.1.0 0.0.0.255
network  172.16.1.0  0.0.0.255
quit
quit

三、在路由器上配置单臂路由,ospf协议,实现路由器与交换机通信

AR1:
R1:

sys
sysname R1
interface g0/0/0.400   //创建子接口
ip address 172.16.1.1  24  //配置ip地址
dot1q termination vid 400    //配置子接口dot1q封装的单层vlan id 
arp broadcast enable       //开启arp 广播
quit
ospf 1            //配置ospf协议
area 0
network 172.16.1.0  0.0.0.255
return

四、配置vrrp主备备份

  • 1、(主)SW2: 在SW2上创建VRRP备份组1,配置SW2在该备份组中的优先级为120,并配置抢占时间为20秒。
    SW2:
inter VLAN 100
vrrp vrid 1 virtual-ip 10.1.1.111  //配置虚拟网关
vrrp vrid 1 priority 120   //默认优先级为100,修改Master设备的优先级大于Backup设备
vrrp vrid 1 preempt-mode timer delay 20   //配置抢占时间为20s
quit
  • 2、SW3:在SW3上创建VRRP备份组1,其在该备份组中的优先级采用缺省值100(不需要配置)。
    SW3:
    inter VLAN 100
    vrrp vrid 1 virtual-ip 10.1.1.111
    quit

    五、PC端ip设置

    ip地址:10.1.1.100
    掩码:255.255.255.0
    网关:10.1.1.111

至此,本实验所有配置完成。
正常情况下的链路转发过程如下图:
华为VRRP综合配置
当主链路出现故障时,链路转发过程如下图:
华为VRRP综合配置

实验二、vrrp负载分担的配置

配置vrrp负载分担,只需将以上的步骤四做以下更改:

四、配置VRRP备份组

  • 1、在SW2上创建VRRP备份组1,配置SW2的优先级为120,抢占延时为20秒,作为Master设备;SW3的优先级为缺省值,作为Backup设备。
    SW2:
    inter VLAN 100
    vrrp vrid 1 virtual-ip 10.1.1.111
    vrrp vrid 1 priority 120   
    vrrp vrid 1 preempt-mode timer delay 20   
    quit

    SW3:

inter VLAN 100
vrrp vrid 1 virtual-ip 10.1.1.111
quit
  • 2、 在SW3上创建VRRP备份组2,配置SW3的优先级为120,抢占延时为20秒,作为Master设备;SW2的优先级为缺省值,作为Backup设备。
    SW2:
inter VLAN 100
vrrp vrid 2 virtual-ip 10.1.1.111
quit

SW3:


inter VLAN 100
vrrp vrid 2 virtual-ip 10.1.1.111
vrrp vrid 2 priority 120  
vrrp vrid 2 preempt-mode timer delay 20   
quit