• 在网络部分理论知识的学习过程中,MSTP(即多实例生成树)属于比较难掌握的知识点,本实验为大家介绍MSTP综合实验讲解,实验要求和拓扑如下。
  • 实验要求:
    1.Client1属于vlan10,Client2属于vlan20,Server1属于vlan30;
    2.vlan10、vlan20、vlan30的网关在SW3上;
    3.实现Client1和Client2访问Server1时,流量负载均衡且路径最优。
  • 实验拓扑如下图:

华为交换机MSTP综合实验详解

第一步:在SW1、SW2、SW3上面配置基本网络。

SW1配置
sysname SW1
vlan batch 10 20 30
port-group 1
group-member Ethernet 0/0/1 Ethernet 0/0/2
port link-type trunk
port trunk allow-pass vlan all
quit
interface Ethernet0/0/10
port link-type access
port default vlan 10
quit
SW2配置
sysname SW2
vlan batch 10 20 30
port-group 1
group-member Ethernet 0/0/1 Ethernet 0/0/2
port link-type trunk
port trunk allow-pass vlan all
quit
interface Ethernet0/0/10
port link-type access
port default vlan 20
quit
SW3配置
sysname SW3
vlan batch 10 20 30
port-group 1
group-member Ethernet 0/0/1 Ethernet 0/0/2
port link-type trunk
port trunk allow-pass vlan all
quit
interface Ethernet0/0/10
port link-type access
port default vlan 30
quit

第二步:配置MSTP

SW1配置
stp region-configuration
region-name ntd
instance 10 vlan 10
instance 20 vlan 20
instance 30 vlan 30
active region-configuration
quit
SW2配置
stp region-configuration
region-name ntd
instance 10 vlan 10
instance 20 vlan 20
instance 30 vlan 30
active region-configuration
quit
SW3配置
stp region-configuration
region-name ntd
instance 10 vlan 10
instance 20 vlan 20
instance 30 vlan 30
active region-configuration
quit

第三步:配置流量负载均衡且流量最优。

SW1配置
stp instance 10 root primary
SW2配置
stp instance 20 root primary
SW3配置
stp instance 30 root primary

第四步:配置网关

interface Vlanif 10
ip address 192.168.10.254 24
interface Vlanif 20
ip address 192.168.20.254 24
interface Vlanif 30
ip address 192.168.30.254 24
quit

第五步:Server1配置如下图

华为交换机MSTP综合实验详解

Client1、Client2访问Server1的ftp服务如下图:
华为交换机MSTP综合实验详解
华为交换机MSTP综合实验详解

第六步,抓包验证,抓取SW3的0/0/1接口数据包

华为交换机MSTP综合实验详解
如下图,可以抓取到Client1访问Server1时来回的数据包:
华为交换机MSTP综合实验详解
至此,实验配置完毕!!!!