允许转载,但必须注明出版处与原文链接,否则追究其法律责任,谢谢合作!

(原文博客https://blog.51cto.com/11179786)


华为无线-AC+AP小型无线网络配置实验_v1

网络结构图:


28c68ae6eedda0d9ad374f8661c64b02.png-wh_



步骤一:配置网络连通性

SW:

interface Vlanif100

ip address 192.168.0.1 255.255.255.0


interface GigabitEthernet0/0/1

port link-type trunk

port trunk pvid vlan 100

port trunk allow-pass vlan 2 to 4094


interface GigabitEthernet0/0/2

port link-type trunk

port trunk pvid vlan 100

port trunk allow-pass vlan 2 to 4094

最终实现目标与解释:

交换机G0/0/2与G/0/0/1接口通过Vlan100 进行连通,为了AP与AC之间能通讯。


AC:

interface Vlanif100

ip address 192.168.0.2 255.255.255.0

dhcp select interface


interface GigabitEthernet0/0/1

port link-type trunk

port trunk pvid vlan 100

port trunk allow-pass vlan 2 to 4094

最终实现目标与解释:

AC的G/0/01接口与交换机的G/0/0/1接口通过Vlan100 进行连通,为了AP与AC之间能通讯。

Vlan100接口做为管理网络的DHCP,注意AC与AP通讯路过的接口都要打上 pvid vlan 100。


1361199554b02d1d67da9bd64bd8e023.png-wh_


步骤二:配置AP上线到AC

AC:

wlan ac-global country-code cn(默认)

wlan ac-global carrier id other ac id 1


wlan

wlan ac source interface vlanif100

ap-region id 10

ap-region-name test

ap-auth-mode mac-auth(默认)


ap id 0 type-id 19 mac 00e0-fc2c-72f0

ap-sysname test-1

region-id 10

最终实现目标与解释:

在Wlan视图下,指定AC的Vlan100接口作为AP上线通讯接口,创建一个AP组 ID为10,命名为test。

通过手动mac方式添加AP, type-id 19为AP型号对应的ID编号,AP命名为test-1并加入相应的组。

4ceca99e803374324a0d3170c8e77312.png-wh_


步骤三:放出Wifi信号

interface Vlanif101

ip address 192.168.101.1 255.255.255.0

dhcp select interface


interface Wlan-Ess1

port hybrid pvid vlan 101

port hybrid untagged vlan 101

最终实现目标与解释:

为无线用户提供一个DHCP服务,使用Vlan101接口做DHCP。

创建一个虚拟二层接口Ess1,以普通物理二层接口功能差不多。


wlan

wmm-profile name wmm id 1

radio-profile name radio id 1

wmm-profile id 1

最终实现目标与解释:

wmm相当于Qos,主要用于质量控制,需要绑到射频模板上使用。

创建一个射频模板,某个射频调用了它,该射频就拥继承模板上的参数。


traffic-profile name traffic id 1

security-profile name security id 1

最终实现目标与解释:

创建一个流量模样和一个安全模板,可以不配置参数,但必须创建并加到服务集中。


wlan

service-set name test id 1

forward-mode tunnel

ssid test-xcw

wlan-ess 1

service-vlan 101

traffic-profile id 1

security-profile id 1

最终实现目标与解释:

创建一个服务集,用于射频调用,里边集成了各种刚刚创建的模板。


ap 0 radio 0

radio-profile id 1

service-set id 1 wlan 1

最终实现目标与解释:

在AP 0上的0=2.4G射频上调用射频模板与服务集。


commit ap 0

最终实现目标与解释:

最后在Wlan视图下提交AP的配置才会放出Wifi信号。

ce7fe1a679b17c5915a343e680567d1d.png-wh_


步骤四:让用户访问互联网

网络结构图:

88755c1ed6581562d022ac0fe251688c.png-wh_

        由于无线用户是通过AC上的Vlan101接口的DHCP获取IP地址,所以网关为Vlan101的地址(192.168.101.1),由于访问其它网段需要路由,建议使用动态路由协议OSPF。

        在AR、SW、AC之间建立一个OSPF-AREA,并公布相关网段。本文不作OSPF研究,如需要了解OSPF配置知识,后续会出相关文章。

9c506ebc2fabc3226e24ddf8e3e218c2.png-wh_


--END