版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。http://zhxai.blog.51cto.com/1184228/271655
 
 
 
实验目的:
(一)禁止pc2上网,其他局域网内主机不受影响。pc2、pc3、pc1都在不同的子网里。
(二)使局域网内所有主机都能上网。(只有一个公网地址)
(三)局域网内所有主机ip地址均自动获取。
(四)r1提供单臂路由和dhcp功能,实现vlan间通信
(五)两个交换机一个为vtp server,另一个为vtp client,vtp有密码.交换机之间做端口汇聚。
(六)通过用浏览器访问R2的公网地址访问WEB服务器
附  r1的公网地址172.16.1.1/24
       r2的公网地址172.16.1.2/24
       r1与r2之间有chap认证。
工程分析:
相关设备配置:
R1的相关配置
Router>en
Router#conf t
Router(config)#int f0/0
Router(config-if)#no ip add
Router(config-if)#no shut
Router(config-if)#int f0/0.2
Router(config-subif)#encapsulation dot1Q 2
Router(config-subif)#ip add 192.168.1.1 255.255.255.0
Router(config-subif)#no shut
Router(config-subif)#int f0/0.3
Router(config-subif)#encapsulation dot1Q 3
Router(config-subif)#ip add 192.168.2.1 255.255.255.0
Router(config-subif)#int f0/0.4
Router(config-subif)#encapsulation dot1Q 4
Router(config-subif)#ip add 192.168.3.1 255.255.255.0
Router(config-subif)#exit
Router(config)#ip dhcp pool t1
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.1
Router(dhcp-config)#ip dhcp pool t2
Router(dhcp-config)#network 192.168.2.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.2.1
Router(dhcp-config)#ip dhcp pool t3
Router(dhcp-config)#network 192.168.3.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.3.1
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.1.1
Router(config)#ip dhcp excluded-address 192.168.2.1
Router(config)#ip dhcp excluded-address 192.168.3.1
Router(config)#int s0/1/0
Router(config-if)#ip add 172.16.1.1 255.255.255.0
Router(config-if)#clock rate 64000
Router(config-if)#no shut
Router(config-if)#encapsulation ppp
Router(config-if)#ppp authentication chap
Router(config-if)#exit
Router(config)#hostname r1
r1(config)#username r2 password 123
r1(config)#ip nat pool z1 172.16.1.1 172.16.1.1 netmask 255.255.255.0
r1(config)#access-list 1 deny 192.168.2.0 0.0.0.255
r1(config)#access-list 1 permit any
r1(config)#ip nat inside source list 1 pool z1 overload
r1(config)#int f0/0.2
r1(config-subif)#ip nat inside
r1(config-subif)#int f0/0.3
r1(config-subif)#ip nat inside
r1(config-subif)#int f0/0.4
r1(config-subif)#ip nat inside
r1(config-subif)#int s0/1/0
r1(config-if)#ip nat outside
R2的相关配置
Router>en
Router#conf t
Router(config)#int s0/1/0
Router(config-if)#ip add 172.16.1.2 255.255.255.0
Router(config-if)#no shut
Router(config-if)#int f0/0
Router(config-if)#ip add 192.168.4.1 255.255.255.0
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#int s0/1/0
Router(config-if)#encapsulation ppp
Router(config-if)#ppp authentication chap
Router(config)#hostname r2
r2(config)#username r1 password 123
r2(config)#ip nat inside source static tcp 192.168.4.2 80 172.16.1.2 80
r2(config)#access-list 1 permit any
r2(config)#ip nat inside source list 1 interface s0/1/0 overload
r2(config)#int f0/0
r2(config-if)#ip nat inside
r2(config-if)#int s0/1/0
r2(config-if)#ip nat outside
S0的相关配置
Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int range f0/3-4
Switch(config-if-range)#switch mode trunk
Switch(config-if-range)#channel-group 1 mode on
Switch(config-if-range)#int f0/1
Switch(config-if)#switch mode trunk
Switch(config-if)#exit
Switch(config)#vtp mode server
Switch(config)#vtp domain aaa
Switch(config)#vtp password bbb
Switch(config)#vlan 2
Switch(config-vlan)#name a2
Switch(config-vlan)#vlan 3
Switch(config-vlan)#name a3
Switch(config-vlan)#vlan 4
Switch(config-vlan)#name a4
Switch(config-vlan)#exit
Switch(config)#int f0/2
Switch(config-if)#switch mode access
Switch(config-if)#switch access vlan 2
S1的相关配置
Switch>en
Switch#conf t
Switch(config)#int range f0/3-4
Switch(config-if-range)#switch mode trunk
Switch(config-if-range)#channel-group 1 mode on
Switch(config-if-range)#exit
Switch(config)#vtp mode client
Switch(config)#vtp domain aaa
Switch(config)#vtp password bbb
Switch(config)#int f0/1
Switch(config-if)#switch mode access
Switch(config-if)#switch access vlan 3
Switch(config-if)#int f0/2
Switch(config-if)#switch mode access
Switch(config-if)#switch access vlan 4
本文出自 “我们说好的幸福” 博客,请务必保留此出处http://zhxai.blog.51cto.com/1184228/271655