版权声明:原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 、作者信息和本声明。否则将追究法律责任。http://yangkaichun.blog.51cto.com/1058887/238915
        今天花了一个小时, 把上个星期学习的CCNA的配置的一些基本命令总结了一下,虽然还有很多理论地方不是太明白,但还是写出来了,作为一个学习的开始吧!
       一下总结如有错误之处希望朋友们给我指正一下,虚心求教!
 
 
       ------------------基本配置------------------------------------
01.路由器的基本配置:
Router>用户模式
Router>enable用户进入特权模式
Router#特权模式
Router#configure terminal特权进入全局配置模式
Router(config)#全局配置模式
Router(config)#hostname R1命名
R1(config)#no ip domain-lookup 关闭域名解析模式
R1(config)#line console 0进入控制台口
R1(config-line)#logging synchronous日志信息同步
R1(config)#interface fastethernet 0/0进入不同的接口
R1(config-if)#ip address 192.168.1.1 255.255.255.0配置IP
R1(config-if)#no shutdown开启接口
R1(config-if)#clock rate 64000  DCE端时钟配置
show命令都是在特权模式下的
R1(config)#show ip route查看路由表
R1(config)#show running-config查看当前配置
R1(config)#show ip interface brief查看端口配置
R1(config)#copy running-config startup-config当前配置保存为启动配置
R1(config)#write memory保存
  
-----------------------------------------------------------------------------
02.路由协议:
 Static routes/Default Static routes
 RIP
 Eigrp
 ospf
-----------------------------------------------------------------------------
Default Static routes
R1(config)#ip route 0.0.0.0 0.0.0.0 192.1.12.2缺省路由
R1(config)#ip route 0.0.0.0 0.0.0.0 192.1.21.2 10浮动静态路由10是管理距离
管理距离应用于协议之间的比较,metric值应用于协议内部之间的比较
Static routes
R1(config)#ip route 192.1.2.0 255.255.255.0 192.1.12.2下一跳地址(直连对端地址)
R1(config)#ip route 192.1.2.0 255.255.255.0 fastethernet0/0出站接口
------------------------------------------------------------------------------
03.RIP
R1(config)#router rip开启rip
R1(config-router)#version 2 版本号
R1(config-router)#no auto-summary关闭自动汇总
R1(config-router)#network 11.1.1.1宣告自己loopback端的ip(网段号也可以)
R1(config-router)#network 192.1.12.1宣告自己路由器的ip(网段号也可以)
自动汇总和手工汇总都会抑制明细路由,做手工汇总必须先关闭自动汇总。
R1(config)#no router rip删除rip协议
R1#show ip protocol 查看ip协议
R1#clear ip route * 清空路由表
------------------------------------------------------------------------------
04.Erigp
R1(config)#router eigrp 1
R1(config-router)#no auto-s
R1(config-router)#network 1.0.0.0宣告loopback的ip网段号(ip地址也可以)
R1(config-router)#network 192.1.12.0宣告路由器ip网段号(ip地址也可以)
R1#show ip eigrp neighbors查看邻居表
R1#show ip rigrp topolgy查看拓扑表
R1#show ip route eigrp通过eigrp学习到得路由
DUAL算法:后继,可行距离FD,通告距离AD,可行性条件FC(FD>AD),可行后继
Eigrp的邻居表,拓扑表,路由表。
-----------------------------------------------------------------------------
05.OSPF
R1#show ip neighbor查看邻居表
R1#show ip ospf datebase查看数据库
R1#show ip ospf interface ethernet1/0查看接口配置
priority优先级  0-255  默认为1
R1#(config-if)#ip ospf priority 10 修改优先级为10
R1(config-router)#router-id 11.11.11.11修改id
配置:
R1(config)#router ospf 1
R1(config-router)#network 1.1.1.0 0.0.0.255 area 1
R1(config-router)#network 192.1.12.0 0.0.0.255 area 0
R2(config)#router ospf 1
R2(config-router)#network 2.2.2.0 0.0.0.255 area 2
R2(config-router)#network 192.1.12.0 0.0.0.255 area 0
这个配置具体还不清楚
R1(config)#int e1/0
R1(config-if)#ip ospf hello-interval 5修改hello时间
R1(config-if)#ip ospf dead-interval 10修改dead时间
----------------------------------------------------------------------------
06.ACL 访问控制列表
---------------------------------------
telnet设置:                         
R1(config)#line vty 0                
R1(config-line)#password yangkaichun 
---------------------------------------
R1(config)#access-list 1 deny 1.1.1.1 0.0.0.0拒绝1.1.1.1访问
R1(config)#access-list 1 premit any允许其它的
R1(config)#int e1/0进入端口调用
R1(config-if)#ip access-group 1 in调用ACL
R1(config)#access-list 100 deny tcp any any eq telnet 不允许telnet登陆
R1(config)#access-list 100 permit ip any any 允许其它的
R1(config)#int e 1/0进入端口调用
R1(config-if)#ip access-group 100 in
R1(config)#access-list 100 deny icmp host 192.1.12.2 host 1.1.1.1 echo拒绝ICMP包
 

R1(config)#access-list 100 deny tcp any any eq 80(不允许HTTP的进入)把80换成?就可查看端口编号了
本文出自 “看不见的网” 博客,请务必保留此出处http://yangkaichun.blog.51cto.com/1058887/238915