(十一)Zabbix_java_gateway无法启动

背景:

1、zabbix服务器搭建完成

2、JDK已经源代码安装

思路:

1、都是参考网上文档

一、基本现象

1、现象:启动服务报如下错误

1.png                                              

大概意思:线程“main”中的异常

java.lang.UnsupportedClassVersionError:com / zabbix / gateway / JavaGateway:不支持的major.minor版本52.0

二、原因版本不一样

1、查看jvm和jdk版本是否一致

(1)查看jvm(java命令)和jdk(javac命令)版本一致,linux版本执行

#java version和javac version命令来查看版本是否一致

[root@localhost zabbix_java]# java -version

java version "1.7.0_51"

OpenJDK Runtime Environment (rhel-2.4.5.5.el7-x86_64 u51-b31)

OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)

[root@localhost zabbix_java]# javac -version

javac 1.8.0_151

三、操作:查找JDK路径及做软链接

1、用which命令判断其java和javac的命令的路径

[root@localhost zabbix_java]# which java

/usr/bin/java

[root@localhost zabbix_java]# which javac

/usr/java/1.8.0_151/bin/javac

通过查看文件属性,java是一个符号链接,默认是

/etc/alternatives/java

2.png

于是就想此链接的文件是系统默认的,更改链接路径应该就能解决版本不一样的问题,更改自定义安装的JDK路径中的java,上面which javac查找到的路径:

/usr/java/1.8.0_151/bin/

2、重新做链接

做链接之前先把源文件链接做备份:

# mv /usr/bin/java /usr/bin/java.bak

然后做链接

# ln -s /usr/java/1.8.0_151/bin/java /usr/bin/java

三、查看版本信息

1、java -version

3.png

2、javac version

4.png

3、确认版本成功更改。

注意:根据网上文献,有的用户是javac的路径需要重新做软链接,可以根据自己情况进行更改。我这里是因为不同的用户需要使用不同的JDK,如果希望所有用户都使用相同的版本的,可以使用sudo update-alternatives这样的命令去设置。

四、重新启动zabbix_java_gateway服务

1、重启服务

5.png

2、查看端口

6.png

3、确认zabbix_java_gateway成功启动。