rpm -e --allmatches --nodeps libevent-1.1a-3.2.1

--allmatches
    删除所有那些包匹配PACKAGE_NAME的版本。如果PACKAGE_NAME有多个匹配,正常情况下将有一个错误说明。

升级时openssl遇到的怪胎,error: specifies multiple packages

error: specifies multiple packages 卸载openssl rpm包遇到的怪胎
[root@testserver openssl-0.9.8l]# rpm -qa | grep openssl
openssl-0.9.8e-12.el5
openssl-devel