题意如下:
1、路由器A位于ISP。210.31.197.94是服务商提供的网关。
2、路由器B与C位于学校内部,在B路由器上做了NAT,其中F0是NAT的外部口,S0是NAT的内部口
3、最终目的实现PC到A路由器F1口能够连通
 
 
4、部分配置如下(使用OSPF完成的连接)
路由器B配置:
B#sh run
interface FastEthernet0
 ip address 210.31.197.93 255.255.255.224
 ip nat outside
!
interface Serial0
 ip address 172.16.0.1 255.255.255.252
 ip nat inside
!
router ospf 1
 network 210.31.197.64 0.0.0.31 area 0.0.0.0
 network 172.16.0.0 0.0.0.3 area 0.0.0.0
!
ip nat pool snc 210.31.197.93 210.31.197.93 netmask 255.255.255.224
ip nat inside source list 30 pool snc overload
ip nat inside source list 10 pool snc overload
ip classless
ip route 0.0.0.0 0.0.0.0 210.31.197.94
access-list 10 permit 172.16.0.0 0.0.255.255
access-list 30 permit 1.1.1.0 0.0.0.3

路由器C配置
C#sh run
ip subnet-zero
interface FastEthernet0
 ip address 1.1.1.1 255.255.255.252
!
interface Serial0
 ip address 172.16.0.2 255.255.255.252
 clock rate 64000
!
router ospf 1
 network 172.16.0.0 0.0.0.3 area 0.0.0.0
 network 1.1.1.0 0.0.0.3 area 0.0.0.0
!
ip classless
!
5、路由表
B#sh ip route
     1.0.0.0/30 is subnetted, 1 subnets
O       1.1.1.0 [110/49] via 172.16.0.2, 00:41:20, Serial0
     210.31.197.0/27 is subnetted, 1 subnets
C       210.31.197.64 is directly connected, FastEthernet0
     172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
C       172.16.0.0/30 is directly connected, Serial0
S*   0.0.0.0/0 is directly connected

C#sh ip route
     1.0.0.0/30 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0
      210.31.197.0/27 is subnetted, 1 subnets
O       210.31.197.64 [110/49] via 172.16.0.1, 00:41:10, Serial0
     172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
C       172.16.0.0/30 is directly connected, Serial0
6、问题:
 B可以ping通A上的两个端口的IP,而C只能ping通到A的F0,pc机也是如此,如何修改才能完成到A上F1口连通的配置?