第七章 阶段实验
 
 
网络拓扑
    
1.连线
2.局域网设置
  三层交换机配置步骤
  1.Trunk
Switch(config)#interface range fastEthernet 0/2 – 3
Switch(config-if-range)#switchport mode trunk
  2.利用vtp协议划分vlanvtp模式为server
Switch(config)#vtp domain 123
Switch(config)#vtp mode server
Switch#vlan database
Switch(vlan)#vlan 2
Switch(vlan)#vlan 3
 
  3.设置vlan的三层接口
Switch(config)#interface v2
Switch(config-if)#ip address 192.168.2.1255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface v3
Switch(config-if)#ip address 192.168.3.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
  4.启用路由功能(ip routing)
Switch(config)#ip routing
  5.设置路由接口
  Switch(config)#interface f0/1
  Switch(config-if)#no switchport
  Switch(config-if)#ip address 10.0.0.2 255.255.255.252
  Switch(config-if)#no shutdown
  6.设置默认路由
  Switch(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.1
  7.设置dhcp服务器
8.设置以太网通道
  二层交换机配置步骤
  1.Trunk
Switch(config)#interface range fastEthernet 0/2 – 3
Switch(config-if-range)#switchport mode trunk
  2.配置交换机的vtp模式( Client
Switch(config)#vtp domain 123
Switch(config)#vtp mode client
  3.将端口添加vlan
Switch(config)#interface f0/4
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#interface f0/5
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit
 
  4.启用生成树
  5.设置根网桥(stp协议)
Switch(config)#spanning-tree vlan 2-3 root primary
  6.设置上行速链路(在非根网桥上配置)
  7.设置速端口(交换机上连接服务器的端口要配置速端口)
  8.设置以太网通道
  路由器配置步骤
  RA
  1.设置端口ip(f0/1)
Router(config)#interface f0/1
Router(config-if)#ip address 10.0.0.1 255.255.255.252
Router(config-if)#no shutdown
  2.配置ppp协议(s0/0端口设ip)
Router(config)#interface serial 0/0
Router(config-if)#encapsulation ppp
Router(config-if)#ip address 172.16.1.1 255.255.255.252
Router(config-if)#no shutdown
Router(config-if)#clock rate 128000
  3.RA作为主认证方配置PAP
Router(config)#username 123 password 0 123
  4.设置静态路由
Router(config)#ip route 192.168.2.0 255.255.255.0 10.0.0.2
Router(config)#ip route 192.168.3.0 255.255.255.0 10.0.0.2
Router(config)#ip route 172.17.1.0 255.255.255.0 172.16.1.2
  RB
  1.设置端口ip(f0/0)
Router(config)#interface f0/0
Router(config-if)#ip address 172.17.1.1 255.255.255.0
Router(config-if)#no shutdown
  2.配置ppp协议(s0/0端口设ip)
Router(config)#interface serial 0/0
Router(config-if)#encapsulation ppp
Router(config-if)#ip address 172.16.1.2 255.255.255.252
Router(config-if)#no shutdown
  3.RB作为被认证方配置PAP
Router(config-if)#ppp pap sent-username 123 password 0 123
  4.设置(静态路由)
Router(config)#ip route 192.168.2.0 255.255.255.0 172.16.1.1
Router(config)#ip route 192.168.3.0 255.255.255.0 172.16.1.1
 
 
注意:在配置的时候要分类配置而不能把设备上所需要的命令一口气配上去,那样会导致正确的配置命令在设备上不起作用,使网络不能正常通讯