环境:Ubuntu 10.10

安装前准备:

                jdk-7u3-linux-i586.tar.gz 


                eclipse-SDK-3.7.2-linux-gtk.tar.gz 


                android-sdk_r17-linux.tgz


搭建的各软件,版本都有一定的要求。


  



都解压到,你想指定到的路径:如,你的主路径下建一个文件夹java。将,android-sdk的tools路径、jdk、jre及eclipse路径,存入,~/.bashrc。

http://www.cnblogs.com/dartagnan/archive/2010/11/30/2003532.html


http://blog.csdn.net/mengweiqi33/article/details/7042450



按照正常路径安装。

问题:problem
at the route :/usr/local/eclipse ,i open the folder,and execute the eclipse.however,it has a mistake.can't open.
i didn't figure it out.
solve method: drop it ,and i try use the software center's software-eclipse,however,i don't know whether its version is not matched.after a day,i uninstalled it.Then,download a new eclipse --indigo--3.7.the question of help-->install new software,always can't execute very well.
    because i delete the available softwr site--dl-ssl.google.com/android/eclipse during the install ADT,the result is i can not connect it.
    and, in android SDK manager,the android API levels are not shown up.Reloading does not help any more.

解决方法:

figure out
    i have moved the android-sdk to /usr/local/ ,cd to the route,then at the terminor:
    ./tools/android(after you have installed  jdk)
    opened the android SDK manager,choose tool --> option ,chech the option:force:http ...https.
     reload.(no more change)
     1.9.2 done.then modify the file /etc/hosts,and add the two line before at the ipv6 setting:
     203.208.46.100 dl.google.com

     203.208.46.100 dl-ssl.google.com
    MUCH BETTER.