目前用的最多的是Centos系统 用于python 用ubuntu的系统兼容性比较好,这边的话 我们看如何升级centos下面的python


下载python链接

选择自己需要的版本2.7或者3.0

https://www.python.org/ftp/python/


YUM安装依赖包

必须安装不然安装pip会报错 

yum -y install zlib gcc gcc-c++ zlib-devel openssl openssl-devel mysql-devel libxml2 libxml2-dev libxslt* mysql python-devel libffi-devel


开始安装

查看默认Python版本
python -V
 
1、安装gcc,用于编译Python源码

    yum install gcc


2、解压并进入源码文件


3、编译安装

    ./configure    可以指定安装路径
    make all
    make install
4、查看版本
    /usr/local/bin/python2.7 -V
5、修改默认Python版本
    mv /usr/bin/python /usr/bin/python2.6
    ln -/usr/local/bin/python2.7 /usr/bin/python
6、防止yum执行异常,修改yum使用的Python版本
    vi /usr/bin/yum
    将头部 #!/usr/bin/python 修改为 #!/usr/bin/python2.6


安装pip

wget http://pypi.python.org/packages/source/s/setuptools/setuptools-0.6c11.tar.gz
tar zxvf setuptools-0.6c11.tar.gz
cd setuptools-0.6c11
python setup.py build
python setup.py install
# wget http://pypi.python.org/packages/source/d/distribute/distribute-0.6.10.tar.gz
# tar xf distribute-0.6.10.tar.gz
# cd distribute-0.6.10
# python2.7 setup.py install
#wget "https://pypi.python.org/packages/source/p/pip/pip-1.5.4.tar.gz#md5=834b2904f92d46aaa333267fb1c922bb" --no-check-certificate
# tar -xzvf pip-1.5.4.tar.gz
# cd pip-1.5.4
# python setup.py install


升级pip

pip install --upgrade pip