安装cacti插件架构扩展


要使用cacti插件必须先扩展cacti架构,来支持插件。

 

下载地址:http://forums.cacti.net/download/file.php?id=13136&sid=3a779e2a7b31eed54b61f120ab8cffa9


注:PA-2.0专门为0.8.7b设计的,版本一定要对应


# tar –zxvf cacti-plugin-arch-2.0.tar.gz

# cd cacti-plugin-arch

# cp cacti-plugin-0.8.7b-PA-v2.0.diff /usr/local/apache/htdocs/cacti

# cp pa.sql /usr/local/apache/htdocs/cacti

# cd /usr/local/apache/htdocs/cacti

# patch -p1 -N < cacti-plugin-0.8.7b-PA-v2.0.diff

# mysql -u cactiuser -p123456 cacti < pa.sql


打开浏览器,http://localhost/cacti    对cacti 进行配置


打开“控制面板———→用户管理———→admin”然后在“区域权限”选

项卡中勾选“Plugin Management”,然后点击保存-控制面板-Configuration-Plugin Management