点到点拓补中的OSPF运行
1)点对点网络的介绍:
在点对点网络上,路由器通过使用组播地址224.0.0.5发送Hello数据包,检查它的邻居。点到点网络不需要选举DR和BDR,在2台路由器能够直接通信时,他们就形成了相邻关系,如下图所示:
image
在点对点拓补结构上默认的Hello间隔和Down判断时间分别是10S和40S。这2个参数和在广播型多路访问网络上的值是相同的。
在点对点链路上配置OSPF使用的命令和步骤跟在广播型多路访问链路上配置OSPF的命令没有区别。
2)点对点网络运行OSPF的实验:拓补图如下图:
image
① 路由器R1、R2、R3的基本配置根据图示配置。
clip_image007clip_image009clip_image011
② 路由器R1上的邻居表
clip_image013
③ 路由器R2上的邻居表
clip_image015
④ 路由器R3上的邻居表
clip_image017
在路由器R1、R2、R3上看到的邻居如上所示,在状态(State)属性下并没有显示身份(DR/BDR),因为在点对点链路上不需要选举DR和BDR的。
⑤ 查看路由器R2上接口信息
clip_image019
从输入接口信息可以看到网络类型是点对点网络,有2个邻居并建立邻接关系。
⑥ 路由器R2的链路状态数据库
clip_image021
⑦ 路由器R3的链路状态数据库
clip_image023
R2、R3输出的链路状态数据库表明,链路类型只有路由器链路(Router Link),没有网络链路(Net Link),因为网络链路是由DR上接口地址来表示的,而在点对点链路中不选举DR和BDR。
image
非广播型多路访问(NBMA)下的OSPF运行
1NBMA的基本特征
NBMA网络是指那些能够支持多台路由器但不具备广播或组播能力的网络。例如,帧中继、ATM和X.25等,“多路访问”意味着一个NBMA的网络“云”是多台设备相连的单个网络,和以太网或者令牌环网一样,但他又和以太网、令牌环网等广播型网络不同,他是非广播的。“非广播”就意味着发送到这个网络上的数据包不一定会被该网络相连的其他所有路由器看到。当路由器的一个接口通过NBMA网络与其他路由器连接时,就会遇到路由器信息可达性问题。如图所示,路由器Site4在同一个物理接口上建立3个PVC,分别于Site1、Site2和Site3连接,这样,Site4可以使用不同的PVC与另外3个地点上的路由器进行通信,而Site1、Site2和Site3之间不能够直接通信,因为他们之间没有PVC。这3点之间如果需要通信,则需经由Site4的转递。
image
从Site4上看,尽管在同一物理接口上有三条虚链路,可是,Site4发送给Site1的数据Site2和Site3是收不到的,同理,发送给Site2的数据Site1和Site3是收不到;发送给Site3的数据Site1和Site2收不到,这就是NBMA网路的特征。假设4台路由器是通过广播型网络互连的,比如以太网,Site 4发送的任何数据都能被其他3台路由器收到。
2 OSPFNBMA拓补中运行的五种模式
在NBMA网络中OSPF的运行模式共有5中,分别是RFC2328定义的2种和CISCO定义的3种,至于OSPF运行那种模式,我们可以进入到通告OSPF的接口上使用ip OSPF Network命令来决定OSPF运行那种模式,其命令如下:
Router(config-if)#ip ospf network {broadcase | nonbroadcast | point-to-multipoint | point-to-multipoint nonbroadcast | point-to-point}
下面通过图表和文字对五种模式进行描述:
1. NBMA模式
NBMA模式是RFC定义模式,在该模式下,OSPF模仿在广播型网络上的运行机制。为了产生广播效果,路由器把需要广播的数据使用单播地址分别发送到所有目的地。在这种模式下,为了让路由器建立起邻接关系,他们之间应该是全互连的VC,而且他们的地址还必须在同一个子网内。同时为了能够让他们选举出DR和BDr,也必须手工为每一台路由器配置他的邻居,DR也会向网络中产生网络LSA。
该模式的特点:
Ø 各路由器之间使用VC建立起全互连的逻辑拓补
Ø 邻居属于同一个子网
Ø 手工指定邻居
Ø 路由器之间选举DR和BDR
Ø LSA和LSAck数据包被分别发送到每一个邻居路由器
2. 点对多点(point-to-multipoint)模式
点对多点模式是RFC定义的模式,在该模式下,OSPF把非广播型网络上所有路由器到路由器的链路看做是点到点链路,他们彼此之间会建立起邻接关系,因此,不选举DR和BDR,当然也不会产生网络LSA。使用点对多点模式不需要全互连的逻辑拓补,因此可以节约VC的数量。OSPF点对多点模式是通过交换附加的链路状态信息来工作的,这种更新信息包含很多描述相邻路由器的连通性的信息元素。
该模式的特点是:
Ø 不需要全互连的逻辑拓补,可以是部分全互连或者星型拓补
Ø 不需要手工配置邻居
Ø 邻居属于同一个子网
Ø 不选举DR和BDR
Ø LSA和LSAck数据包被发送到每个邻居路由器
3. 点对多点非广播(point-to-multipoint nonbroadcase)模式
点对多点非广播模式是Cisco定义的模式,该模式对RFC定义的点对多点模式进行了扩展。RFC点到多点模式运行在底层支持组播和广播的点对点虚电路,因此能够动态的发现邻居的环境。但是,有些点对多点网络底层不支持组播和广播,所以不能采用点对多点模式,在这种情况下可以采用点对多点非广播模式。
该模式的特点是:
Ø 部分全互连或者星型逻辑拓补;
Ø 邻居属于同一个子网
Ø 手工配置邻居
Ø 不选举DR和BDR
4. 点对点(point-to-point)模式
点对点模式是Cisco定义的模式,该模式通常在点到点型子接口上,每个点到点链路对应一个独立的IP子网,如同运行在点对点的拓补中一样
该模式的特点是:
Ø 通过点对点子接口的部分全互连拓补或者星型逻辑拓补
Ø 不需要手工配置邻居
Ø 不选举DR和BDR
Ø 各子接口属于不同的子网
5. 广播(Broadcast)模式
广播模式是Cisco定义的模式,该模式是避免静态列出所有现存邻居的一种解决方法。接口被逻辑的设为广播型,并以在BMA网络上的姿态运行。仍然选举DR和BDR,也会产生Net Link LSA,因此各点的连通性是至关重要的,全互连的逻辑拓补接口能够保证各点的连通性。
该模式的特点是:
Ø 全互连的逻辑拓补
Ø 邻居属于同一个子网
Ø 不需要手工配置邻居
Ø 路由器之间选举DR和BDR
下面用图表来比较这五种运行在NBMA网络中OSPF的运行模式:
image
3NBMA模式的配置实验
实验拓补图如下:
image
① 路由器R1的配置
clip_image030
② 路由器R2的配置
clip_image032
③ 路由器R3的配置
clip_image034
④ 路由器R4的配置
clip_image036
⑤ 查看路由器R1接口运行模式
clip_image038
从输出的内容可以看到:接口运行在非广播模式,即NBMA模式,并且选举出了DR和BDR,而路由器器R1现在的身份就是DROther,DR是R4,BDR是R2.
⑥ 查看路由器R2上的拓补数据库
clip_image040
输出显示,DR产生并且通告了第二种类型的LSA——NET LSA。
⑦ 查看路由器R1的邻居表
clip_image042
从邻居表中可以看出查看拓补数据结构DR是路由器R4,BDR是路由器R2,其余两台路由器是DROther。
⑧ 查看路由表
clip_image044
image
4)点对多点模式的配置实验
实验拓补图如下:
image
① 路由器R1的配置:
clip_image049clip_image051
② 路由器R2的配置:
clip_image053
③ 路由器R3的配置:
clip_image055
注意:将Network 12.12.12.0 0.0.0.255 area 0改为network13.13.13.0 0.0.0.255 area 0
④ 路由器R4的配置
clip_image057
image
⑤ 以R1为例,查看子接口接口serial1/2.12运行模式;
clip_image060
⑥ 查看R1的邻居数据库:
clip_image062
⑦ 在路由器R1上ping路由器R2、R3和R4
clip_image064
⑧ 在路由器R1上看到的路由器表
clip_image066
⑨ 在R1上看到的拓补数据库:
clip_image068
5)点对多点非广播实验
点对多点非广播模式的拓补图跟点对多点的拓补图是一样的,所以点对多点非广播模式的拓补图就看点对多点的拓补图就好了。其实点对多点非广播模式的基本配置和点对多点模式的基本配置没有太大的区别,只需要在指定运行模式的命令中附加一个non-broadcast参数即可,即接口模式下配置的ip ospf network point-to-point(点对多点)修改为ip ospf network point-to-point non-broadcast(点对多点非广播)。但路由器的工作方式却有本质上的改变——用单播替代了组播完成了信息的交换。由于不支持广播,所以需要手动指定邻居。4台路由器的配置如下所述(用show run 截取重要配置):
① 路由器R1的相关配置:
clip_image070
本实验中,R1上没有使用neighbor命令建立邻居关系,但并不代表总是可以省略。
②路由器R2的相关配置
R2#show run
!
interface Loopback1
ip address 12.12.12.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/2
ip address 123.123.123.21 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
serial restart-delay 0
frame-relay map ip 123.123.123.12 201 broadcast
i
router ospf 100
log-adjacency-changes
network 12.12.12.0 0.0.0.255 area 0
network 123.123.123.0 0.0.0.255 area 0
neighbor 123.123.123.12
 
③ 路由器R3的相关配置
R3#show run
!
interface Loopback1
ip address 13.13.13.1 255.255.255.0
ip ospf network point-to-point
interface Serial1/2
ip address 123.123.123.31 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
serial restart-delay 0
frame-relay map ip 123.123.123.13 301 broadcast
i!
router ospf 100
log-adjacency-changes
network 13.13.13.0 0.0.0.255 area 0
network 123.123.123.0 0.0.0.255 area 0
neighbor 123.123.123.13
 
④ 路由器R4的相关配置
R4#show run
!
interface Loopback1
ip address 14.14.14.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/2
ip address 123.123.123.41 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
serial restart-delay 0
frame-relay map ip 123.123.123.14 401 broadcast
!
router ospf 100
log-adjacency-changes
network 14.14.14.0 0.0.0.255 area 0
network 123.123.123.0 0.0.0.255 area 0
neighbor 123.123.123.14
 
⑤ 查看路由器R3的接口类型:
clip_image075
输出显示,与运行点对多点模式下的输出没有输出区别。
⑥ 查看路由器的邻居表:
clip_image077clip_image079clip_image081clip_image083
输出结果显示:不选举DR和BDR
⑦ 查看拓补数据库
clip_image085
⑧ 在R1上查看路由表:
clip_image087
6)点对点模式的实验
实验拓补图如下:
image
① 路由器R1的相关配置
R1#show run
interface Loopback1
ip address 11.11.11.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/2
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/2.12 point-to-point
ip address 123.123.12.12 255.255.255.0
frame-relay interface-dlci 102
!
interface Serial1/2.13 point-to-point
ip address 123.123.13.13 255.255.255.0
frame-relay interface-dlci 103
!
interface Serial1/2.14 point-to-point
ip address 123.123.14.14 255.255.255.0
frame-relay interface-dlci 104
!
router ospf 100
log-adjacency-changes
network 11.11.11.0 0.0.0.255 area 0
network 123.123.0.0 0.0.15.255 area 0
②路由器R2的相关配置
R2#show run
!
interface Loopback1
ip address 12.12.12.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/2
ip address 123.123.12.21 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
frame-relay interface-dlci 201
!
router ospf 100
log-adjacency-changes
network 12.12.12.0 0.0.0.255 area 0
network 123.123.12.0 0.0.0.255 area 00
③路由器R3的相关配置
R3#show run
!
interface Loopback1
ip address 13.13.13.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/2
ip address 123.123.13.31 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
frame-relay interface-dlci 301
!
router ospf 100
log-adjacency-changes
network 13.13.13.0 0.0.0.255 area 0
network 123.123.13.0 0.0.0.255 area 0
④路由器R4的相关配置
R4#show run
!
interface Loopback1
ip address 14.14.14.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/2
ip address 123.123.14.41 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
serial restart-delay 0
frame-relay interface-dlci 401
!
router ospf 100
log-adjacency-changes
network 14.14.14.0 0.0.0.255 area 0
network 123.123.14.0 0.0.0.255 area 0
!
 
image
⑤查看路由器R4接口的运行模式
clip_image092
从输出显示可以看出接口运行在点对点模式上,还有就是Hello间隔时间是10S,Dead时间是40S,wait时间是40S
⑥查看个路由器的邻居表:
clip_image094
clip_image096
clip_image098
clip_image100
从输出结果可以看出,优先级都变成了0,同时不选举DR和BDR
⑦查看R1上的路由器表
clip_image102
⑧查看路由器R3上的路由器表:
clip_image104
⑨查看路由器R2上的拓补数据库
clip_image106
⑩在路由器R3测试路由器R3跟路由器R2及R4的连通性
clip_image108
7)广播模式实验
实验拓补图如下:采用了全互连的逻辑拓补接口,接口运行在广播模式下,同时启动了inverse-arp 自动地址映射功能。
image
① 路由器R1的配置
clip_image110
② 路由器R2的配置:
clip_image112
③ 路由器R3的配置:
clip_image114
④ 路由器R4的配置:
clip_image116
⑤ 查看各路由器的邻居表
clip_image118clip_image120clip_image122clip_image124
从输出结果可以看出,DR是路由器R4,BDR是路由器R3,路由器R2和R1都是DRother
⑥ 查看路由器R1接口模式
clip_image126
输出结果看出:接口运行在广播模式
⑦ 查看路由器R2的拓补数据库
clip_image128
从输出结果看到:有DR产生的第二类LSA——Net-Link LSA
⑧ 查看R4上的路由表
clip_image130
⑨ 在路由器R2查看帧中继中自动地址映射结果如下:
clip_image132
⑩ 在R4上测试到路由器R1的连通性:
clip_image002