Hsrp 、vrrp简介以及案例
Hsrp简介:
HSRP 是 Cisco 的专有协议。HSRP(Hot Standby Router Protocol)把多台路由器组成
一个“热备份组”,形成一个虚拟路由器。这个组内只有一个路由器是活动的(Active),并
由它来转发数据包,如果活动路由器发生了故障,备份路由器将成为活动路由器。从网络内
的主机来看,网关并没有改变。
HSRP 路由器利用 HELLO 包来互相监听各自的存在。当路由器长时间没有接收到 HELLO
包,就认为活动路由器故障,备份路由器就会成为活动路由器。HSRP 协议利用优先级决定
哪个路由器成为活动路由器。如果一个路由器的优先级比其它路由器的优先级高,则该路由
器成为活动路由器。路由器的缺省优先级是 100。 一个组中,最多有一个活动路由器和一
个备份路由器。
HSRP 路由器发送的多播消息有以下三种:
(1) HELLO : HELLO 消息通知其它路由器发送路由器的 HSRP 优先级和状态信息,HSRP 路
由器默认为每 3 秒钟发送一个 HELLO 消息;
(2) Coup:当一个备用路由器变为一个活动路由器时发送一个 coup 消息; 
(3) Resign:当活动路由器要宕机或者当有优先级更高的路由器发送 HELLO 消息时,主
动发送一个 resign 消息。
HSRP 路由器有以下六种状态:
(1) Initial :HSRP 启动时的状态,HSRP 还没有运行,一般是在改变配置或接口刚刚启
动时进入该状态;
(2) Learn :路由器已经得到了虚拟 IP 地址,但是它既不是活动路由器也不是备份路由
器。它一直监听从活动路由器和备份路由器发来的 HELLO 报文;
(3) Listen:路由器正在监听 HELLO 消息;
(4) Speak :在该状态下,路由器定期发送 HELLO 报文,并且积极参加活动路由器或备份
路由器的竞选;
(5) Standby :当活动路由器失效时路由器准备接管数据传输功能;
(6) Active:路由器执行数据传输功能。
VRRP简介
VRRP(Virtual Router Redundancy Protocol,虚拟路由器冗余协议)将可以承担网关功能的一组路由器加入到备份组中,形成一台虚拟路由器,这样主机的网关设置成虚拟网关,就能够实现冗余。
VRRP是一种容错协议,在提高可靠性的同时,简化了主机的配置。在具有多播或广播能力的局域网(如以太网)中,借助VRRP能在某台路由器出现故障时仍然提供高可靠的缺省链路,有效避免单一链路发生故障后网络中断的问题,而无需修改动态路由协议、路由发现协议等配置信息。
VRRP协议的实现有VRRPv2和VRRPv3两个版本。其中,VRRPv2基于IPv4,VRRPv3基于IPv6。VRRPv2和VRRPv3在功能实现上并没有区别,只是应用的网络环境不同。
VRRP备份组简介
VRRP将局域网内的一组路由器划分在一起,称为一个备份组。备份组由一个Master路由器和多个Backup路由器组成,功能上相当于一台虚拟路由器。
VRRP备份组具有以下特点:
• 虚拟路由器具有IP地址,称为虚拟IP地址。局域网内的主机仅需要知道这个虚拟路由器的IP地址,并将其设置为缺省路由的下一跳地址。
• 网络内的主机通过这个虚拟路由器与外部网络进行通信。
• 备份组内的路由器根据优先级,选举出Master路由器,承担网关功能。其他路由器作为Backup路由器,当Master路由器发生故障时,取代Master继续履行网关职责,从而保证网络内的主机不间断地与外部网络进行通信。
图 1 VRRP组网示意图

如图 1所示,Router A、Router B和Router C组成一个虚拟路由器。此虚拟路由器有自己的IP地址。局域网内的主机将虚拟路由器设置为缺省网关。Router A、Router B和Router C中优先级最高的路由器作为Master路由器,承担网关的功能。其余两台路由器作为Backup路由器。
1. 备份组中路由器的优先级
VRRP根据优先级来确定备份组中每台路由器的角色(Master路由器或Backup路由器)。优先级越高,则越有可能成为Master路由器。
VRRP优先级的取值范围为0到255(数值越大表明优先级越高),可配置的范围是1到254,优先级0为系统保留给特殊用途来使用,255则是系统保留给IP地址拥有者。当路由器为IP地址拥有者时,其优先级始终为255。因此,当备份组内存在IP地址拥有者时,只要其工作正常,则为Master路由器。
2. 备份组中路由器的工作方式
备份组中的路由器具有以下两种工作方式:
• 非抢占方式:如果备份组中的路由器工作在非抢占方式下,则只要Master路由器没有出现故障,Backup路由器即使随后被配置了更高的优先级也不会成为Master路由器。
• 抢占方式:如果备份组中的路由器工作在抢占方式下,它一旦发现自己的优先级比当前的Master路由器的优先级高,就会对外发送VRRP通告报文。导致备份组内路由器重新选举Master路由器,并最终取代原有的Master路由器。相应地,原来的Master路由器将会变成Backup路由器。
3. 备份组中路由器的认证方式
为了防止非法用户构造报文***备份组,VRRP通过在VRRP报文中增加认证字的方式,验证接收到的VRRP报文。VRRP提供了两种认证方式:
• simple:简单字符认证。
• md5:MD5认证。
在一个安全的网络中,用户也可以不设置认证方式。
VRRP监视功能
1. 监视指定接口功能
VRRP的监视接口功能使其在路由器连接上行链路的接口出现故障时,备份组无法感知上行链路的故障,如果该路由器此时处于Master状态,将会导致局域网内的主机无法访问外部网络。通过监视指定接口的功能,可以解决该问题。当连接上行链路的接口处于Down或Removed状态时,路由器主动降低自己的优先级,使得备份组内其它路由器的优先级高于这个路由器,以便优先级最高的路由器成为Master,承担转发任务。
2. 监视Track项功能
通过VRRP监视Track项功能,可以实现:
• 根据上行链路的状态,改变路由器的优先级。当上行链路出现故障,局域网内的主机无法通过路由器访问外部网络时,被监视Track项的状态为Negative,并将路由器的优先级降低指定的数额。从而,使得备份组内其它路由器的优先级高于这个路由器的优先级,成为Master路由器,保证局域网内主机与外部网络的通信不会中断。
• 在Backup路由器上监视Master路由器的状态。当Master路由器出现故障时,工作在切换模式的Backup路由器能够迅速成为Master路由器,以保证通信不会中断。

Hsrp配置:
实验环境说明:
本实验采用四台cisco3560路由器,
1.基本实验
Hsrp配置
Debug 观察主备之间的切换。熟悉基本配置。
Hsrp的选项:priortiy ,preempt,track检测上行链路失效 ,hello-time

实验拓扑
 

 

Standby   ip是123.123.123.123,R2/R6之间网段是:192.168.1.0
R3/R6之间网段:192.168.2.0   R2/R3/R1之间是采用交换机连接,接口分别是e1/1,  交换机接口是f0/1,f0/2,f0/3。

关键配置
R2(config)#int e1/1 
R2(config-if)#standby 1 preempt
R2(config-if)#stand 1 ip 123.123.123.123
R2(config-if)#stand 1 priority 150

R3(config)#int e1/1 
R3(config-if)#standby 1 preempt
R3(config-if)#stand 1 ip 123.123.123.123
R3(config-if)#stand 1 priority 200
R3(config-if)#stand 1 track int s0/2 60    上行链路s0/2失效后priority立减60切换为standby状态

实验验证
在R3上观察状态(应该是active):
R3(config-if)#do sh stand b
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP    
Et1/1       1   200  P Active   local           123.123.123.2   123.123.123.123
接着我们修改优先级,把R2的优先级调到250,查看r3的状态(应该是standby):
R3(config-if)#do sh stand b
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP    
Et1/1       1   200  P Standby  123.123.123.2   local           123.123.123.123

Vrrp配置
实验目地
Vrrp是业界标准。Track命令必须先在全局下定义track的对象:track 1 interface s0/2 line-protocol
实验拓扑

Vrrp ip是123.123.123.123,R2/R6之间网段是:192.168.1.0
R3/R6之间网段:192.168.2.0   R2/R3/R1之间是采用交换机连接,接口分别是e1/1,  交换机接口是f0/1,f0/2,f0/3。
关键配置
R2:的配置:

track 1 interface Serial0/2 line-protocol

interface Ethernet1/1
 ip address 123.123.123.2 255.255.255.0
 half-duplex
 vrrp 1 ip 123.123.123.123
 vrrp 1 priority 120
vrrp 1 preempt
vrrp 1 track 1 decrement 30
R3的配置:
track 1 interface Serial0/2 line-protocol

interface Ethernet1/1
 ip address 123.123.123.2 255.255.255.0
 half-duplex
 vrrp 1 ip 123.123.123.123
vrrp 1 preempt
实验验证
R2de int s0/2 shutdown以后查看vrrp状态:
R2(config)#do sh vrrp b
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Et1/1              1   15  3921       Y  Backup  123.123.123.3   123.123.123.123

 MSTP以及链路聚合:
MSTP简介:
链路聚合简介:
1、拓扑图

 

Sw1配置:
#
 link-aggregation group 1 mode manual

#
 stp instance 1 root primary   实例1在sw1上作为根桥
 stp enable
stp region-configuration 创建mst域
 region-name test     域名
 revision-level 1    级别设为1
 instance 1 vlan 10 to 20  实例1中包含vlan10 20
 instance 2 vlan 30 to 40  实例2中包含vlan30 40
 active region-configuration  激活mst区域
#
vlan 1
#
vlan 10
#                                        
vlan 20
#
vlan 30
#
vlan 40
#
interface Ethernet1/0/1
 port link-type trunk做trunk端口

 port trunk permit vlan all 允许所有vlan经过turnk链路。
#
interface Ethernet1/0/2
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1
#
interface Ethernet1/0/3
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1
interface Ethernet1/0/4                  
 port link-type trunk
 port trunk permit vlan all
查看链路聚合:
[sw1]dis link-aggregation summary

Aggregation Group Type:D -- Dynamic, S -- Static , M -- Manual
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Actor ID: 0x8000, 000f-e242-8a41

  AL  AL   Partner ID            Select Unselect Share Master
  ID  Type                       Ports  Ports    Type  Port
--------------------------------------------------------------------------------
  1   M    none                  2      0        Shar  Ethernet1/0/2  


[sw1]dis stp instance 1
-------[MSTI 1 Global Info]-------
MSTI Bridge ID      :1.000f-e274-4920
MSTI RegRoot/IRPC   :1.000f-e274-4920 / 0
MSTI RootPortId     :0.0
MSTI Root Type      :PRIMARY root
Master Bridge       :32768.000f-e242-8a41
Cost to Master      :180
TC or TCN received  :47

 ----[Port1(Ethernet1/0/1)][FORWARDING]----
 Port Role           :Designated Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :1.000f-e274-4920 / 128.1
 Num of Vlans Mapped :2
 Port Times          :RemHops 20

 ----[Port2(Ethernet1/0/2)][FORWARDING]----
 Port Role           :Designated Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=180
 Desg. Bridge/Port   :1.000f-e274-4920 / 128.2
 Num of Vlans Mapped :2
 Port Times          :RemHops 20
                                         
 ----[Port4(Ethernet1/0/4)][DISCARDING]----
 Port Role           :Alternate Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :1.000f-e274-4920 / 128.4
 Num of Vlans Mapped :2
 Port Times          :RemHops 20

[sw1]dis stp instance 2
-------[MSTI 2 Global Info]-------
MSTI Bridge ID      :32770.000f-e274-4920
MSTI RegRoot/IRPC   :2.000f-e242-8a41 / 180
MSTI RootPortId     :128.2
Master Bridge       :32768.000f-e242-8a41
Cost to Master      :180
TC or TCN received  :51

 ----[Port1(Ethernet1/0/1)][FORWARDING]----
 Port Role           :Designated Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32770.000f-e274-4920 / 128.1
 Num of Vlans Mapped :2
 Port Times          :RemHops 19

 ----[Port2(Ethernet1/0/2)][FORWARDING]----
 Port Role           :Root Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=180
 Desg. Bridge/Port   :2.000f-e242-8a41 / 128.2
 Num of Vlans Mapped :2
 Port Times          :RemHops 20

 ----[Port4(Ethernet1/0/4)][DISCARDING]----
 Port Role           :Alternate Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32770.000f-e274-4920 / 128.4
 Num of Vlans Mapped :2
 Port Times          :RemHops 19
sw2的配置:
#
 link-aggregation group 1 mode manual

stp instance 2 root primary
 stp enable
stp region-configuration
 region-name test
 revision-level 1
 instance 1 vlan 10 to 20
 instance 2 vlan 30 to 40
 active region-configuration
#
vlan 1
#
vlan 10
#                                        
vlan 20                                  
#
vlan 30
#
vlan 40
#
#
interface Ethernet1/0/2
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1
#
interface Ethernet1/0/3
 port link-type trunk
 port trunk permit vlan all
 port link-aggregation group 1 #
interface Ethernet1/0/4
#
interface Ethernet1/0/5
 port link-type trunk                    
 port trunk permit vlan all
#
interface Ethernet1/0/6
 port link-type trunk
 port trunk permit vlan all
查看链路聚合的汇总信息:
[sw2]dis link-aggregation summary

Aggregation Group Type:D -- Dynamic, S -- Static , M -- Manual
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Actor ID: 0x8000, 000f-e242-8a41

  AL  AL   Partner ID            Select Unselect Share Master
  ID  Type                       Ports  Ports    Type  Port
--------------------------------------------------------------------------------
  1   M    none                  2      0        Shar  Ethernet1/0/2  

查看instance信息:
[sw2]dis stp instance 1
-------[MSTI 1 Global Info]-------
MSTI Bridge ID      :32768.000f-e242-8a41
MSTI RegRoot/IRPC   :0.000f-e274-4920 / 180  区域根桥。
MSTI RootPortId     :128.2
Master Bridge       :32768.000f-e242-8a41
Cost to Master      :0
TC or TCN received  :11

 ----[Port2(Ethernet1/0/2)][FORWARDING]----
 Port Role           :Root Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=180
 Desg. Bridge/Port   :0.000f-e274-4920 / 128.2
 Num of Vlans Mapped :2
 Port Times          :RemHops 20

 ----[Port5(Ethernet1/0/5)][FORWARDING]----
 Port Role           :Master Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32768.000f-e242-8a41 / 128.5
 Num of Vlans Mapped :2
 Port Times          :RemHops 19

  ---- More ----
%Apr  2 02:01:20:182 2000 sw3 SHELL/5/LOGOUT:- 1 - user1(192.168.100.187) in unit1 logout
#Apr  2 02:01:24:549 2000 sw3 L2INF/2/PORT LINK STATUS CHANGE:- 1 -
 Trap 1.3.6.1.6.3.1.1.5.3: portIndex is 4227810, ifAdminStatus is 1, ifOperStatus is 2

%Apr  2 02:01:24:726 2000 sw3 L2INF/5/PORT LINK STATUS CHANGE:- 1 -
 Ethernet1/0/24: is DOWN
 ----[Port6(Ethernet1/0/6)][FORWARDING]----
 Port Role           :Designated Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32768.000f-e242-8a41 / 128.6
 Num of Vlans Mapped :2
 Port Times          :RemHops 19
Sw3配置:
#
 stp enable
stp region-configuration
 region-name test
 revision-level 1
 instance 1 vlan 10 to 20
instance 2 vlan 30 to 40

 active region-configuration
#
vlan 1
#
vlan 10
#
vlan 20
vlan 30
vlan 40
interface Ethernet1/0/1
 port link-type trunk
 port trunk permit vlan all
interface Ethernet1/0/6
 port link-type trunk
 port trunk permit vlan all
#
[sw3]dis stp instance 1
-------[MSTI 1 Global Info]-------
MSTI Bridge ID      :32769.000f-e274-2158
MSTI RegRoot/IRPC   :32769.000f-e274-2158 / 0
MSTI RootPortId     :0.0
Master Bridge       :32768.000f-e274-2158
Cost to Master      :0
TC or TCN received  :0

 ----[Port1(Ethernet1/0/1)][DISCARDING]----
 Port Role           :Alternate Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32769.000f-e274-2158 / 128.1
 Num of Vlans Mapped :2
 Port Times          :RemHops 20

 ----[Port6(Ethernet1/0/6)][FORWARDING]----
 Port Role           :Master Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32769.000f-e274-2158 / 128.6
 Num of Vlans Mapped :2
 Port Times          :RemHops 20

Sw4的配置:
stp enable
stp region-configuration
 region-name test
 revision-level 1
instance 1 vlan 10 to 20

 instance 2 vlan 30 to 40
 active region-configuration
#
vlan 1
vlan 10
vlan 20
#
vlan 30
#
vlan 40
interface Ethernet1/0/4
 port link-type trunk
 port trunk permit vlan all 做trunk端口。
#
interface Ethernet1/0/5
 port link-type trunk
 port trunk permit vlan all

查看mst实例2的状态:
[sw4]display stp instance 2
-------[MSTI 1 Global Info]-------
MSTI Bridge ID      :32769.000f-e274-2158
MSTI RegRoot/IRPC   :32769.000f-e274-2158 / 0
MSTI RootPortId     :0.0
Master Bridge       :32768.000f-e274-2158
Cost to Master      :0
TC or TCN received  :0

 ----[Port1(Ethernet1/0/1)][FORWARDING]----
 Port Role           :Master Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32769.000f-e274-2158 / 128.1
 Num of Vlans Mapped :2
 Port Times          :RemHops 20

 ----[Port6(Ethernet1/0/6)][DISCARDING]----
 Port Role           : Alternate Port
 Port Priority       :128
 Port Cost(Legacy)   :Config=auto / Active=200
 Desg. Bridge/Port   :32769.000f-e274-2158 / 128.6
 Num of Vlans Mapped :2
 Port Times          :RemHops 20


Linux下双网卡绑定:
简介:
两块网卡具有相同的IP地址而并行链接聚合成一个逻辑链路工作。其实这项技术在Sun和Cisco中 早已存在,被称为Trunking和Etherchannel技术,在Linux的2.4.x的内核中也采用这这种技术,被称为bonding。 bonding技术的最早应用是在集群——beowulf上,为了提高集群节点间 的数据传输而设计的。
 步骤:物理网卡 eth0  eth1
# vim /etc/sysconfig/network-scripts/ifcfg-eth0
   DEVICE=eth0
   ONBOOT=yes
   BOOTPROTO=static (两个网卡必须一样)
   MASTER=bond0
# vim /etc/sysconfig/network-scripts/ifcfg-eth1
   DEVICE=eth1
   ONBOOT=yes
   BOOTPROTO=static
   MASTER=bond0
 
逻辑网卡 bond0
# vim /etc/sysconfig/network-scripts/ifcfg-band0
   DEVICE=bind0
   ONBOOT=yes
   BOOTPROTO=static
   IPADDR=192.168.145.101(地址)
   NETMASK=255.255.255.0(子网掩码)
 
编辑所需要的模块:
# vim /etc/modprobe.conf
 ( modprobe bonding)
  alias bond0  bonging
  options bond0  miimon=100(监控间隔) mode=1(工作模式)
 
(bond模式 0 1 2 3 ,0表示负载均衡 1表示冗余 )
 
开机脚本:
# vim /etc/rc.d/rc.local
  ifenslave bond0  eth0 eth1 绑定端口
 
# init 6 重新启动一下
 
# cat /proc/net/bonding/bond0 查看状态
 

浮动静态路由和多链路捆绑:
简介:

浮动静态路由是一种特殊的静态路由,通过配置一个比主路由的管理距离更大的静态路由,保证网络中主路由失效的情况下,提供备份路由。但在主路由存在的情况下它不会出现在路由表中。浮动静态路由主要用于拔号备份

 

案例一:浮动静态路由

 

R1的配置:

 

int e1

ip address 192.168.2.254 24

int s0

ip add 192.168.3.1 24

int s1

ip add 192.168.5.1 24

quit

ospf enable

int e1

ospf enable area 0

int s0

ospf enable area 0

quit

ip route 192.168.4.0 24 192.168.5.2

 

R2的配置:
int s0

ip add 192.168.3.2 24

shut

undoshut

int s1

ip add 192.168.5.2 24

shut

undoshut

int e1

ip add 192.168.4.254 24

quit

 

ospf enable

int e1

ospf enable area 0

int s0

ospf enable area 0

quit

ip route 192.168.2.0 24 192.168.5.1

测试:

断开s0时依旧可以通信:不过先超时,说明发生切换。

 

 

MP协议(the PPP Multilink protocol)能够将多条 PPP链路捆绑起来,从而达到增加带宽的目的。MP协议能够对大的报文进行分片,分片将在多个 PPP链路上送到同一个目的地,从而减少大报文的传送时间。

将多个 PPP链路捆绑成 MP,之后 需要创建一个虚拟接口与对端交换数据。此时也可选择一个接口模板以便动态地创建一个虚拟接口。

虚拟接口模板(Virtual-Template),是用于配置一个虚拟接口的模板,主要应用于***及 MP等应用环境。

 

案例二:mp多链路捆绑

 

 

R1的配置:

 

# int e1

# ip address 192.168.2.254 24

 

# int virtual-tem 1  创建虚拟模板接口

# ip add 192.168.6.1 24

# int s0

ip add 192.168.3.1 24

 

# ppp mp int vir 1 把接口聚合到虚拟模板1

#ppp mp 

# int s1

ip add 192.168.5.1 24

 

# ppp mp int vir 1

 # ppp mp# 启动ppp的多路捆绑的协商协议

 

 

 ip route 192.168.4.0 24 192.168.6.2

 

 

R2的配置:

# int e1

# ip add 192.168.4.254 24

# quit

 

# int virtual-tem 1  创建虚拟模板接口

# ip add 192.168.6.2 24

# int s0    进入物理口

ip add 192.168.3.2 24

 

# ppp mp int vir 1    把接口聚合到虚拟模板1

# ppp mp

int s1

ip add 192.168.5.2 24

 

# ppp mp int vir 1   把接口聚合到虚拟模板1

 ppp mp 启动ppp的多路捆绑的协商协议

# ip route 192.168.2.0 24 192.168.6.1

 

测试:

2.0网段主机ping4.0网段主机通

 

 

案例三 standby interface
在正常链路的接口上去指明备份接口就行了  (需要配置启用备份接口定时器,默认是立刻切换)

standby  timer enable-delay seconds 设置从主接口切换到备用接口的延时

standby  timer disable-delay seconds  设置从备用接口切换到主接口的延时

 

standby threshold  enable-threshold  disable-threshold负载分担配置

缺省情况下,没有使能接口的备份负载分担功能

 

 

 

 

 
 
R1
# int e1
# ip address 192.168.2.254 24
# int s1
# ip add 192.168.5.1 24
# quit
# ip route 192.168.4.0 24 192.168.3.2
# ip route 192.168.4.0 24 192.168.5.2
 
# int s0
# ip add 192.168.3.1 24
# standby interface s 1 指明备份接口
# standby timer enable-delay 10     设置切换延迟,等待10秒之后切换到备份接口
# standby timer disable-delay 10  设置切换延迟,等待10秒后切回到主接口
###############################
R2
# int s1
# ip add 192.168.5.2 24
# shut
# undoshut
# int e1
# ip add 192.168.4.254 24
# quit
# ip route 192.168.2.0 24 192.168.5.1
# ip route 192.168.2.0 24 192.168.3.1
 # int s0
# ip add 192.168.3.2 24
# shut
# undoshut

# standby interface s 1 指明备份接口
# standby timer enable-delay 10     设置切换延迟,等待10秒之后切换到备份接
# standby timer disable-delay 10  设置切换延迟,等待10秒后切回到主接口
 

测试:

 

 

当断开s0时:先超时然后又通了