仅供菜鸟学习交流用,不足之处,请指出。谢谢!
 
 
实验名称:单臂路由
实验目的:通过路由器进行多个VLAN互联
实验环境:1. 交换机为二层交换机,支持VLAN划分;2. 路由器1个。(在Packet Tracer 5.0 上完成的实验)
 1111
实验配置:
1.配置路由器:
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#no ip address
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface fastEthernet 0/0.1
Router(config-subif)#encapsulation dot1Q 2
Router(config-subif)#ip address 192.168.2.1 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#exit
Router(config)#interface fastEthernet 0/0.2
Router(config-subif)#encapsulation dot1Q 3
Router(config-subif)#ip address 192.168.3.1255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#end
Router#show running-config
2.配置交换机:
Switch>enable
Switch#configure terminal
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config-vlan)#vlan 3
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 3
Switch(config-if)#end
Switch#show running-config
3.配置pc机:
pc1:192.168.2.2 255.255.255.0
网关:192.168.2.1
 
pc2:192.168.3.3 255.255.255.0
网关:192.168.3.1
 
 
实验思考:利用单臂路由的方式实现VLAN间路由,和利用路由接口实现VLAN间路由相比,通过路由子接口的方式利用一个路由接口可以实现多个VLAN间路由,对于路由接口的使用效率更好,而与SVI方式实现VLAN间路由相比,单臂路由方式实现VLAN间路由,在网络中某VLAN设备必须都物理上连接在一个路由子接口上,限制了VLAN网络的灵活部署,同时,由于通过子接口的划分,多个VLAN的大量设备都通过少数的接口进行数据转发,容易在此接口位置形成网络瓶颈